Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

QoS Frame relay fragmentation with the CBWFQ

Dear All,

I configured QoS for remote branches the bandwidth link is 256 so i need to configure frame relay fragmentation but when i configure it under the sub interface the router hang and to solve the problem i should delete the fragmentation to access the router from the same session and CPU was raising to 50%. my question is have i configure the fragmentation at the both sides on one only?

BR,

Mohamed Taher

4 REPLIES

Re: QoS Frame relay fragmentation with the CBWFQ

Hi,

If you have sensitive application such as VOIP, then I recommend to have FRF on both sides implemented , this should have affect on the serialization delay.

Frame-relay fragmentation decreases the delay over the WAN link, however , you shouldnt notice hanging other than higher delay on the opposite direction of the WAN.

HTH

Mohamed

New Member

Re: QoS Frame relay fragmentation with the CBWFQ

Hi Mohamed

     the other side link speed is 2 M so i think i dont need fragmentation. but my main issue is the router hanging i notice also than the number of frame with unexpected b bit is very high do you have what this is meaning?

Thanks,

Mohamed Taher

Re: QoS Frame relay fragmentation with the CBWFQ

Hi Mohamed,

Thats a bad sign.

If the B bit is increasing , then it means the Number of fragments received by this DLCI that have an unexpected B bit set. When this occurs, all fragments being reassembled are dropped and a new frame is begun with this fragment


So the fragmented packets are dropped and it could be causing high delay and application interrupt.

Please post your current FRF config

HTH

Mohamed

New Member

Re: QoS Frame relay fragmentation with the CBWFQ

Hi Mohamed,

Here is the configuration below:

class-map match-all mail
match access-group name mail
class-map match-all update
match access-group name updates
class-map match-all SAP
match access-group name SAP
class-map match-all voice
match access-group name voice
!
!        
policy-map QOS
class voice
  priority percent 30
class update
  bandwidth percent 10
class SAP
  bandwidth percent 40
class mail
  bandwidth percent 15


interface Serial0/0/0
bandwidth 256
no ip address
encapsulation frame-relay IETF
no fair-queue
frame-relay traffic-shaping
frame-relay lmi-type ansi
max-reserved-bandwidth 95
!        
interface Serial0/0/0.1 point-to-point
ip address 172.20.35.62 255.255.255.252
frame-relay class QOS
frame-relay interface-dlci 16

ip access-list extended SAP
permit ip any host 10.1.200.101
permit ip any host 10.1.200.102
permit ip any host 10.1.200.103
permit ip any host 10.1.200.104
permit ip any host 10.1.200.114
permit ip any host 10.1.200.115
ip access-list extended mail
permit ip any host 81.29.101.3
ip access-list extended updates
permit ip any host 10.1.200.10
permit ip any host 10.1.200.11
permit ip any host 10.1.200.12
permit ip any host 10.1.200.13
ip access-list extended voice
permit udp any any range 16384 32767
permit tcp any eq 1720 any
permit tcp any any eq 1720
permit tcp any eq 1970 any
permit tcp any any eq 1970
permit udp any any eq 4569
permit udp any any eq 5036
permit udp any any eq 5060
!        
!        
map-class frame-relay QOS
frame-relay fragment 320
frame-relay traffic-rate 256000 256000
service-policy output QOS

thanks,

Mohamed Taher

418
Views
0
Helpful
4
Replies