Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

QoS help and opinion

I need some help guys. I have a config that I need to know what the dscp marking will be when it leaves the router serial sub interface. Can someone tell me, from the config below, what the packet will be marked as when it leaves? Thanks.

ip access-list extended testvoiceout

permit ip host X.X.X.X any

ip access-list extended testout

deny ip host X.X.X.X any

permit ip any any

class-map match-any testvoiceout

match access-group name testvoiceout

class-map match-any testout

match access-group name testout

policy-map bigtest

class testvoiceout

priority percent 10

set dscp 42

class testout

set dscp 21

policy-map bigtest1

class class-default

shape average 42000000

service-policy bigtest

interface serial1/1.1

service-policy out bigtest1

6 REPLIES
Bronze

Re: QoS help and opinion

Hi,

As far as I can see using your configuration

host X.X.X.X get dscp 42 , and everything else get dscp 21. :)

HTH,

BR,

Bjornarsb

Re: QoS help and opinion

As said above the host x.x.x.x gets DSCP 42 which by default maps to Ip prec 5.

A better way would be to map it to DCSP EF (46). Voice packets are marked with DCSP EF and these packets have a lower drop precedence.

Also you do not require the deny x.x.x.x entry in the second access-list. The class maps are called in the order and hence all the packets from that source matches the first class and would never go to the second class.

HTH, rate if it does

Narayan

Re: QoS help and opinion

Hi there,

You can't use set in a nested policy-map, 'set' command is not supported in a 2nd level policymap, accordingly this configuration won't work and will give you an error.

As a work around mark the traffic when incoming on the LAN interface then do the nested shaping and LLQ on the outgoing serial.

HTH, please do rate all helpful replies,

Mohammed Mahmoud.

New Member

Re: QoS help and opinion

Well, I dont get an error, and all appears to work ok. But, Im being told that coming out of my interface, I am marking at best-effort. I did a show policy int S... and it said I was remarking appropriately. But, ISP said "no, its coming to us as best effort". Im not sure why it was coming as best effort, anyone know?

New Member

Re: QoS help and opinion

hi joseph,

it matters how u apply service policy to interface, here in the config u have applied policy bigtest1,covering bigtest

so packets matching accesslist of testvoiceout will be marked as af42 (high priority than below)

this packets also goes under priority queue -seperate queue

packets matching accesslist of testout will be marked as af21 class

rate it make worth to u

New Member

Re: QoS help and opinion

Yeah, Im just not sure why the ISP says they only saw best effort from my site. I ended up putting the service policy "bigtest" on the main interface, and then he could see the packets marked appropriately. Im not sure why and thats what Im trying to understand. Can you guys shed some light on that?

379
Views
0
Helpful
6
Replies
CreatePlease to create content