Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

QoS Help Needed

I have Ooma (VOIP) at home and I also run CrashPlan (online backup software).  Unfortunately, those two are not the best of friends.  If CrashPlan is running at full speed, my Ooma connection suffers greatly -- I can hear you, but y.u .an't h..r m..   I might as well just use my cell phone.

I am trying to figure out how I can setup QoS (or something/anything) to monitor for Ooma traffic (either traffic from an IP, to an IP, IP and port combination, or a mixture of those) and in response either completely drop or severely limit the traffic for CrashPlan.

I've tried setting up normal QoS to give priority to the Ooma traffic, but it hasn't changed my connection quality.

I have a Cisco 871W running 12.4(15)T3.

Any help is greatly appreciated!

class-map match-any SDM-Transactional-1

match  dscp af21

match  dscp af22

match  dscp af23

class-map match-any SDM-Signaling-1

match  dscp cs3

match  dscp af31

class-map match-any SDM-Routing-1

match  dscp cs6

class-map match-any SDM-Voice-1

match  dscp ef

match access-group 5

match access-group 150

class-map match-any SDM-Management-1

match  dscp cs2

!

!

policy-map SDM-QoS-Policy-1

class SDM-Voice-1

  priority percent 33

  set dscp ef

class SDM-Signaling-1

  bandwidth percent 5

class SDM-Routing-1

  bandwidth percent 5

class SDM-Management-1

  bandwidth percent 5

class SDM-Transactional-1

  bandwidth percent 5

class class-default

  fair-queue

  random-detect

!
~~~~
!

interface FastEthernet4

description Connection to Internet$ETH-WAN$$FW_OUTSIDE$

ip dhcp client update dns server none

ip address dhcp client-id FastEthernet4

no ip redirects

no ip unreachables

no ip proxy-arp

ip accounting output-packets

ip nat outside

ip ips sdm_ips_rule in

ip virtual-reassembly

ip route-cache flow

duplex auto

speed auto

service-policy output SDM-QoS-Policy-1

!
~~~~
!

access-list 5 remark Access group for SDM-Voice-1

access-list 5 permit 172.16.0.16

access-list 150 remark Access group for SDM-Voice-1

access-list 150 permit ip any host 172.16.0.16

access-list 150 permit ip host 172.16.0.16 any

10 REPLIES
Super Bronze

QoS Help Needed

Disclaimer

The      Author of this posting offers the information contained within this      posting without consideration and with the reader's understanding   that    there's no implied or expressed suitability or fitness for any    purpose.   Information provided is for informational purposes only  and   should not   be construed as rendering professional advice of any  kind.   Usage of  this  posting's information is solely at reader's own  risk.

Liability Disclaimer

In      no event shall Author be liable for any damages whatsoever    (including,   without limitation, damages for loss of use, data or    profit) arising  out  of the use or inability to use the posting's    information even if  Author  has been advised of the possibility of   such  damage.

Posting

What kind of connection is this?  What's the available (actual) outbound bandwidth?

Do you know any of the particulars for either/both your VoIP and backup traffic?

Community Member

QoS Help Needed

Hi Joseph, I'm using AT&T U-verse.  12Mbps down, 1.5Mbps up.  Fa4 is a 10Mbps connection to the AT&T U-verse gateway.

I don't have the particulars on the ports used by either, but it's easy enough to get them.  I can do that if you'd like, otherwise you can just use whatever and I can find/replace.

Super Bronze

QoS Help Needed

Disclaimer

The       Author of this posting offers the information contained within  this      posting without consideration and with the reader's  understanding   that    there's no implied or expressed suitability or  fitness for any    purpose.   Information provided is for informational  purposes only  and   should not   be construed as rendering professional  advice of any  kind.   Usage of  this  posting's information is solely  at reader's own  risk.

Liability Disclaimer

In       no event shall Author be liable for any damages whatsoever     (including,   without limitation, damages for loss of use, data or     profit) arising  out  of the use or inability to use the posting's     information even if  Author  has been advised of the possibility of    such  damage.

Posting

Try for a first go:

policy-map CBWFQ

class-default

fair-queue

shape 1400000

interface FastEthernet4

service-policy output CBWFQ

Community Member

QoS Help Needed

It didn't like "shape 1400000"

Hossy_Router_871W(config-pmap-c)#shape 1400000

                                       ^

% Invalid input detected at '^' marker.

Hossy_Router_871W(config-pmap-c)#shape ?

  adaptive        Enable Traffic Shaping adaptation to BECN

  average         configure token bucket: CIR (bps) [Bc (bits) [Be (bits)]],

                  send out Bc only per interval

  fecn-adapt      Enable Traffic Shaping reflection of FECN as BECN

  fr-voice-adapt  Enable rate adjustment depending on voice presence

  max-buffers     Set Maximum Buffer Limit

  peak            configure token bucket: CIR (bps) [Bc (bits) [Be (bits)]],

                  send out Bc+Be per interval

Hossy_Router_871W(config-pmap-c)#shape

QoS Help Needed

The command is: shape average xxxxx

Hope this help

Community Member

QoS Help Needed

That didn't seem to make a difference.  Still very choppy audio.

QoS Help Needed

are there any errors on the interface. choppy calls and bad quality etc can not only be caused due to congestion etc but latency , packet loss, errors in the interface etc.

Super Bronze

Re: QoS Help Needed

Disclaimer

The       Author of this posting offers the information contained within  this      posting without consideration and with the reader's  understanding   that    there's no implied or expressed suitability or  fitness for any    purpose.   Information provided is for informational  purposes only  and   should not   be construed as rendering professional  advice of any  kind.   Usage of  this  posting's information is solely  at reader's own  risk.

Liability Disclaimer

In       no event shall Author be liable for any damages whatsoever     (including,   without limitation, damages for loss of use, data or     profit) arising  out  of the use or inability to use the posting's     information even if  Author  has been advised of the possibility of    such  damage.

Posting

Okay there are at least 4 reasons why it didn't help.

  1. Shaping value is too high
  2. Need to reduce tx-ring-limit
  3. We need to further prioritize VoIP and/or deproritize your backup application
  4. There also inbound (transient) congestion

For #1 try:

Shape average 1000000 (if this works we can experiment by slowly/incrementally making it larger)

For #2 try:

interface FastEthernet4

tx-ring-limit 2

For #3 try:

class-map match VoIP

match ??? (here we need to identify your VoIP traffic)

class-map match Backup

match ??? (here we need to identify your backup traffic)

policy-map CBWFQ_Shape

class-default

shape average 1000000 (we can adjust value later)

service-policy CBWFQ

policy-map CBWFQ

class VoIP

priority percent 30

class Backup

bandwidth percent 1

class class-default

fair-queue

interface FastEthernet4

service-policy output CBWFQ_Shape

For #4:

Verify difficult to deal with or mitigate - hopefully something above cures your problem

Community Member

QoS Help Needed

Hi Joseph.  Thanks again for your replies.  I am going through and testing your options.  Unfortunately, I cannot currently reproduce the failure so any tests for success are impossible at the moment.  I will continue to try and update this thread as results become available.

Based on the reading I've done thus far, it seems that tx-ring-limit may do the trick, especially with my original QoS policy.

I will keep you updated and thanks again!

Community Member

QoS Help Needed

Just an update: I am still unable to reproduce the problem, so I don't know if it's resolved or I'm just lucky right now.

From my original configuration (using the SDM-QoS-Policy-1), I've only added the tx-ring-limit 2 setting to Fa4.  'show run' shows that two settings were added:

tx-ring-limit 2

tx-queue-limit 2

I will keep attempting to reproduce the problem, but hopefully this solved my issue.  I think I might remove these options at some point to verify the problem still exists and re-add them to confirm this is the actual fix.

1044
Views
0
Helpful
10
Replies
CreatePlease to create content