Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

QoS Help

Im trying to prioritise by allowing 70Kbps of bandwidth to a particular connection on a frame relay connectivity. This is what I did

step 1

------

Configure the following ACL:

access-list 100 permit tcp 10.x.x.0 0.0.0.255 host x.x.x.x eq www precedence critical

where 10.x.x.0 is the network address of the source network and x.x.x.x is the host IP of destination

Step 2

------

Configure the class-map to use ACL 100(above ACL in step 1) and configure policy-map to prioritise 70Kbps of bandwidth to the class-map:

class-map fmis-traffic

match access-group 100

!

!

policy-map fmis-policy

class fmis-traffic

priority 70

Step 3

------

This command is then applied on the serial interface (couldnt apply it on the sub-interface) to activate the above policy-map:

"service-policy output fmis-policy"

can someone check this out whether this is the right approach or not and if you think of something better please let me know.

Thank you

7 REPLIES

Re: QoS Help

Hi

The 3 step process is correct but since you are matching the traffic destined to the server with precdence as critical ,how are you marking the traffic as critical and how do u differentiate the traffic destined to the server as critical and non critical.

I feel you have got some application on that server which you want to access over the WAN.

Then i feel simple ACL matching the source network(ur local lan) and the destination server ip is enough to be precise u can use the TCP option to define the port as you have already done ..

regds

Silver

Re: QoS Help

The QoS config for a FR sub interface ( or for any logical interface) is different.This is a good link to get you started

http://www.cisco.com/en/US/products/sw/iosswrel/ps1839/products_feature_guide09186a0080110bc6.html

New Member

Re: QoS Help

Thank you very much for all the information. I have done the following:

step 1

------

Configure the following ACL:

access-list 100 permit tcp 10.1.104.0 0.0.0.255 host 10.1.85.149 eq www

access-list 100 permit ip 10.1.104.0 0.0.0.255 host 10.1.85.149 precedence critical

Step 2

------

Configure the class-map to use ACL 100(above ACL in step 1) and configure policy-map to prioritise 70Kbps of bandwidth to the class-map:

class-map fmis-traffic

match access-group 100

!

!

policy-map fmis-policy

class fmis-traffic

priority 64

Step 3

------

This command is then applied on the sub-interface:

frame-relay interface-dlci 16

class fmis-policy

This config automatically appears:

map-class frame-relay fmis-policy

no frame-relay adaptive-shaping

Can you please advice me on this config and also how do I check that it is working. I just run the "show access-list" to see whether there is any match or any other command ?

Silver

Re: QoS Help

class-map fmis-traffic

match access-group 100

!

!

policy-map temp

class fmis-traffic

priority 64000

policy-map shape

class class-default

shape average 192000

service-policy temp

!

!

interface Serial2/0:0

no ip address

encapsulation frame-relay

load-interval 30

frame-relay lmi-type ansi

!

!

interface Serial2/0:0.598 point-to-point

description test connection

ip address 10.10.100.1 255.255.255.252

frame-relay interface-dlci 598

load-interval 30

!

!

map-class frame-relay shape

service-policy output shape

Under the frame-relay DLCI 598 apply the map-class

This should be the configuration. Pls apply this and check if it works

New Member

Re: QoS Help

Thank you attrgautam

Just a question on this. Why do I have to configure the "shape average 192000" on the second policy map ?. I have a frame relay with 128K Access and 64K PVC and I want the traffic to use the whole PVC-64K when there is traffic between 10.1.104.0/24 to 10.1.85.149 on port 80.

I have tried this and when I do a "show access-list" there is no match. I then apply this command to the serial interface(not sub interface):

"service-policy output fmis-policy" I didnt use "temp" but use "fmis-policy" as the name of the first policy map

Then I manage to see the ACL counters for the first ACL.Didnt see

Silver

Re: QoS Help

You will need to shape to 192K (or whatever is your link bandwidth) on logical interfaces(like sub interfaces/FR PVC/GRE Tunnels).

Apply the parent policy(not child policy) on the FR DLCI not main interface.

New Member

Re: QoS Help

Thank you very much. I have solve the problem using your solution. I was also having problem because of the old IOS version on the remote router which I beleive doesnt support QoS. That is the reason why I couldnt apply the "service policy output" command on the map-class.

Thank you once againa

138
Views
5
Helpful
7
Replies
CreatePlease to create content