Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Qos implentation

I have got cisco 1700 series router with 1 mbps link. i want to split this bandwidth as 512 for voice and 512 for data..how can this be done..please

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Qos implentation

Hi,

The simple example for LLQ if you are using SIP would be (guaranteeing the 512K for voice, while data can use the whole 1M if no voice traffic):

!

class-map match-all voice

match access-group 101

!

!

policy-map voice

class voice

priority 512

class class-default

fair-queue

!

interface Serial1/0.1 point-to-point

service-policy output voice

!

access-list 101 remark ###RTP ports

access-list 101 permit udp any any range 16384 32767

access-list 101 remark ###

access-list 101 remark ###SIP signalling

access-list 101 permit tcp any any eq 5060

access-list 101 permit tcp any eq 5060 any

access-list 101 permit udp any any eq 5060

access-list 101 permit udp any eq 5060 any

access-list 101 remark ###

But you must make sure to implement this configuration on both sides of the leased line, to affect both traffic directions.

HTH,

Mohammed Mahmoud.

11 REPLIES
Community Member

Re: Qos implentation

You should first let us know if you are also going to mark your voice and data traffic. if yes, what are the marking values you are going to use...only then can we provide you a sample config...

- Manoj

Re: Qos implentation

Hi chenthi

What is the codec you are using?

How many calls you want to let them go through the router over wan(may be)?

What is your link speed?

I'm not sure bandwith 512 for your voice traffics may or may not enough in your case.

F.e. I use a G729r8codec for my voice packets. I need 4 calls going through the router over wan to my branch.So I need approx 100Kbps(25kbps x 4) for my case.

##

class-map match-all VoicePayload

match protocol rtp

class-map match-all CriticalApp

match access-group name ACLForAPP

##

policy-map VoiceGoFirst

class VoicePayload

priority 100

set dscp 5

class CriticalApp

bandwidth 512

class class-default

fair-queue

##

int s0/1/1

service-policy output VoiceGoFirst

##

Be aware when you implement the software queuing in my configuration is LLQ. If your link isn't congestion(HWQueue is full) then the LLQ won't be used. Keep in mind In priority queue class inherits police mechanism so if your voice traffics exceed the bandwidth in priority queue that you defined then will be dropped.

Hope this helps

Thot

Re: Qos implentation

Friend,

What type of link is this and to which module is this terminated?

If its a VWIC module you can create 2 channel groups and create a seperate pipe itself for voice and the other for data.

if this is not feasible in your network design, then you would require to do this with the help of QoS as suggested above.

Use LLQ and assign a bandwidth of 512 for voice traffic.

HTH, rate if it does

Narayan

Re: Qos implentation

Hi,

I actually agree with Narayan, as having 2 pipes as your first option might be the simplest solution, with no QoS configuration and no hassles with your Provider to do the same for the return traffic, your second option is to simply do LLQ for your voice as stated above.

HTH,

Mohammed Mahmoud.

Hall of Fame Super Gold

Re: Qos implentation

I don't agree that the "two pipes" design is a good solution, because:

1. Limited to specific network topologies, like channel-group, or pvc that not everyone have.

2. harder to configure. Will necessitate specialized routing or policy-based.

3. Non-standard. Go ask any ISP to do such a special config for you and check reactions.

4. Inherently inefficient. When there are few voice calls, all the remaining bandwidth is wasted.

So I would recommend always to configure QoS that is LLQ for voice and that's it.

Re: Qos implentation

Hi Paolo,

I agree with you in a way and disagree in another way, its not a rule it depends on the situation:

1.In most cases the customers are having PVCs, and can have 2 separate PVCs.

2.Static routes can do it with no PBR, all you need is static routes for Voice subnets and other static routes for data subnets (actually i've a couple of clients with this setup).

3.I agree that its a non-standard, but many SPs can do it, in order not to do QoS configuration on their side (if its MPLS VPN for example), or ask the customer to replace his router to have a router supporting QoS or even a router that can handle QoS.

4.Agree with you on this one, but some customers don't care, as long as everything is working fine (the voice PVC can be a 64K PVC, according to the customer call needs).

So. i'll say that it depends.

BR,

Mohammed Mahmoud.

Re: Qos implentation

I totally agree with Mohammed

we have some clients who particularly wanted this king of setup.

Narayan

Community Member

Re: Qos implentation

Hai,

As i have explained earlier that i want to divide the bandiwidth. Leased line e1 circuit and bandwidth opted by customer is 1 mb.They have to divide the bandwidth as two ie

1. voice = 512

2. data = 512

The reason behind splitting is to have Good quality in Voice with out breakage bz DATA side is using most of the bandwidth.

I require commands to implement.. if any one can help me out ..Thank you

Regards

A.ChenthilKumar

Re: Qos implentation

Hi,

The simple example for LLQ if you are using SIP would be (guaranteeing the 512K for voice, while data can use the whole 1M if no voice traffic):

!

class-map match-all voice

match access-group 101

!

!

policy-map voice

class voice

priority 512

class class-default

fair-queue

!

interface Serial1/0.1 point-to-point

service-policy output voice

!

access-list 101 remark ###RTP ports

access-list 101 permit udp any any range 16384 32767

access-list 101 remark ###

access-list 101 remark ###SIP signalling

access-list 101 permit tcp any any eq 5060

access-list 101 permit tcp any eq 5060 any

access-list 101 permit udp any any eq 5060

access-list 101 permit udp any eq 5060 any

access-list 101 remark ###

But you must make sure to implement this configuration on both sides of the leased line, to affect both traffic directions.

HTH,

Mohammed Mahmoud.

Community Member

Re: Qos implentation

dear Mohammed,

I got you explanation.let me implement in customer router and check . Your explanation seems to work out..

Regards

A.ChenthilKumar

Community Member

Re: Qos implentation

Dear Thot,

Thank You for your explanation.

I will try first in Router impl class-map and will be back with you plz

Regards

A.ChenthilKumar

270
Views
0
Helpful
11
Replies
CreatePlease to create content