Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

QOS in 3560

I am facing an issue with QOS in 3560 switch, we are doing the QOS in ingress mode. We are setting the total bandwidth 5MB.Please find below script which we are following.

pa5-rn-mf-idf1-c1#sh version

"flash:/c3560-ipbase-mz.122-44.SE2.bin"

pa5-rn-mf-idf1-c1#sh mls qos

QoS is enabled

QoS ip packet dscp rewrite is enabled

pa5-rn-mf-idf1-c1#

class-map match-all video

match access-group name video

!

policy-map ingress-cctv

class video

set precedence 4

police 5000000 375000 exceed-action drop

!

interface FastEthernet0/1

description ***Connected to CCTV***

switchport access vlan 200

switchport mode access

spanning-tree portfast

spanning-tree bpduguard enable

service-policy input ingress-cctv

!

interface GigabitEthernet0/1 //Uplink ports to distribution switch

description Link to porto5-dist1 Gig1/1

switchport trunk encapsulation dot1q

switchport trunk native vlan 999

switchport trunk allowed vlan 17,200

switchport mode trunk

udld port aggressive

spanning-tree guard loop

ip access-list extended video //Access list for matching the IP traffic

permit ip 10.160.0.0 0.0.255.255 239.160.0.0 0.0.255.255

Switch Output shown after the QOS settings.

pa5-th-gf-idf1-c1#sh mls qos interface fastEthernet 0/1 statistics

FastEthernet0/1 (All statistics are in packets)

dscp: incoming

-------------------------------

0 - 4 : 262168080 0 0 0 0

5 - 9 : 0 0 0 0 0

10 - 14 : 0 0 0 0 0

15 - 19 : 0 0 0 0 0

20 - 24 : 0 0 0 0 0

25 - 29 : 0 0 0 0 0

30 - 34 : 0 0 0 0 0

35 - 39 : 0 0 0 0 0

40 - 44 : 0 0 0 0 0

45 - 49 : 0 0 0 0 0

50 - 54 : 0 0 0 0 0

55 - 59 : 0 0 0 0 0

60 - 64 : 0 0 0 0

dscp: outgoing

-------------------------------

0 - 4 : 2755773 0 0 0 0

5 - 9 : 0 0 0 0 0

10 - 14 : 0 0 0 0 0

15 - 19 : 0 0 0 0 0

20 - 24 : 0 0 0 0 0

25 - 29 : 0 0 0 0 0

30 - 34 : 0 0 0 0 0

35 - 39 : 0 0 0 0 0

40 - 44 : 0 0 0 0 0

45 - 49 : 0 0 0 13727 0

50 - 54 : 0 0 0 0 0

55 - 59 : 0 0 0 0 0

60 - 64 : 0 0 0 0

cos: incoming

-------------------------------

0 - 4 : 262168184 0 0 0 0

5 - 7 : 0 0 0

cos: outgoing

-------------------------------

0 - 4 : 6234152 0 0 0 0

5 - 7 : 0 772565 0

Policer: Inprofile: 171538294 OutofProfile: 1

Can you confirm me how we can confirm the QOS is working fine ?? policy map doesn't show anything.

1 ACCEPTED SOLUTION

Accepted Solutions

Re: QOS in 3560

hi there

exactly as Giuseppe suggested, you have to check it on the other end of the switch

lets say you connected a router to other end

creat a class map as bellow

class-map map1

match precedence 4

policy-map p1

class map1

on the router interface connected to the 3560

int fa

service-policy p1 intput

now do show policy-map int fa

you have to see traffic mcoming under map1

and you have to see the max linit as your policed traffic limit

if any of the above not shown you need to check your switch config

good luck

HTH

4 REPLIES
Hall of Fame Super Silver

Re: QOS in 3560

Hello Saij,

you should look at the other end of the uplink switch to see if there are incoming frames with a DSCP compatible with IP precedence 4.

setting a specific DSCP value could make easier to check.

see

http://www.cisco.com/en/US/partner/docs/switches/lan/catalyst3560/software/release/12.2_44_se/configuration/guide/swqos.html#wp1322872

or

http://www.cisco.com/en/US/docs/switches/lan/catalyst3560/software/release/12.2_44_se/configuration/guide/swqos.html#wp1322872

Hope to help

Giuseppe

Re: QOS in 3560

hi there

exactly as Giuseppe suggested, you have to check it on the other end of the switch

lets say you connected a router to other end

creat a class map as bellow

class-map map1

match precedence 4

policy-map p1

class map1

on the router interface connected to the 3560

int fa

service-policy p1 intput

now do show policy-map int fa

you have to see traffic mcoming under map1

and you have to see the max linit as your policed traffic limit

if any of the above not shown you need to check your switch config

good luck

HTH

New Member

Re: QOS in 3560

Thanks for the quick response,I will check the same and update..

Super Bronze

Re: QOS in 3560

If the traffic you're marking flows out g0/1, its stats should show the marked packets.

As to policing, I think, "Policer: Inprofile: 171538294 OutofProfile: 1 ", (shown for f0/1), indicates the policer results.

[edit]

PS:

re: Giuseppe's

"setting a specific DSCP value could make easier to check"

It's likely you'll see your IP Prec 4 as DSCP CS4 marked packets, but Giuseppe is correct that setting IP Prec 4, you could have any or 8 DSCP values. If you want to avoid this possiblity mark as CS4.

464
Views
0
Helpful
4
Replies
CreatePlease to create content