Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

QOS Monitoring/Configuration

Hello,

We have 2 x C3662 running 12.2.40 and 2 x C3845 running 12.3.11T8. What options do I have for monitoring and or configuring QOS on these devices. I have created some class-maps & a policy-map but not sure if these are correct or even working !!.

Regards

Scott

3 REPLIES
Silver

Re: QOS Monitoring/Configuration

Hi,

could you post here your goals and confs?

Thanks

Andrea

New Member

Re: QOS Monitoring/Configuration

Hi,

We have two offices seperated by to 10Mb LES links we run a pure VOIP environment and need to ensure that voice traffic is kept optimised across these links.

class-map match-any L3L2-VoiceRTP

match ip precedence 1

match access-group name VoiceRTP

class-map match-any L3L2-VoiceControl

match ip precedence 2

match access-group name VoiceControl

!

!

policy-map QoS-POLICY-10MB

class L3L2-VoiceRTP

priority 1888

class L3L2-VoiceControl

priority 768

policy-map Shape-POLICY

class class-default

shape average 10240000 2560000

service-policy QoS-POLICY-10MB

interface FastEthernet0/1

ip address xxx.xxx.xxx.xxx 255.255.255.252

ip nbar protocol-discovery

service-policy output Shape-POLICY

ip route-cache flow

speed 100

full-duplex

Re: QOS Monitoring/Configuration

VoiP packets are genrally marked as IP prcedence 5 or DSCP EF

Control traffic is marked as CS3

Please have the class-maps configured as follows

class-map match-any L3L2-VoiceRTP

match ip precedence 5 or match ip dscp EF

match access-group name VoiceRTP

class-map match-any L3L2-VoiceControl

match ip precedence 3 or match ip dscp cs3

match access-group name VoiceControl

ip access-list extended VoiceRTP

permit udp any any eq 16384 32767

you can also use match ip rtp 16384 16383

I have also found you using NBAR which drives to define the classmaps using the match protocol command

"match protocol rtp "

This is CPU intensive and hence better to be cautious before configuring it

HTH, rate if it does

Narayan

102
Views
0
Helpful
3
Replies