Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

QoS not working with Oracle traffic

Dear Support,

I’ve got a problem with my QoS, since we moved our Oracle 9i server to the data centre where our internet connection is presented. A large download from the internet stops traffic getting to the Oracle server.

We have two 2621XM routers that link between the sites over a LES 10 circuit, and have applied QoS configuration to support LLQ of 55% on them. I have tried using different methods of matching, i.e. via access-lists to identify source/destination address, source/destination port, NBAR, etc.

As we use the standard Oracle listening port (1521), I’ve just kept it simple and using the match protocol sqlnet to identify traffic.

I have noticed that the traffic is fairly minimal to the server, the login and selecting the databases to open is only a few packets. The actual opening of the database is a couple thousand packets.

The problem seems to happen when opening the database if a large download from the internet is happening at the same time. Rather than the database being displayed after round 20 seconds it just sits there for over 2 minutes, at this time we terminate the internet download to avoid causing users problems.

The policy map seems to indicate that QoS is operating as expected, i.e. there are packets in the default class being tail dropped and it is matching the Oracle traffic.

Can someone help me out as I have other QoS configurations on different sites that work perfectly.

In summary the config is;

class-map match-any MISSION-CRITICAL-DATA

match protocol sqlnet

policy-map BRANCH-WAN-EDGE

class MISSION-CRITICAL-DATA

priority percent 55

set dscp af31

policy-map Shaper

class class-default

shape average 10000000

service-policy BRANCH-WAN-EDGE

!

interface FastEthernet0/0

service-policy output Shaper

HQ=192.168.1.x/24

LES 10= 172.16.10.0/30

DC=10.17.1.x/24

Please find attached router config extracts and copy of the debug (sorry time between routers wasn’t correct, when test was done)

Thanks for your assistance.

Regards, Adrian

5 REPLIES
Purple

Re: QoS not working with Oracle traffic

Out of curiosity, on the MISSION-CRITICAL-SERVERS AClL, why have you specified the port (1521) as the destination port. If the servers are located at the GQ site, the port should be the source port. In that case, you can use the ACL as your class-map match criteria.

Paresh

New Member

Re: QoS not working with Oracle traffic

Hi Paresh,

Many thanks for you response, I have tried doing the matching with various ACLs (Extended / Standard, etc) but same sort of problem.

We have done some more testing and it seems a bit inconclusive.

If we start Oracle first and then start a download (650mb), Oracle seems to take priority and opens in about 20-25 secs, however the huge download estimates to finish in about 10-14 hrs.

If we start the download first and then Oracle, it seems that the download takes priority and estimates to complete in 10 mins, where as Oracle still does not open until the download is cancelled.

However - I tested Oracle with a smaller download of 5mb and it seems that Oracle is not affected by a download this size.

Regards, Adrian

Purple

Re: QoS not working with Oracle traffic

Hi,

The ACL matching with class-maps is pretty reliable. I suggest that you use a sniffer like Ethereal on the LAN segment where your server is and try and see the actual port numbers used by it. Then, you can have an ACL that more accurately matches the server traffic.

Paresh

New Member

Re: QoS not working with Oracle traffic

Do you see any packets matching the sqlnet class?

sh policy-map int x/y

If not try what Paresh has suggested to use ACLs. As a test to start with (until you are sure you are using the right port), just match on the server ip address only.

Rgds

E.

New Member

Re: QoS not working with Oracle traffic

Dear All,

Many thanks for you assistance, I have now modified the policy map to match via an ACL using either source/destination address. (after examining the listener.ora file it was determined the box could listen on both the default 1521 & 1526).Also I changed the QoS from LLQ (priority percent 55) to 'Bandwidth 80 percent' this seems to bring up the Oracle database, but can't check thoroughly until later today.

I will let you all know if this resolves my issue.

Thanks again.

Regards, Adrian.

585
Views
8
Helpful
5
Replies
CreatePlease login to create content