Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

QOS of EOMPLS help needed

Hi All Members,

 


I am having problem in applying the qos in ethernet over mpls(EOMPLS).


CE1(2811 router)------->PE1(2811 router)----------->P(3750 switch)--------->PE2(2811 cisco router)-------->CE2(2811 cisco router)


If i am using the above senario on eompls qos. i can mark and match all cos5 and exp5 on all ce1,pe1,pe2 and ce2. all things worked fine.


CE1(2811 router)------->PE1(2811 router)----------->P(3750 switch)--------->PE2(6523 or 7203 L3 switch)-------->CE2(2811 cisco router)


when i am using (cisco 6523  or 6503 or 7203 l3 switch) as PE2 instead of 2811, problems started here. i didn't see any markings or matching of qos on 6503 l3 switch. Is there anything i am missing on l3 switch for qos. 

I will really thankful for suggestions & solutions on this issue.

I have also enabled mls qos globally on l3 6503 switch as PE2. i have checked with mls qos trust cos on incoming interface on 6503 switch but nothing changes. Any more configuration needed on l3switch. why its not matching and marking. 

Below are the configs and output with the first scenario.
------------------------------------------------


CE1 CONFIG:

class-map match-any EF
 match ip precedence 5
!
!
policy-map foo
 class EF
  set cos 5
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/1
 mtu 1546
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/1.50
 encapsulation dot1Q 50
 ip address 172.16.15.1 255.255.255.0
 service-policy output foo
!
----------------------------------------------------
PE1 CONFIG:

class-map match-all QOS_G_5
 match qos-group 5
class-map match-any LOO1
 match cos  5
!
!
policy-map EF
 class LOO1
  set qos-group 5
policy-map QOS_G_5
 class QOS_G_5
  set mpls experimental topmost 5
!
interface GigabitEthernet0/0
 description to-P
 mtu 1546
 ip address 192.168.23.2 255.255.255.0
 ip ospf network point-to-point
 duplex auto
 speed auto
 mpls ip
 service-policy output QOS_G_5
!
interface GigabitEthernet0/1.50
 encapsulation dot1Q 50
 xconnect 67.217.136.1 50 encapsulation mpls
 service-policy input EF
!
--------------------------------------------------------
On P(3750):

no qos configuration used.
--------------------------------------------------------
PE2 CONFIG:(2811)


class-map match-all EXP_5
 match mpls experimental topmost 5
class-map match-all QOS_GROUP_5
 match qos-group 5
!
policy-map mpls2ip
 class QOS_GROUP_5
policy-map IN_FROM_R3
 class EXP_5
!
interface GigabitEthernet0/0
 description to-P
 mtu 1546
 ip address 192.168.34.5 255.255.255.0
 ip ospf network point-to-point
 duplex auto
 speed auto
 mpls ip
 service-policy input IN_FROM_R3
!
interface GigabitEthernet0/1.50
 encapsulation dot1Q 50
 xconnect 3.3.3.3 50 encapsulation mpls
 service-policy output mpls2ip
!
---------------------------------------------------

CE2 config:

!
class-map match-all cos5
 match cos  5
!
policy-map foo
 class cos5
!
interface FastEthernet0/1.50
 encapsulation dot1Q 50
 ip address 172.16.15.2 255.255.255.0
 service-policy input foo
!
------------------------------
------------------------------
------------------------------

 

OUTPUT :

 


PE1#show mpls l2transport vc

Local intf     Local circuit              Dest address    VC ID      Status
-------------  -------------------------- --------------- ---------- ----------
Gi0/1.50       Eth VLAN 50                5.5.5.5         50         UP

PE2#show mpls l2transport vc

Local intf     Local circuit              Dest address    VC ID      Status
-------------  -------------------------- --------------- ---------- ----------
Gi0/1.50       Eth VLAN 50                3.3.3.3         50         UP


-------------------------------------------------------------------
CE1#show policy-map interface
FastEthernet0/1.50

  Service-policy output: foo

    Class-map: EF (match-any)
      5 packets, 500 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: ip precedence 5
        5 packets, 500 bytes
        5 minute rate 0 bps
      QoS Set
        cos 5
          Packets marked 5

    Class-map: class-default (match-any)
      11 packets, 1064 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: any
--------------------------------------------------------------


PE1#show policy-map interface
GigabitEthernet0/0

  Service-policy output: QOS_G_5

    Class-map: QOS_G_5 (match-all)
      5 packets, 202110 bytes
      5 minute offered rate 2000 bps, drop rate 0 bps
      Match: qos-group 5
      QoS Set
        mpls experimental topmost 5
          Packets marked 5

    Class-map: class-default (match-any)
      78 packets, 232800 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: any
GigabitEthernet0/1.50

  Service-policy input: EF

    Class-map: LOO1 (match-any)
      5 packets, 590 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: cos  5
        5 packets, 590 bytes
        5 minute rate 0 bps
      QoS Set
        qos-group 5
          Packets marked 5

    Class-map: class-default (match-any)
      5 packets, 536 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: any
PE1#
-------------------------------------------------------------------
PE2#show policy-map interface
GigabitEthernet0/0

  Service-policy input: IN_FROM_R3

    Class-map: EXP_5 (match-all)
      5 packets, 680 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: mpls experimental topmost 5
      QoS Set
        qos-group 5
          Packets marked 5

    Class-map: class-default (match-any)
      148 packets, 11762 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: any
GigabitEthernet0/1.50

  Service-policy output: mpls2ip

    Class-map: QOS_GROUP_5 (match-all)
      5 packets, 202630 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: qos-group 5
------------------------------------------------------------------
CE2#show policy-map interface
FastEthernet0/1.50

  Service-policy input: foo

    Class-map: cos5 (match-all)
      5 packets, 590 bytes
      5 minute offered rate 0 bps
      Match: cos  5

    Class-map: class-default (match-any)
      4 packets, 472 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: any
CE2#
-----------------------------------------------------------------------
PE2 output with 6503(no matching)  

Service-policy input: IN_FROM_R3

    Class-map: EXP_5 (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: mpls experimental topmost 5
      QoS Set
        qos-group 5
          Packets marked 0

    Class-map: class-default (match-any)
      148 packets, 11762 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: any
GigabitEthernet0/1.50

  Service-policy output: mpls2ip

    Class-map: QOS_GROUP_5 (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: qos-group 5
---------------------------------------------------------------------------------------------------------------------------
---------------------------------------------------------------------------------------------------------------------------

 


Thanks & Regards,
Ahsan Rasheed

1 REPLY
New Member

Any one who worked on layer 3

Any one who worked on layer 3 switch qos?

Specifically on layer 3 switch 6500 qos?

on layer 3 switch 6500 , mls qos need to enable globally?mls qos trust cos need to enable globally?layer 3 6500 switch is marking and matching cos 5 traffic to default?why

although on 2821 or 2811 routers above configurations are working fine of qos but not on 6500.

126
Views
0
Helpful
1
Replies
CreatePlease login to create content