cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
838
Views
0
Helpful
8
Replies

QoS on 1841 router with ADSL interface

msafargaleev
Level 1
Level 1

Hi,

I'm trying to set up QoS on ADSL interface.

Below is part of configuration:

class-map match-all voip

match access-group name qos

!

!

policy-map marking

class voip

priority 120

set ip dscp ef

policy-map test

class class-default

shape average 1000000

service-policy marking

interface ATM0/0/0.1 point-to-point

description WAN

ip address 10.1.163.129 255.255.255.252

pvc 0/34

encapsulation aal5snap

service-policy output test

However, i see nothing in show policy-map interface ATM0/0/0.1 command.

IOS version 12.4-6.T5 advanced security. Why this happen? Thanks in advance.

8 Replies 8

mheusinger
Level 10
Level 10

Hello,

Are there any other interfaces involved, like Dialer or virtual template? Can you post the complete router config?

Regards, Martin

lgijssel
Level 9
Level 9

First step will be to determine whether you are receiving packets that match the policy map. What does your access-list qos look like? Can you see that it matches packets?

Use "sh access-list" to verify this.

Please find some config tipsin the link below:

http://www.cisco.com/en/US/products/ps6350/products_configuration_guide_chapter09186a0080455b04.html

Regards,

Leo

Thanks for replay.

This is complete configuration:

Current configuration : 6491 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec localtime show-timezone

service timestamps log datetime msec localtime show-timezone

service password-encryption

service sequence-numbers

!

!

boot-start-marker

boot system flash c1841-advsecurityk9-mz.124-6.T5.bin

boot-end-marker

!

security authentication failure rate 3 log

security passwords min-length 6

logging buffered 51200 debugging

logging console critical

!

no aaa new-model

!

resource policy

!

no ip source-route

ip cef

!

!

!

!

no ip domain lookup

!

ip ssh time-out 60

ip ssh authentication-retries 2

!

!

!

!

class-map match-all voip

match access-group name qos

!

!

policy-map marking

class voip

priority 120

set ip dscp ef

policy-map test

class class-default

shape average 1000000

service-policy marking

!

!

interface FastEthernet0/0

description LAN

ip address 192.168.162.254 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip route-cache flow

duplex auto

speed auto

no mop enabled

!

interface FastEthernet0/1

no ip redirects

no ip unreachables

no ip proxy-arp

ip route-cache flow

duplex auto

speed auto

no mop enabled

!

interface ATM0/0/0

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0/0/0.1 point-to-point

ip address 10.1.163.193 255.255.255.252

no snmp trap link-status

pvc 8/35

encapsulation aal5snap

service-policy output test

!

!

ip route 0.0.0.0 0.0.0.0 ATM0/0/0.1

!

!

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

ip access-list extended qos

permit ip host 192.168.162.6 host 192.169.163.163

!

!

!

!

!

control-plane

!

line con 0

logging synchronous

login local

transport output telnet

line aux 0

login local

transport output telnet

line vty 0 4

privilege level 15

login local

transport input telnet ssh

line vty 5 15

privilege level 15

login local

transport input telnet ssh

!

scheduler allocate 20000 1000

!

!

end

Leo, i don't think that this is related to access-list because when i put service-policy test oh fastethernet 0/0 interface (this interface not used in my scenario and in "down" state) i see command output

sho policy-map interface fastEthernet 0/1

FastEthernet0/1

Service-policy output: test

Class-map: class-default (match-any)

0 packets, 0 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: any

Traffic Shaping

Target/Average Byte Sustain Excess Interval Increment

Rate Limit bits/int bits/int (ms) (bytes)

1000000/1000000 6250 25000 25000 25 3125

Adapt Queue Packets Bytes Packets Bytes Shaping

Active Depth Delayed Delayed Active

- 0 0 0 0 0 no

Service-policy : marking

Class-map: voip (match-all)

0 packets, 0 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: access-group name qos

Queueing

Strict Priority

Output Queue: Conversation 72

Bandwidth 120 (kbps) Burst 3000 (Bytes)

(pkts matched/bytes matched) 0/0

(total drops/bytes drops) 0/0

QoS Set

dscp ef

Packets marked 0

Class-map: class-default (match-any)

0 packets, 0 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: any

My suggestion is that you try it like the example in:

http://www.cisco.com/en/US/tech/tk39/tk824/technologies_configuration_example09186a0080094cf6.shtml#sampleconfig

According to that example, your policy-map test should look like this:

policy-map test

class voip

priority 120

set ip dscp ef

class class-default

shape average 1000000

Regards,

Leo

Hello,

I just copy and pasted your config into 7200 with 12.4(9)T and it works.

Difference:

interface ATM1/0

no ip address

no atm ilmi-keepalive

!

interface ATM1/0.1 point-to-point

ip address 10.1.163.193 255.255.255.252

no snmp trap link-status

service-policy output test

pvc 8/35

encapsulation aal5snap

So I had no "dsl operating-mode auto" and the service-policy is configured in subif and not PVC mode.

Might be your IOS as well.

Hope this helps! Please use the rating system.

Regards, Martin

Martin,

When i trying to attach service-policy in subinterface mode i have this error:

router(config-subif)#service-policy output test

GTS : Not supported on this interface

although, as i've read here http://www.cisco.com/warp/public/121/where_policy.html

it should be supported configuration

Hm. Another idea:

Can you try something like

int atm1/0.1

pvc 8/35

class-vc Myclass

vc-class Myclass

service-policy output Test

Unfortunately I cannot test this here. Just reminds me on the frame-relay approach, where the policy-map can only be applied to a "map-class frame-relay" and not directly to a FR sub-interface.

Regards, Martin

It isn't possible to attach service-policy into class-vc atm (at least on my router).

I'll try to use latest version of Cisco IOS, perhaps it's help.

Review Cisco Networking products for a $25 gift card