Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

QoS on 2811 & 3845 Series Routers

I am trying to configure QoS on the above routers and since they do not have AutoQoS I am doing a map-class frame-relay but the link becomes inaccessible after about 2 minutes. I am using the following configuration syntax below:

ip rtp header-compression iphc-format

frame-relay traffic-shaping

int s1/0:1.1 point-to-point

frame-relay class voice

map-class frame-relay voice

frame-relay cir 256000

frame-relay mincir 72000

frame-relay fragment 320

frame-relay fair-queue

ip rtp priority 16384 16383 72000

With all these it goes off after about 3 minutes and thus the link becomes unaccessible.

Can someone give me syntax for the two routers which will work.

3 REPLIES
Community Member

Re: QoS on 2811 & 3845 Series Routers

Looking at the configuration, I would suggest two things.

1.The map class has to be associated with a major interface.but in ur config, it is associated with a sub-interface.

So, to modify this , give the no cmd of frame-relay class voice at the subinterface level and apply it to the major intf serial0/0 as

(conf -if)#frame-relay class voice.

2.In your example, i m not able to see frame-relay traffic-rate "average value" , "peak value " cmd. If you are using frame-relay adaptive-shaping becn cmd, then no need for frame-relay traffic-rate cmd.

Try out these 2 options . If the problem still persists, tell us the following info:

you are using PVC or SVC?

Blue

Re: QoS on 2811 & 3845 Series Routers

For voice on frame relay Cisco recommends that you not allow bursting past your CIR, so your cir and mincir should be the same. If you know your carrier never discards burst packets you may be able to violate this rule. The bc value should also be 1/100 of the CIR to reduce jitter.

Here is a production config for a 128 kb CIR frame circuit with fragmentation and header compression.

class-map match-any voice

description Voice

match ip dscp ef

match access-group 103

!

class-map match-all voicecontrol

description VoiceControl

match ip dscp af31

!

access-list 103 permit udp any any range 16384 32767

!

policy-map voice128

class voice

priority 64

class voicecontrol

bandwidth 8

class class-default

fair-queue

random-detect dscp-based

!

map-class frame-relay 128CIRvoice

frame-relay adaptive-shaping becn

frame-relay cir 128000

frame-relay bc 1280

frame-relay mincir 128000

service-policy output voice128

frame-relay fragment 400

!

interface Serial2/1:1

bandwidth 768

no ip address

encapsulation frame-relay

frame-relay traffic-shaping

frame-relay lmi-type ansi

!

interface Serial2/1:1.5 point-to-point

bandwidth 256

ip address 10.254.0.213 255.255.255.252

frame-relay class 128CIRvoice

frame-relay interface-dlci 675

frame-relay ip rtp header-compression

Community Member

Re: QoS on 2811 & 3845 Series Routers

I am now being faced with a situation where when i configure this interface with this working configuration it stops workings so i have to go in and reload the router for it to work again. I am doing this on both remote and head office routers. it is only that the Head Office Router has 8 different links on the same interface.

The other problem is that we are not using Cisco IP Phones, so i have to allow ports for Nortel IP phones and they are as below:

the UDP Ports used by Our Meridian IP Telephony System:

5000 - 5263 - IP Telephony Ports.

4100 and 4001 - Meridian Registration Ports

What do I need to do in order to get the link not to go down with the above configuration and at the same time use the Nortel IP phones well.

The link is 256K

655
Views
0
Helpful
3
Replies
CreatePlease to create content