Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

QoS on 6Mbps WAN link

I hope this is the right spot for this. 

I've got a router with its fastethernet connection going to a device that combines 4 T1s, for a total of 6mbps.  I want to configure a QOS policy on the Fastethernet interface to prioritize user traffic over backup traffic.  My plan was to use PQ to set the top priority as user traffic and the lowest as backup.  The problem is I don't know if PQ will recognize the bandwidth statement on the interface configuration or if it will simply see fastethernet and use 100mbps as the limit for congestion management.

I want to put bandwidth 6000 on the interface config and have PQ use that as its congestion point.  Will this work?

I may be thinking through this incorrectly.  If I assign user traffic, via an ACL, to priority 1 queue will it always be sent first?

something like:

access-list 10 deny <bandwidth traffic>

access-list 10 permit ip any any  (the rest is considered user traffic)

priority-list 1 protocol ip high list 10

interface fa0/0

priority-group 1

Would this accomplish my goal of letting backup traffic use whatever bandwidth is available until user traffic comes along?

2 REPLIES

QoS on 6Mbps WAN link

Hello,

I would recommend to use MQC rather than legacy QoS.

What I would do is the following.

On the inbound I would match the interesting traffic in ACL and set the correct DSCP values (e.g. EF for PQ traffic)

On the outbound interface

1. Use classes to match the traffic based on their DSCP values

2. Use the classes in the policy-map setting one class for PQ and the rest for CBWFQ

3. Use the policy-map out on the outbound traffic.

In this way you don't only ensure that you prioritize your traffic at your exit point, but also if the upstream providers care about the QoS values their will prioritize your traffic. Any provider with minimum QoS will prioritize the packets market with EF for example.

If you prioritize only at your interface without marking the traffic, indeed your prioritized packets will leave first the interface queue, but you have no warranty that the provider will do the same.

Let me know what you think about my proposal.

Calin

Super Bronze

QoS on 6Mbps WAN link

Disclaimer

The    Author of this posting offers the information contained within this    posting without consideration and with the reader's understanding that    there's no implied or expressed suitability or fitness for any  purpose.   Information provided is for informational purposes only and  should not   be construed as rendering professional advice of any kind.  Usage of  this  posting's information is solely at reader's own risk.

Liability Disclaimer

In    no event shall Author be liable for any damages whatsoever  (including,   without limitation, damages for loss of use, data or  profit) arising  out  of the use or inability to use the posting's  information even if  Author  has been advised of the possibility of such  damage.

Posting


I believe PQ only reacts to interface congestion.  If you want to properly prioritize for 6 Mbps later downstream, you need a hierarchal policy with a shaper.  Something like (syntax might be incorrect):

policy-map parent

class class-default

shape average 6000000

service-policy child

policy-map child

class backup

bandwidth 8000

interface f0/0

service-policy parent out

337
Views
0
Helpful
2
Replies