Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

QOS on ATM Interface

Hello,

In one of my remote office, we have a 1841 device (c1841-advipservicesk9-mz.124-19.bin) with a WIC-1ADSL=that is used for Internet browsing and access to our private network through an ipsec gre tunnel.

As the internet browsing is consuming a lot of bandwith, i would like to prioritize some packets to the internal network when they transit through this device.

Though, i'm unable to find the good configuration.

I used the following link as a reference http://www.cisco.com/en/US/tech/tk39/tk824/technologies_tech_note09186a00800d76b5.shtml but when I tried to apply the service-policy on my atm subinterface, it gave me the following error "CBWFQ : Hierarchy not supported for ATM VCs"

Here is a part of my config

class-map match-any critical_app
match access-group 100
!
!
policy-map bandwith
class critical_app
  bandwidth percent 50
class class-default
  bandwidth percent 25
policy-map parent
class class-default
  service-policy bandwith

interface FastEthernet0/1
ip address 10.10.1.1 255.255.255.0
  ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface ATM0/0/0
no ip address
no ip mroute-cache
no atm ilmi-keepalive
dsl operating-mode auto
hold-queue 224 in
!
interface ATM0/0/0.1 point-to-point
pvc 0 0/50
  vbr-nrt 480 480 1

!!!!!!! I tried to apply the service policy here!!!!!!!!!!!!
  pppoe-client dial-pool-number 1
!
!
interface Dialer1
mtu 1492
ip address negotiated
ip nat outside
ip virtual-reassembly max-reassemblies 64
encapsulation ppp
dialer pool 1
dialer-group 10
ppp authentication chap callin
ppp chap hostname user
ppp chap password 0 password
crypto map WAN

ip nat inside source list 10 interface Dialer1 overload

access-list 100 permit tcp any any eq 99

How can i simply set up a low latency queue for the packets concerned by the ACL 100 ?

9 REPLIES
Hall of Fame Super Silver

Re: QOS on ATM Interface

Hello Mathieu,

you can apply the CBWFQ scheduler directly to the PVC because you have defined the ATM traffic parameters with vbr-nrt command (otherwise it would not be accepted).

You don't need the external shaper, well you have no shaper in parent policy because the ATM traffic parameters act also as a shaper.

apply directly bandwidth scheduler, I would suggest a different name

Also taking in account that GRE and IPSec copy on external headers the internal headers if needed you can provide an LLQ to IP precedence 5 for VOIP RTP bearer channels, some bandwidth to other packets in the VPN connection and you don't need to assign resources to class class-default it uses what is left free.

class voip

match ip precedence 5

class vpn

match ip address    100

policy myscheduler

class voip

priority percent 10

class vpn

bandwidth percent 50

class class-default

random-detect

int atm0/0/0.1

pvc 0 0/50

service-policy out myscheduler

of you can apply it directly on atm subinterface or under ATM main interface (I had to do so on a C877)

Hope to help

Giuseppe

New Member

Re: QOS on ATM Interface

Hello giuslar,

Here is what I get :

interface ATM0/0/0
no ip address
no ip mroute-cache
no atm ilmi-keepalive
dsl operating-mode auto
hold-queue 224 in
!
interface ATM0/0/0.1 point-to-point
pvc 0 0/50
  vbr-nrt 480 480 1
  service-policy output myscheduler
  pppoe-client dial-pool-number 1

Do you think it's ok like that ?

Because when I do a show policy interface, it's just empty, nothing appears !

And if i try to apply it direclty on the atm interface, it says : CBWFQ : Not supported on this interface

Hall of Fame Super Silver

Re: QOS on ATM Interface

Hello Mathieu,

try also to apply it on the ATM subinterface

Hope to help

Giuseppe

New Member

Re: QOS on ATM Interface

Same thing : CBWFQ : Not supported on this interface

Hall of Fame Super Silver

Re: QOS on ATM Interface

Hello Mathieu,

try to use a 12.4T image, in my case on C877 I had to move to 12.4T because I saw no matches on policy-map int, with no config change with just change of IOS the problem was fixed

Hope to help

Giuseppe

New Member

Re: QOS on ATM Interface

Unfortunately I don't have enough RAM for that

New Member

Re: QOS on ATM Interface

I had the same result when I tried to apply the service policy to this interface and I am running 12.4(11)T3.

interface ATM3/0
description Primary link to SJC
no ip address
ip flow ingress
atm clock INTERNAL
atm scrambling cell-payload
no atm ilmi-keepalive
!
interface ATM3/0.32 point-to-point
description Data PVC to SJC
bandwidth 42000
ip address 10.0.0.5 255.255.255.252
no ip redirects
ip flow ingress
no ip mroute-cache
no snmp trap link-status
pvc 1/32
  oam-pvc manage
  oam retry 3 10 1
  encapsulation aal5snap
!
!
interface ATM3/0.33 point-to-point

description Voice PVC to SJC
bandwidth 3000
ip address 10.0.0.9 255.255.255.252
ip flow ingress
no snmp trap link-status
pvc 1/33
  vbr-rt 3000 2000 32
  oam-pvc manage
  oam retry 3 10 1
  encapsulation aal5snap

Did you resolve this problem?

New Member

Re: QOS on ATM Interface

Hello James,

I solved this by upgrading to 12.4(25c)

New Member

Re: QOS on ATM Interface

Are you running IPBASE or ADVENTERPRISE?

1181
Views
0
Helpful
9
Replies
CreatePlease to create content