Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

QOS on cisco 800 series

I have configured the following on my cisco 800 series routers to priorotise traffic across my 4MB link. I am not sure if I have got the config correct as I seem to get delays with normal traffic like Citrix. Please can anyone advise on the method used ad if there is a better way of doing this?

Thanks

class-map match-any VOICE

match access-group 111

!

!

policy-map LLQ

class VOICE

priority 1500

set ip precedence 5

class class-default

fair-queue

policy-map PARENT

class class-default

shape average 3920000

service-policy LLQ

!

!

!

interface FastEthernet4

ip address 172.16.0.1 255.255.255.0

load-interval 30

service-policy output PARENT

!

access-list 111 permit ip 10.10.40.0 0.0.0.255 10.10.30.0 0.0.0.255

access-list 111 permit udp any any precedence critical

8 REPLIES

Re: QOS on cisco 800 series

Hi

which cisco router model you are using up over there ?

i dont think cisco 800 series model is capable of handling 4Mbps link with all qos flavors configured on it.

regds

New Member

Re: QOS on cisco 800 series

It is a Cisco 871 router.

Thanks

Re: QOS on cisco 800 series

hi

are you trying to configure qos on an internet link ?

QOS configurations has to be an end to end configuration where in any break in between will not yield the desired results for you.

regds

New Member

Re: QOS on cisco 800 series

Thanks for the reply. No, this is not over an internet link. It is a dedicated link between two sites. It is rated limited to 4MB by the ISP.

Ta

Re: QOS on cisco 800 series

hi

can you confirm whether your SP is honouring your marking out there in his PE router and mapping the same to his backbone markings ?

If he doesnt honour your marking and dont map it with his backbone markings you may end up in experiencing packet drops.

regds

New Member

Re: QOS on cisco 800 series

Usually citrix will use TCP ports 1494, 2598 and UDP port 1604.

access-list 110 remark Citrix-Prioritization

access-list 110 permit tcp any eq 1494 any

access-list 110 permit tcp any any eq 1494

access-list 110 permit udp any eq 1604 any

access-list 110 permit udp any any eq 1604

access-list 110 permit tcp any eq 2598 any

access-list 110 permit tcp any any eq 2598

class-map match-any CITRIX

match protocol citrix

match access-group 110

policy-map OUTBOUND

class CITRIX

priority percent

class class-default

fair-queue

interface Fastethernet 4

service-policy output OUTBOUND

If you are using any other ports you can create an ACL for that.

Hope this might help you..

Thanks

Rajesh

New Member

Re: QOS on cisco 800 series

Thanks Rajesh...

What would be the best way to include QOS for my voice traffic? Voice traffic is defined using this acl

access-list 111 permit ip 10.10.40.0 0.0.0.255 10.10.30.0 0.0.0.255

access-list 111 permit udp any any precedence critical

Thanks!

New Member

Re: QOS on cisco 800 series

class-map match-any CITRIX

description CITRIX

match protocol citrix

match access-group 110

class-map match-any VOICE

description VOIP

match access-group 111

match ip dscp ef

match ip precedence 5

policy-map OUTBOUND

class CITRIX

priority percent

class VOICE

priority percent

class class-default

fair-queue

interface Fastethernet 4

max-reserved-bandwidth <----Add this line, if the total percentage goes above 75%

service-policy output OUTBOUND

3242
Views
0
Helpful
8
Replies