Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

QoS on ME3800

Hi All,

Is it possible to apply the below configuration on ME3800 switch. I need to use the switch just to aggregate the traffic coming from three ports each with separate VLAN and switch them through dot1q trunk link to the other site.

i dont have any EFP configuration.

the link is limited to 200Mbps

The QoS configuration should match and apply policy for traffic coming from the three input interfaces

class-map match-any class1

match dscp ef

match dscp 45

match dscp 47

class-map class2

match dscp 15

class-map class3

match dscp af31

class-map class4

match dscp cs4

policy-map MAP

class class1

priority

class class2

bandwidth remaining percent 20

class class3

bandwidth remaining percent 10

class class4

bandwidth remaining percent 80

policy-map parent

class class-default

shape average 200000000

service-policy MAP

int g0/1--------------> this is the out interface which connects to site2, the link is limited to 200Mbps

service-policy output parent

switchport mode trunk

int g0/2------------->dscp 45, cs4 comming from this interface

switchport mode access

switchport access vlan 101

int g0/3-------------> dscp ef, dscp 15, AF31 comming from this interface

switchport mode access

switchport access vlan 102

int g0/4-------------> dscp 47 coming from this interface

switchport mode access

switchport access vlan 103

2 REPLIES
New Member

QoS on ME3800

Will this work? just use the ME3800 as a layer 2 switch "like any 3560 or 3750" and no MPLS configuration. but use it for WAN and use MQC QoS on the outbound trunk interface?

QoS on ME3800

Hi,

The configuration and the setup looks ok. Tou can find my comment below.

First, you have to define a bandwidth to the class 1, if this class is needed and you need to have LLQ.

Second, regarding your QoS service policy you may have to use the    max-reserved-bandwidth 100 command under the int gi 0/1.

"By default, when the bandwidth percent and priority percent commands are used to allocate bandwidth, the sum of the bandwidth percentage allocated to the high priority traffic and the bandwidth percentage allocated to the non-priority traffic cannot exceed 75 percent of the total bandwidth available on the interface.

The remaining 25 percent of the total bandwidth available on the interface is kept in reserve for the unclassified traffic and routing traffic, if any, and proportionally divided among the defined traffic classes. To override the 75 percent limitation, use themax-reserved bandwidth command in interface configuration mode." Source: Cisco web site

In practice, it is may better to configure max-reserved bandwith to a value close to 95% in order to always permit qos unmarked traffic to pass via this interface during congestions (e.g. routing updates, cdp, arp etc)

Hope that  helps!

Vasilis

825
Views
0
Helpful
2
Replies
CreatePlease login to create content