Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
Bronze

QoS on WS-X6704-10GE (7600 IOS 15.1)

Hi,

I am configuring QoS on this ethernet card. Unfortunately MQC with policing and priority is not supported, so I have to use L2 QoS (wrr, rcv, priority-queue).

At this moment I need QoS only for VoIP traffic which means that I just have to enable mls qos and cos-dscp mapings.

Is there something else that I need to configure on the egress port to the core network?

"show mls qos queuing interface tenGigabitEthernet 2/3" gives me this info:

Weighted Round-Robin

  Port QoS is enabled

  Trust state: trust COS

  Extend trust state: not trusted [COS = 0]

  Default COS is 0

    Queueing Mode In Tx direction: mode-cos

    Transmit queues [type = 1p7q8t]:

    Queue Id    Scheduling  Num of thresholds

    -----------------------------------------

       01         WRR                 08

       02         WRR                 08

       03         WRR                 08

       04         WRR                 08

       05         WRR                 08

       06         WRR                 08

       07         WRR                 08

       08         Priority            01

    WRR bandwidth ratios:  100[queue 1] 150[queue 2] 200[queue 3]   0[queue 4]   0[queue 5]   0[queue 6]   0[queue 7]

    queue-limit ratios:     50[queue 1]  20[queue 2]  15[queue 3]   0[queue 4]   0[queue 5]   0[queue 6]   0[queue 7]  15[Pri Queue]

Packets dropped on Transmit:

    queue     dropped  [cos-map]

    ---------------------------------------------

    1                        0  [0 1 ]

    2                        0  [2 3 4 ]

    3                        0  [6 7 ]

    4                        0  []

    5                        0  []

    6                        0  []

    7                        0  []

    8                        0  [5 ]

Does this mean that for the Prority queue 15% of bandwidth for this priority-queue and I can get more if there is any free bandwidht?

And what is the difference between WRR bandwidht ratio and queue-limit ratio?

I read the documentation for PFC QoS on 7600 on this link

http://www.cisco.com/en/US/partner/docs/routers/7600/ios/15S/configuration/guide/7600_15_0s_book.html

and it is helpful but I would like to have your opinion and a guide it there is any.

And the VoIP gear is connected to this router on a WS-X6748-SFP where we don't have control and they do not mark it.

That is why I need to mark every packet that is arriving with COS 5. Is this the right configuration for this?

interface GigabitEthernet1/25

switchport

switchport access vlan 304

switchport mode access

speed nonegotiate

mls qos trust cos

mls qos cos 5

And a SVI interface is used for every VLAN.

This is the mls qos global configuration:

mls flow ip interface-full

no mls flow ipv6

mls qos map policed-dscp max-burst 0 8 16 24 32 40 48 56 to 9

mls qos map cos-dscp 0 8 9 24 32 46 48 56

no mls qos recirc untrust

no mls qos rewrite ip dscp

mls qos

The ISO version is 151-3.S0a

On ES+ card is evertything clear and easy to configure.

5 REPLIES
Bronze

QoS on WS-X6704-10GE (7600 IOS 15.1)

I really wonder why nobody is responding to this

The problem is that I don't see the markings on the other side.

I tried with mls qos cos 5, port-based marking and vlan based marking

This is the policy-map

policy-map SET_DSCP_EF

class class-default

  set ip dscp ef

This is the mls config

mls flow ip interface-full

no mls flow ipv6

mls qos map cos-dscp 0 8 9 24 32 46 48 56

no mls qos recirc untrust

no mls qos rewrite ip dscp

mls qos

and this is the egress interface to the network

interface TenGigabitEthernet2/1

mtu 9164

ip address 10.1.0.30 255.255.255.252

ip ospf network point-to-point

ip ospf hello-interval 1

ip ospf bfd

load-interval 30

carrier-delay msec 0

wrr-queue bandwidth 5 25 20 20 20 5 5

priority-queue queue-limit 30

wrr-queue queue-limit 5 25 10 10 10 5 5

wrr-queue random-detect min-threshold 1 80 100 100 100 100 100 100 100

wrr-queue random-detect min-threshold 2 80 100 100 100 100 100 100 100

wrr-queue random-detect min-threshold 3 80 100 100 100 100 100 100 100

wrr-queue random-detect min-threshold 4 80 100 100 100 100 100 100 100

wrr-queue random-detect min-threshold 5 80 100 100 100 100 100 100 100

wrr-queue random-detect min-threshold 6 80 100 100 100 100 100 100 100

wrr-queue random-detect min-threshold 7 80 100 100 100 100 100 100 100

wrr-queue random-detect max-threshold 1 100 100 100 100 100 100 100 100

wrr-queue random-detect max-threshold 2 100 100 100 100 100 100 100 100

wrr-queue random-detect 4

wrr-queue random-detect 5

wrr-queue random-detect 6

wrr-queue random-detect 7

wrr-queue cos-map 1 1 1

wrr-queue cos-map 2 1 0

wrr-queue cos-map 3 1 4

wrr-queue cos-map 4 1 2

wrr-queue cos-map 5 1 3

wrr-queue cos-map 6 1 6

wrr-queue cos-map 7 1 7

mls qos trust dscp

bfd interval 50 min_rx 50 multiplier 3

service-policy output MATCH

Even the service-policy output MATCH in class default is not matching anything.

I need help with this

QoS on WS-X6704-10GE (7600 IOS 15.1)

Hi,

Can you attached a diag or just rough sketch of the network with relevant port numbers please.

Regards,

Smitesh

Bronze

QoS on WS-X6704-10GE (7600 IOS 15.1)

Yes of course. I read a lot of documents about this and I really don't know why I don't see the EF or EXP5 bit on the other side. On THe 7609 with ES+ card is everything working fine.

Bronze

QoS on WS-X6704-10GE (7600 IOS 15.1)

I just disabled mls qos globally and now I see the marked packets on the other side (7606-02).

This is weird, but I need WRR on interfaces to the core network.

Bronze

QoS on WS-X6704-10GE (7600 IOS 15.1)

Well I solved it last week.

Uniform mode did the trick. On the L2 ports I had to configure mls qos cos 5.

1777
Views
0
Helpful
5
Replies
CreatePlease to create content