Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

QoS or Traffic-shaping for IP-phone ?

Hi

I'm trying to prioritize traffic between to phone-servers on diffrent locations. On one side there is a vpn

3000, so there i cant do so much. So I'm looking at the other side (no many say, if I want to run QoS it

should be all the way). But is there a chance to either run QoS or traffic shaping on one side.

contention 20:1 upstream 800 kbs (min 40 kbs)

VPN tunnel site-to-site.

Host A is talking to Citrix-server on site B

Phone-server A is talking to Phone-server B and should be prioritize.

I have setup a lab on this, see attachment-->QoS.jpg .

when i try to use QoS on "ATM 0", i cant see any difference in traffic. Is this because i only use qos on

one side?

To test QoS i use FTP-server to see if the router prioritize traffic. But when i try the have equal amount

of bandwith and this is not the result i wanted.

When i use traffic-shaping it is seems to working greatwith FTP (dont know about IP-phones), but this

solution seems to be a little bit static, rather use som QoS. My understanding is that there is no

possibility to use QoS -->input on a interface?

Is there anyone who can tell me if I should use QoS (how), or if it will work fine with traffic-shaping.

SiteA#sh run

!

class-map match-any IPtel2

match access-group 100

class-map match-any IPtel

match access-group name IPtel

!

!

policy-map localQoS

class IPtel2

shape average 400000 400000 400000

class class-default

fair-queue

shape average 150000

policy-map MinQoSpolicy

class IPtel

priority 1150

class class-default

fair-queue

crypto isakmp policy 10

encr 3des

authentication pre-share

group 2

crypto isakmp key cisco address 194.x.x.1

!

!

crypto ipsec transform-set trans1 esp-3des esp-md5-hmac

!

crypto map MYMAP 10 ipsec-isakmp

set peer 194.x.x.1

set transform-set trans1

match address 150

qos pre-classify

!

interface FastEthernet0/0

bandwidth 1544

ip address 192.168.100.1 255.255.255.0

duplex auto

speed auto

service-policy output localQoS

!

interface Ethernet1/0

no ip address

half-duplex

!

!

! (This interface represent the ATM interface)

interface Serial1/0

ip address 194.x.x.2 255.255.255.0

no ip mroute-cache

clock rate 384000

crypto map MYMAP

service-policy output MinQoSpolicy

!

ip http server

no ip http secure-server

ip classless

ip route 192.168.1.0 255.255.255.0 194.9.4.1

ip access-list extended IPtel

permit ip host 192.168.100.10 any

access-list 100 permit ip host 192.168.1.10 host 192.168.100.10

access-list 150 permit ip 192.168.100.0 0.0.0.255 192.168.1.0 0.0.0.255

//lamin

Apologize for my bad English

6 REPLIES
New Member

Re: QoS or Traffic-shaping for IP-phone ?

siteA#sh policy-map int

FastEthernet0/0

Service-policy output: localQoS

Class-map: IPtel2 (match-any)

166330 packets, 173901128 bytes

5 minute offered rate 316000 bps, drop rate 0 bps

Match: access-group 100

166330 packets, 173901128 bytes

5 minute rate 316000 bps

Traffic Shaping

Target/Average Byte Sustain Excess Interval Increment

Rate Limit bits/int bits/int (ms) (bytes)

400000/400000 100000 400000 400000 1000 50000

Adapt Queue Packets Bytes Packets Bytes Shaping

Active Depth Delayed Delayed Active

- 0 136016 142623452 1908 1817680 no

Class-map: class-default (match-any)

48917 packets, 67095947 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: any

Queueing

Flow Based Fair Queueing

Maximum Number of Hashed Queues 256

(total queued/total drops/no-buffer drops) 0/0/0

Traffic Shaping

Target/Average Byte Sustain Excess Interval Increment

Rate Limit bits/int bits/int (ms) (bytes)

150000/150000 1950 7800 7800 52 975

Adapt Queue Packets Bytes Packets Bytes Shaping

Active Depth Delayed Delayed Active

- 0 25023 33760923 19087 26177334 no

Serial1/0

Service-policy output: MinQoSpolicy

Class-map: IPtel (match-any)

87049 packets, 3938988 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: access-group name IPtel

87051 packets, 3939032 bytes

5 minute rate 0 bps

Queueing

Strict Priority

Output Queue: Conversation 264

Bandwidth 1150 (kbps) Burst 28750 (Bytes)

(pkts matched/bytes matched) 103/11148

(total drops/bytes drops) 0/0

Class-map: class-default (match-any)

24552 packets, 1098349 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: any

Queueing

Flow Based Fair Queueing

Maximum Number of Hashed Queues 256

(total queued/total drops/no-buffer drops) 0/0/0

siteA#

New Member

Re: QoS or Traffic-shaping for IP-phone ?

Friend,

There is no need to have a service-policy on the Fastethernet interface.

Voice will have detrimental effect if you shape it.

If you want to shape the traffic, then you should create a nested policy where you prioritise the voice packet.

eg

policy-map localQoS

class class-default

shape average

service-policy voice-----------Nested policy

policy-map voice

class IPtel

priority 1150

Apply it to the ATM interface

interface Serial1/0

service-policy output localQoS

New Member

Re: QoS or Traffic-shaping for IP-phone ?

Hi mtechnology

Ok I think i understand what you mean. I just want to prioritize trafic between the two IP-phone servers, but can only do this prioritizing on one side, with Qos or traffic-shaping not both at the same time. I was thinking to use QoS on ATM interface(in my lab didnt work, maybe some wrong with my config or there need to Qos on the other side- VPN3000, doesnt support QoS) or use traffic-shaping to allways have some bandwidth for the IP-servers. Is traffic-shaping the best alternativ?

//Lamin

Bronze

Re: QoS or Traffic-shaping for IP-phone ?

Hi,

You should only do marking on your LAN input.

Then QOS output on wan interface.

Qos output on you LAN is not necesarry.

Traffic-shaping is a technique for limiting traffic, so if you limit unimportant traffic you get more bandwith for Voice.

However it is better to do LLQ for voice and reserve a minimum bandwith.

And of cource to get full utilization of QOS you need it on both ends for. (Return traffic)

HTH

Regards,

Bjornarsb

New Member

Re: QoS or Traffic-shaping for IP-phone ?

Hi Bj?rn

on the other side there is a VPN3000 it cant prioritize traffic. So I can only do this on one side. When I did my lab with traffic-shaping I could dedicate bandwidth for the IP-phone servers. This by only do some config on one side on Fa0/0 inteface-->output, this seems to work fine. But I rather use QoS is this possible?

//Lamin

Bronze

Re: QoS or Traffic-shaping for IP-phone ?

Hi,

Yes you can use QOS.

Please have a look at this example:

Create a child or lower-level policy that configures a queueing mechanism. In the example below, we configure LLQ using the priority command and CBWFQ using the bandwidth command. Refer to Congestion Management Overview for more information.

policy-map child

class voice

priority 512

Create a parent or top-level policy that applies class-based shaping. Apply the child policy as a command under the parent policy since the admission control for the child class is done based on the shaping rate for the parent class.

policy-map parent

class class-default

shape average 2000000

service-policy child

Apply the parent policy to the subinterface.

interface ethernet0/0.1

service-policy parent

HTH,

Regards

Bjornarsb

226
Views
0
Helpful
6
Replies