Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

QoS/ Prioritisation

Hello All,

I am installing an internet connection into a shared office suite and need to fairly allocate internet bandwidth accordingly.

Say its a 1Mbit line, I would like either network to be able to burst to the maximum bandwidth when available but say a user on network 1 is using all the bandwidth and user on network 2 starts browsing, I would like the bandwidth to be split 50/50. 

Can any give me a few ideas how to do this?

Thanks

Everyone's tags (1)
5 REPLIES

Re: QoS/ Prioritisation

You can use CBWFQ

With Class-based weighted fair queueing (CBWFQ) you can assign min banwidth to your user-defined traffic classes. For CBWFQ, you define traffic classes based on match criteria including protocols, access control lists (ACLs), and input interfaces. It allow burst if the bandwidth is not used.

Francisco

New Member

Re: QoS/ Prioritisation

Thanks for the prompt reply. 

Does anyone have some configuration examples.

Lets say there are 2 network hosts 192.168.1.1/24 and 192.168.1.1/24 and I want to allocate bandwidth fairly to each source address,

Silver

Re: QoS/ Prioritisation

What kind of hardware will terminate the circuit?  Router, Firewall, L3 Switch?  We'll also need the version of code running on that hardware.



Chris

Re: QoS/ Prioritisation

Good question by chris. I should have asked for the platform first and software code.

An example here is one on a route platform 3845 router with Queueing strategy Class-based queueing enable.


class-map match-all NetworkQUEUE
match ip dscp cs2
class-map match-all INTERNETQUEUE
match ip dscp CS3
class-map match-any LLQ1
match ip dscp ef
match ip dscp 41

!
policy-map INT_OUT
class LLQ1
    priority percent 20
class NetworkQUEUE
    bandwidth percent 40
class INTERNETQUEUE
    bandwidth percent 40
policy-map SHAPE_OUT
class class-default
    shape average 96000000 960000
  service-policy INT_OUT

!

int fa0/0
service-policy output SHAPE_OUT

In the example above, i also have voice traffic with priority queueing assigned 20% of interface bandwidth and the rest of the traffic internet and network for example even 40%..

Please note the above is just an example of how to setup CBWFQ with PQ.

Hope that is helpful!

Francisco.

Re: QoS/ Prioritisation

Or match using ACL

access-list 101 permit tcp 172.10.1.0 0.0.0.255 any  (Network traffic)
access-list 102 permit tcp 172.10.2.0 0.0.0.255 any  (Internet traffic)

class-map match-all NetworkQUEUE
match access-group 100

class-map match-all INTERNETQUEUE
match access-group 102

478
Views
0
Helpful
5
Replies
CreatePlease to create content