Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

QoS - priority percent

With the following config...

policy-map COS

class IP-PREC4

set ip precedence 4

priority percent 50

class IP-PREC3

set ip precedence 3

bandwidth percent 30

class class-default

fair-queue

random-detect

policy-map SHAPING

class class-default

shape average 512000 5120

service-policy COS

!

interface FastEthernet0/0

description MPLS 2MB connection

FastEthernet5/1/1

bandwidth 2000

ip address 192.168.x.214 255.255.255.252

speed 10

full-duplex

max-reserved-bandwidth 100

service-policy output SHAPING

...would the priority percent use 50% of the shaped rate or 50% of the interface's bandwidth command for it's percentage calculation?

Cheers

1 ACCEPTED SOLUTION

Accepted Solutions

Re: QoS - priority percent

To add some explanation to this:

With your configuration the queue system is built up the following way:

Interface Traffic -> LLQ -> Shaping Queue -> Transmit Queue -> Outgoing traffic

So if you configure the 'priority percent 50' command, the LLQ will allow 1000 kbps for the priority traffic.

But the shaping queue is configured for 512kbps only, so 1000 kbps priority traffic could overwhelm the shaping queue, leaving no space for other traffic.

Cheers:

Istvan

7 REPLIES

Re: QoS - priority percent

Hi Duncan,

The priority percent command uses the bandwidth setting to calculate the bandwidth allocated to the priority queue. In this case it will allocate 1000 kbps.

You should set the priority command to

"priority 256"

if you want the priority queue to use 50% of the shaped bandwidth.

Cheers:

Istvan

Re: QoS - priority percent

To add some explanation to this:

With your configuration the queue system is built up the following way:

Interface Traffic -> LLQ -> Shaping Queue -> Transmit Queue -> Outgoing traffic

So if you configure the 'priority percent 50' command, the LLQ will allow 1000 kbps for the priority traffic.

But the shaping queue is configured for 512kbps only, so 1000 kbps priority traffic could overwhelm the shaping queue, leaving no space for other traffic.

Cheers:

Istvan

New Member

Re: QoS - priority percent

Gotcha. Thanks Istvan.

Duncan

Super Bronze

Re: QoS - priority percent

"...would the priority percent use 50% of the shaped rate or 50% of the interface's bandwidth command for it's percentage calculation? "

If I remember correctly, with the later IOS images, the bandwidth percentages will use the parent policy's shaped rate not the interface bandwidth setting (which whould be used by class percentages in the parent policy).

BTW, another interesting bandwidth issue is, you've explicity allocated 80%. For IOS on most platforms (pre 12.4[20]T?), you would be unable to do this without increasing the max-reserved-bandwidth from its default 75% (as you've done), although here too I think this would only apply to the parent policy, not a subordinate policy.

It also looks like you've clipped an actual CBWFQ implementation. What does a show policy-map interface indicate (since many IOSs will show class bandwidth allocations for percentages)?

New Member

Re: QoS - priority percent

Thanks Joseph. Where did you get this info? I've tried to find something definitive on the Cisco site regarding this but no luck to date.

Unfortunately it's a provider router (CE) so I don't have telnet access, but I do have GN3 so I'll give it a try on there.

Cheers

Duncan

Super Bronze

Re: QoS - priority percent

Sorry, don't recall if I seen good Cisco documentation on this point.

BTW, I dropped your configuration into a lab router (2801 using 12.4.23) and it looks like my memory was confirmed.

class-map match-all IP-PREC3

match ip precedence 3

class-map match-all IP-PREC4

match ip precedence 4

!

!

policy-map COS

class IP-PREC4

set ip precedence 4

priority percent 50

class IP-PREC3

set ip precedence 3

bandwidth percent 30

class class-default

fair-queue

random-detect

policy-map SHAPING

class class-default

shape average 512000 5120

service-policy COS

interface FastEthernet0/0

ip address dhcp

duplex auto

speed auto

max-reserved-bandwidth 100

service-policy output SHAPING

Rtr1#sh policy-map i o

FastEthernet0/0

Service-policy output: SHAPING

Class-map: class-default (match-any)

122 packets, 18767 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: any

Traffic Shaping

Target/Average Byte Sustain Excess Interval Increment

Rate Limit bits/int bits/int (ms) (bytes)

512000/512000 1280 5120 5120 10 640

Adapt Queue Packets Bytes Packets Bytes Shaping

Active Depth Delayed Delayed Active

- 0 122 18767 3 1006 no

Service-policy : COS

Class-map: IP-PREC4 (match-all)

0 packets, 0 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: ip precedence 4

QoS Set

precedence 4

Packets marked 0

Queueing

Strict Priority

Output Queue: Conversation 40

Bandwidth 50 (%)

Bandwidth 256 (kbps) Burst 6400 (Bytes)

(pkts matched/bytes matched) 0/0

(total drops/bytes drops) 0/0

Class-map: IP-PREC3 (match-all)

0 packets, 0 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: ip precedence 3

QoS Set

precedence 3

Packets marked 0

Queueing

Output Queue: Conversation 41

Bandwidth 30 (%)

Bandwidth 153 (kbps)Max Threshold 64 (packets)

(pkts matched/bytes matched) 0/0

(depth/total drops/no-buffer drops) 0/0/0

Class-map: class-default (match-any)

122 packets, 18767 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: any

Queueing

Flow Based Fair Queueing

Maximum Number of Hashed Queues 32

(total queued/total drops/no-buffer drops) 0/0/0

exponential weight: 9

class Transmitted Random drop Tail drop Minimum Maximum Mark

pkts/bytes pkts/bytes pkts/bytes thresh thresh prob

0 24/2604 0/0 0/0 20 40 1/10

1 0/0 0/0 0/0 22 40 1/10

2 0/0 0/0 0/0 24 40 1/10

3 0/0 0/0 0/0 26 40 1/10

4 0/0 0/0 0/0 28 40 1/10

5 0/0 0/0 0/0 30 40 1/10

6 98/16163 0/0 0/0 32 40 1/10

7 0/0 0/0 0/0 34 40 1/10

rsvp 0/0 0/0 0/0 36 40 1/10

Super Bronze

Re: QoS - priority percent

(NB: prior post is throwing Apache errors?)

Sorry, don't recall if I've seen good Cisco documentation on this point.

BTW, I dropped your configuration into a lab router (2801 using 12.4.23) and it looks like my memory was confirmed.

class-map match-all IP-PREC3

match ip precedence 3

class-map match-all IP-PREC4

match ip precedence 4

!

!

policy-map COS

class IP-PREC4

set ip precedence 4

priority percent 50

class IP-PREC3

set ip precedence 3

bandwidth percent 30

class class-default

fair-queue

random-detect

policy-map SHAPING

class class-default

shape average 512000 5120

service-policy COS

interface FastEthernet0/0

ip address dhcp

duplex auto

speed auto

max-reserved-bandwidth 100

service-policy output SHAPING

Rtr1#sh policy-map i o

FastEthernet0/0

Service-policy output: SHAPING

Class-map: class-default (match-any)

122 packets, 18767 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: any

Traffic Shaping

Target/Average Byte Sustain Excess Interval Increment

Rate Limit bits/int bits/int (ms) (bytes)

512000/512000 1280 5120 5120 10 640

Adapt Queue Packets Bytes Packets Bytes Shaping

Active Depth Delayed Delayed Active

- 0 122 18767 3 1006 no

Service-policy : COS

Class-map: IP-PREC4 (match-all)

0 packets, 0 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: ip precedence 4

QoS Set

precedence 4

Packets marked 0

Queueing

Strict Priority

Output Queue: Conversation 40

Bandwidth 50 (%)

Bandwidth 256 (kbps) Burst 6400 (Bytes)

(pkts matched/bytes matched) 0/0

(total drops/bytes drops) 0/0

Class-map: IP-PREC3 (match-all)

0 packets, 0 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: ip precedence 3

QoS Set

precedence 3

Packets marked 0

Queueing

Output Queue: Conversation 41

Bandwidth 30 (%)

Bandwidth 153 (kbps)Max Threshold 64 (packets)

(pkts matched/bytes matched) 0/0

(depth/total drops/no-buffer drops) 0/0/0

Class-map: class-default (match-any)

122 packets, 18767 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: any

Queueing

Flow Based Fair Queueing

Maximum Number of Hashed Queues 32

(total queued/total drops/no-buffer drops) 0/0/0

exponential weight: 9

class Transmitted Random drop Tail drop Minimum Maximum Mark

pkts/bytes pkts/bytes pkts/bytes thresh thresh prob

0 24/2604 0/0 0/0 20 40 1/10

1 0/0 0/0 0/0 22 40 1/10

2 0/0 0/0 0/0 24 40 1/10

3 0/0 0/0 0/0 26 40 1/10

4 0/0 0/0 0/0 28 40 1/10

5 0/0 0/0 0/0 30 40 1/10

6 98/16163 0/0 0/0 32 40 1/10

7 0/0 0/0 0/0 34 40 1/10

rsvp 0/0 0/0 0/0 36 40 1/10

2135
Views
10
Helpful
7
Replies