Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

QOS question for older 7206 code 12.3

I have just discovered the 7206 router I have inhereted are only doing FIFO on the serial interfaces. They are attached to full DS3 and max out at about  6MB of traffic daily. We do not do voice or video. I have had some issue with clents complaing of timout issue with some of their API apps coming accross the internet.

Does anyone thing it would be a good idea to do WFQ on this interface?   Below is a show interface and I do see some drops.

BSFiber#sh int s3/0
Serial3/0 is up, line protocol is up
  Hardware is M1T-T3 pa
    MTU 4470 bytes, BW 44210 Kbit, DLY 200 usec,
     reliability 255/255, txload 35/255, rxload 12/255
  Encapsulation HDLC, crc 16, loopback not set
  Keepalive set (10 sec)
  Restart-Delay is 0 secs
  Last input 00:00:03, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/345/163071 (size/max/drops/flushes); Total output drops: 57912
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 2238000 bits/sec, 1489 packets/sec
  5 minute output rate 6124000 bits/sec, 1257 packets/sec
     923784572 packets input, 3049982363 bytes, 143 no buffer
     Received 1618464 broadcasts, 0 runts, 2 giants, 0 throttles
              0 parity
     632 input errors, 595 CRC, 0 frame, 31 overrun, 31426 ignored, 6 abort
     4209966523 packets output, 2139863988 bytes, 0 underruns
     0 output errors, 0 applique, 5 interface resets
     0 output buffer failures, 0 output buffers swapped out
     13 carrier transitions
   rxLOS inactive, rxLOF inactive, rxAIS inactive
   txAIS inactive, rxRAI inactive, txRAI inactive

1 ACCEPTED SOLUTION

Accepted Solutions

Re: QOS question for older 7206 code 12.3

With FIFO once the hardware queue is filled up then traffic will start getting drop randomly without software queuing enable. .

Example of WFQ configuration i am using and match traffic based on DSCP or you could match your application traffic based on ACL.

interface Serial2/1
no ip address
encapsulation ppp
no ip mroute-cache
load-interval 30
dsu bandwidth 44210
framing c-bit
cablelength 10
no clns route-cache
max-reserved-bandwidth 90
service-policy output INT_OUT


policy-map INT_OUT
    class HIGHQ
    bandwidth remaining percent 45
  class ROUTINGQ
    bandwidth remaining percent 5
  class LOWQ
    bandwidth remaining percent 10
  class class-default
    bandwidth remaining percent 35


class-map match-all ROUTING_Q
  match ip dscp cs6
class-map match-all LOW_Q
  match ip dscp cs1
class-map match-all HIGHQ
  match ip dscp cs4

Regards

Francisco

1 REPLY

Re: QOS question for older 7206 code 12.3

With FIFO once the hardware queue is filled up then traffic will start getting drop randomly without software queuing enable. .

Example of WFQ configuration i am using and match traffic based on DSCP or you could match your application traffic based on ACL.

interface Serial2/1
no ip address
encapsulation ppp
no ip mroute-cache
load-interval 30
dsu bandwidth 44210
framing c-bit
cablelength 10
no clns route-cache
max-reserved-bandwidth 90
service-policy output INT_OUT


policy-map INT_OUT
    class HIGHQ
    bandwidth remaining percent 45
  class ROUTINGQ
    bandwidth remaining percent 5
  class LOWQ
    bandwidth remaining percent 10
  class class-default
    bandwidth remaining percent 35


class-map match-all ROUTING_Q
  match ip dscp cs6
class-map match-all LOW_Q
  match ip dscp cs1
class-map match-all HIGHQ
  match ip dscp cs4

Regards

Francisco

225
Views
0
Helpful
1
Replies
CreatePlease to create content