Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

QoS Question

I have three T1s configured in a PPP multilink bundle on a central router used by two additional site routers as an egress point. I now have a requirement to implement minimum access rates for each of the two remote sites with bursts permitted to utilize unused bandwidth. What type of QoS implementation would be best for this model? As a side note, I must classify traffic based on IP addresses because customer traffic is ecrypted and encapsulated at this point. Thanks.

1 ACCEPTED SOLUTION

Accepted Solutions

Re: QoS Question

Hello,

I would recommend to use CBWFQ (class-based weighted fair-queueing). This will give minimum bandwidth guarantees to a class with the allowance of utilizing the full available bandwidth. An example config would be:

class-map match-all Site1

match ip address 101

class-map match-all Site2

match ip address 102

policy-map OUT

class Site1

bandwidth percent 30

class Site2

bandwidth percent 30

class class-default

fair-queue

interface Multilink1

ip address 192.168.1.1 255.255.255.252

bandwidth 4500

service-policy output OUT

access-list 101 permit ip 10.1.0.0 0.0.255.255 any

access-list 102 permit ip 10.2.0.0 0.0.255.255 any

This assumes that site1 has IP addresses in 10.1.0.0/16 and gets at a minimum 30% of the link bandwidth. site2 gets also at least 30% and uses 10.2.0.0/16

Of course you would need to adjust IP addresses, interfaces and bandwidth parameters to your environment and needs.

Hope this helps! Please rate all posts.

Regards, Martin

2 REPLIES

Re: QoS Question

Hello,

I would recommend to use CBWFQ (class-based weighted fair-queueing). This will give minimum bandwidth guarantees to a class with the allowance of utilizing the full available bandwidth. An example config would be:

class-map match-all Site1

match ip address 101

class-map match-all Site2

match ip address 102

policy-map OUT

class Site1

bandwidth percent 30

class Site2

bandwidth percent 30

class class-default

fair-queue

interface Multilink1

ip address 192.168.1.1 255.255.255.252

bandwidth 4500

service-policy output OUT

access-list 101 permit ip 10.1.0.0 0.0.255.255 any

access-list 102 permit ip 10.2.0.0 0.0.255.255 any

This assumes that site1 has IP addresses in 10.1.0.0/16 and gets at a minimum 30% of the link bandwidth. site2 gets also at least 30% and uses 10.2.0.0/16

Of course you would need to adjust IP addresses, interfaces and bandwidth parameters to your environment and needs.

Hope this helps! Please rate all posts.

Regards, Martin

New Member

Re: QoS Question

Martin,

This is exactly what I was looking for. Thank you very much!

-Erik

104
Views
5
Helpful
2
Replies
CreatePlease to create content