cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
491
Views
0
Helpful
1
Replies

QoS rewrite on ethercahnnel

mats.brynolf
Level 1
Level 1

I'm trying to rewrite all traffic to 0 coming in on a etherchannel. This is how the config looks like.

When I do RSPAN and capture traffic for one of these VLANs I can still see DSCP flags set to something other then 0.

class-map match-all rewrite

match access-group name rewrite-dscp

!

policy-map rewrite

class rewrite

set dscp default

!

ip access-list standard rewrite-dscp

permit any

!

interface GigabitEthernet2/35

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 101-179,260-267,269-275,685,686,3601

switchport mode trunk

no ip address

wrr-queue cos-map 1 7 1

wrr-queue cos-map 1 8 4

wrr-queue cos-map 2 2 2

wrr-queue cos-map 3 1 6

wrr-queue cos-map 3 2 7

wrr-queue cos-map 3 8 3

flowcontrol send off

no cdp enable

channel-group 3 mode active

end

!

interface GigabitEthernet2/36

description ok7-dr1 <-> PP2 Admin

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 101-179,260-267,269-275,685,686,3601

switchport mode trunk

no ip address

wrr-queue cos-map 1 7 1

wrr-queue cos-map 1 8 4

wrr-queue cos-map 2 2 2

wrr-queue cos-map 3 1 6

wrr-queue cos-map 3 2 7

wrr-queue cos-map 3 8 3

flowcontrol send off

no cdp enable

channel-group 3 mode active

end

!

interface Port-channel3

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 101-179,260-267,269-275,685,686,3601

switchport mode trunk

no ip address

flowcontrol send off

service-policy input rewrite

end

I can't set the service policy command directly on the physical interfaces so that's why its not there.

router(config-if)#service-policy input rewrite

Policy can not be installed because interface GigabitEthernet2/35 is a member of Port-channel

MQC features are not supported for this interface

1 Accepted Solution

Accepted Solutions

allan.thomas
Level 8
Level 8

You should configure the port-channel and physical ports with the command 'mls qos vlan-based', and then configure or apply the service-policy rewrite on each of the trunked vlan interfaces (SVIs) as shown below:-

!

interface port-channel 3

mls qos vlan-based

!

interface GigabitEthernet2/35

mls qos vlan-based

!

interface GigabitEthernet2/36

mls qos vlan-based

!

interface vlan 101

service-policy input rewrite

.

.

.

interface vlan 179

service-policy input rewrite

HTH

Allan.

View solution in original post

1 Reply 1

allan.thomas
Level 8
Level 8

You should configure the port-channel and physical ports with the command 'mls qos vlan-based', and then configure or apply the service-policy rewrite on each of the trunked vlan interfaces (SVIs) as shown below:-

!

interface port-channel 3

mls qos vlan-based

!

interface GigabitEthernet2/35

mls qos vlan-based

!

interface GigabitEthernet2/36

mls qos vlan-based

!

interface vlan 101

service-policy input rewrite

.

.

.

interface vlan 179

service-policy input rewrite

HTH

Allan.

Review Cisco Networking products for a $25 gift card