Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

QoS settings which will match SP DSCP and policing policy

Hi Experts,

 

I have requirement of configuring QoS configuration on WAN router on one of the client site and they need very generic QoS configuration however they have shared the PE router configuration which gives an idea about service agreement what client has for traffic classification .

I have shared the PE router configuration below , client wants to mark the traffic for voice and video however according QoS model we will mark voice as EF (DSCP 46 ) which is not been seen in below service provider router .... i could see only cs4 , af41-43 is been matched ...

 

My question is , how do i proceed for QoS configuration on WAN router (CE router ) for voice and video without asking service provider to change or do any modification on PE router ?

 

your answer would be appreciated ..... if you could share me class-map with proper marking which will be carry forward with appropriate marking on PE for voice and video , that will be really great.....

 

 

PE router configuration is as below :

class-map match-any pe_af4_in_input
  match ip dscp cs4  af41
!
class-map match-any pe_af4_output
  match ip dscp cs4  af41  af42  af43
!
class-map match-any pe_mgmt_pnb_output
  match ip dscp 63
!
class-map match-any pe_mgmt_pnb_input
  match ip dscp 63
!
class-map match-any pe_af4_out_input
  match ip dscp af42  af43
!
policy-map abcd-IN-G4/1/0.xxx
  class pe_mgmt_pnb_input
    police 180000 13500 27000 conform-action set-mpls-exp-imposition-transmit 6 exceed-action set-mpls-exp-imposition-transmit 2 violate-action set-mpls-exp-imposition-transmit 2
  class pe_af4_in_input
    police 15072000 128500 257000 conform-action set-mpls-exp-imposition-transmit 6 exceed-action set-mpls-exp-imposition-transmit 2 violate-action set-mpls-exp-imposition-transmit 2
  class pe_af4_out_input
    police 8000 8000 8000 conform-action set-mpls-exp-imposition-transmit 2 exceed-action set-mpls-exp-imposition-transmit 2 violate-action set-mpls-exp-imposition-transmit 2
  class class-default
    police 8000 8000 8000 conform-action set-mpls-exp-imposition-transmit 5 exceed-action set-mpls-exp-imposition-transmit 5 violate-action set-mpls-exp-imposition-transmit 5
!
policy-map abcd-OUT-G4/1/0.xxx

  class pe_mgmt_pnb_output
    bandwidth 188
     random-detect dscp-based aggregate
     random-detect exponential-weighting-constant 6
     random-detect dscp values 63 minimum-thresh 32 maximum-thresh 51 mark-prob 10
  class pe_af4_output
    bandwidth 16582
     random-detect dscp-based aggregate minimum-thresh 129 maximum-thresh 206 mark-prob 10
     random-detect exponential-weighting-constant 10
     random-detect dscp values 36 minimum-thresh 39 maximum-thresh 103 mark-prob 5
     random-detect dscp values 38 minimum-thresh 39 maximum-thresh 103 mark-prob 5
  class class-default
    bandwidth 1842
     random-detect dscp-based aggregate minimum-thresh 26 maximum-thresh 69 mark-prob 5
     random-detect exponential-weighting-constant 7
     random-detect dscp values 48 minimum-thresh 86 maximum-thresh 138 mark-prob 10
!
policy-map abcd-POUT-G4/1/0.xxx
   class class-default
    shape average 18800000
   service-policy abcd-OUT-G4/1/0.xxx
!
policy-map abcd-PIN-G4/1/0.xxx
   class class-default
    police 20000000 141000 282000 conform-action transmit exceed-action drop violate-action drop
   service-policy abcd-IN-G4/1/0.xxx

 

5 REPLIES
Super Bronze

DisclaimerThe Author of this

Disclaimer

The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.

Liability Disclaimer

In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.

Posting

In answer to your question, you could encapsulate your traffic, in something like GRE, which will allow you to have an "outer" ToS that you can set to match your SP's QoS model or you might try to mark to match your SP's QoS model before sending your traffic to them and remarking SP received traffic to your QoS model.

Otherwise, and perhaps the better solution, would be to get your SP to "improve" their QoS model (which I won't comment further on).

New Member

 Hi Joseph, Thank you so much

 

Hi Joseph,

 

Thank you so much for your reply .... I would be going with marking to match my SP's QoS model before sending my traffic to SP.

It would be great if you could just put comment on below sample configuration for voice if anything i am missing or i can go ahead with this for rest of traffic.

 

ip access-list extended VVLAN-VOICE
Remark RTP
permit udp any any range 16384 32767


ip access-list extended VVLAN-SIGNALING
remark SCCP
permit tcp any any range 2000 2002

 

class-map match-any VOICE-TRAFFIC
match protocol rtp
match ip dscp cs5 ef
match access-group name VVLAN-VOICE
match access-group name VVLAN-SIGNALING

policy-map abcd-WAN-QOS

class VOICE-TRAFFIC
set ip dscp af41
Bandwidth percentage 20

policy-map abcd-WAN-QOS-OUT
 class class-default
    shape average 20000000
  service-policy abcd-WAN-QOS

interface <INTERFACE id>

service-policy output abcd-WAN-QOS-OUT

 

basically I would be matching the ef and then remarking to AF41 under policy map for voice or rather other video also i can do the same . since my SP is trusting AF41

 

could you please put comment on this ?

 

This will really help me to get more clarification on QoS

 

Super Bronze

DisclaimerThe Author of this

Disclaimer

The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.

Liability Disclaimer

In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.

Posting

I believe you're on the correct path.

You might want to use LLQ for your voice class.

You also might want to use the same Bc and Be parameters for your shaper as the provider's policer.

Your provider appears to have 3 classes, but it's unclear whether MPLS "2" is better or worse than MPLS "5".  If it's better, you might your VoIP signally to use it.  This to help avoid mark down of overrate MPLS "6" traffic.

New Member

Hi Joseph, Once again thanks

Hi Joseph,

 

Once again thanks for your reply and giving me confidence to proceed for further activity.

 

I am quite confused about reverse traffic coming from provider to my lan ...  according to PE configuration , PE is giving priority for AF41,42 & 43 and i need to carry forward the same till end .

How do i put policy for reverse traffic with same marking till destination in lan .

 

It would be great if you could share some sample configuration for this .

 

 

Super Bronze

DisclaimerThe Author of this

Disclaimer

The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.

Liability Disclaimer

In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.

Posting

Oh, that's pretty simple.  On your interface to the provider you add an ingress policy that matches ToS markings and/or other traffic attributes (like you're already done for your egress policy) and then you remark however you want.  For example:

 

class-map match-any service-provider-voice

match ip dscp af41

 

policy-map abcd-WAN-QOS-IN

class service-provider-voice

set ip dscp EF

 

interface <INTERFACE id>

service-policy input abcd-WAN-QOS-IN

service-policy output abcd-WAN-QOS-OUT

271
Views
0
Helpful
5
Replies
CreatePlease to create content