Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

QoS Shaping / Policy Map

So I'm trying to wrap my head around shapping and nested MQC. I have a site with a 10Mbps MPLS connection delivered via 100Mbps ethernet. So the CIR from the provider is 10Mbps. However when trying to stress test this thing with QoS enabled I can't ever seem to get above 4Mbps. I'm wondering if some QoS / Shapping experts can take a look at my config and tell me where I'm going wrong.

class-map match-any GDOI

match access-group name gdoi

class-map match-any VoIP-Bearer

description VoIP Bearer Channels

match ip dscp ef

class-map match-any Control

description VoIP Control Channels

match ip dscp af31

match ip dscp cs3

class-map match-any VideoConf

description Video Conferencing

match ip dscp af41

policy-map child_wan

class GDOI

    bandwidth remaining percent 10

class VoIP-Bearer

    priority percent 30

class Control

    bandwidth remaining percent 10

class VideoConf

    bandwidth remaining percent 25

class class-default

    bandwidth remaining percent 25

    fair-queue

     random-detect

policy-map SHAPE_TRAFFIC_FROM_WAN

class class-default

    shape average 9000000 90000

  service-policy child_wan

policy-map SHAPE_TRAFFIC_TO_WAN

class class-default

    shape average 10000000 100000

  service-policy child_wan

interface GigabitEthernet0/0

description Ethernet LAN/Switch

ip address X.X.X.X 255.255.255.252

no ip redirects

no ip unreachables

ip flow ingress

load-interval 30

duplex auto

speed auto

service-policy output SHAPE_TRAFFIC_FROM_WAN

interface GigabitEthernet0/1

description 10 MB Ethernet MPLS

mtu 1600

bandwidth 10000

ip address X.X.X.X 255.255.255.252

no ip redirects

no ip unreachables

ip flow ingress

ip flow egress

load-interval 30

duplex full

speed 100

no cdp enable

crypto map lanGDOI-map

service-policy output SHAPE_TRAFFIC_TO_WAN

~~~
Rate helpful posts
Blog - http://tripplehelix.net       

~~~ Rate helpful posts Blog - http://tripplehelix.net
Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
New Member

QoS Shaping / Policy Map

Hi Friend,

While I look into your config can I suggest you one thing, on your WAN interface GigabitEthernet0/1 can you please set the command speed 10 this way you will drive the physical inteface down to 10 mbps and hence no shaping will be needed.

HTH

Regards

Umesh Shetty

10 REPLIES
New Member

QoS Shaping / Policy Map

Hi Friend,

While I look into your config can I suggest you one thing, on your WAN interface GigabitEthernet0/1 can you please set the command speed 10 this way you will drive the physical inteface down to 10 mbps and hence no shaping will be needed.

HTH

Regards

Umesh Shetty

New Member

Re: QoS Shaping / Policy Map

Ugh great thanks Cisco forums, this is not possible the provider is giving us a 100Mbps PHY. Anyone know how to mark this as unanswered since I stupidly hit the correct answer button?

~~~
Rate helpful posts
Blog - http://tripplehelix.net

~~~ Rate helpful posts Blog - http://tripplehelix.net

QoS Shaping / Policy Map

What is your IOS version? I just ran into this problem where calculations weren't happening correctly because of a change in the IOS code. If you're higher than 12.4(20)T, you may need to put a bandwidth statement in your class default on the parent policy:

policy-map SHAPE_TRAFFIC_TO_WAN

class class-default

    shape average 10000000 100000

    bandwidth 10000

  service-policy child_wan

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
New Member

QoS Shaping / Policy Map

Currently running 12.4-22.T1, do you know the open bug ID on that?

~~~
Rate helpful posts
Blog - http://tripplehelix.net

~~~ Rate helpful posts Blog - http://tripplehelix.net

Re: QoS Shaping / Policy Map

There's no bug that I'm aware of, but your calculations could be way off. You have a post-hqf image, which Joseph, another engineer on this forum explained to me the other day.

There are a couple of questions that I have though.

How are you testing?

Is there anything else going through the router at the time of testing? If you have 6mb already allocated to something else, then you'll only have 4Mb left over to use.

Can you post "show policy-map inter"?

Can you post "show int"?

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
New Member

QoS Shaping / Policy Map

Hi Friend

Can you possibly post the output of the show policy-map interface GigabitEthernet0/1 and show interface

GigabitEthernet0 when the traffic is hitting 4 Mbps>

HTH

Regards

Umesh Shetty

New Member

Re: QoS Shaping / Policy Map

So here's the output, really I can barely get it to climb above 3Mbps.As far as testing I'm doing an extended ICMP ping with a payload of  18024 bytes from the router to my core router which is fed via a OC-3 which is barely at 10% utilization so I know it's not the bottle-neck. I'd expect this to get snapped up in the default-class which given there is little to no other traffic on the circuit should be able to burst above its allocation, which I do see given the offered rate is higher than the reservation.

show policy-map interface gi 0/1

GigabitEthernet0/1

  Service-policy output: SHAPE_TRAFFIC_TO_WAN

    Class-map: class-default (match-any)

      1361774 packets, 550748484 bytes

      30 second offered rate 2409000 bps, drop rate 0 bps

      Match: any

      Queueing

      queue limit 64 packets

      (queue depth/total drops/no-buffer drops) 0/75/0

      (pkts output/bytes output) 1535472/569634501

      shape (average) cir 10000000, bc 100000, be 100000

      target shape rate 10000000

      bandwidth 10000 kbps

      Service-policy : child_wan

        queue stats for all priority classes:

          Queueing

          queue limit 64 packets

          (queue depth/total drops/no-buffer drops) 0/0/0

          (pkts output/bytes output) 238575/40857018

        Class-map: GDOI (match-any)

          4 packets, 416 bytes

          30 second offered rate 0 bps, drop rate 0 bps

          Match: access-group name gdoi

            4 packets, 416 bytes

            30 second rate 0 bps

          Queueing

          queue limit 64 packets

          (queue depth/total drops/no-buffer drops) 0/0/0

          (pkts output/bytes output) 4/472

          bandwidth remaining 10% (700 kbps)

        Class-map: VoIP-Bearer (match-any)

          238575 packets, 40857018 bytes

          30 second offered rate 0 bps, drop rate 0 bps

          Match: ip dscp ef (46)

            238575 packets, 40857018 bytes

            30 second rate 0 bps

          Priority: 30% (3000 kbps), burst bytes 75000, b/w exceed drops: 0

        Class-map: Control (match-any)

          72685 packets, 10026382 bytes

          30 second offered rate 10000 bps, drop rate 0 bps

          Match: ip dscp af31 (26)

            31765 packets, 4247502 bytes

            30 second rate 5000 bps

          Match: ip dscp cs3 (24)

            40920 packets, 5778880 bytes

            30 second rate 5000 bps

          Queueing

          queue limit 64 packets

          (queue depth/total drops/no-buffer drops) 0/0/0

          (pkts output/bytes output) 72685/10026382

          bandwidth remaining 10% (700 kbps)

        Class-map: VideoConf (match-any)

          0 packets, 0 bytes

          30 second offered rate 0 bps, drop rate 0 bps

          Match: ip dscp af41 (34)

            0 packets, 0 bytes

            30 second rate 0 bps

          Queueing

          queue limit 64 packets

          (queue depth/total drops/no-buffer drops) 0/0/0

          (pkts output/bytes output) 0/0

          bandwidth remaining 25% (1750 kbps)

        Class-map: class-default (match-any)

          1050510 packets, 499864668 bytes

          30 second offered rate 2398000 bps, drop rate 0 bps

          Match: any

          Queueing

          queue limit 64 packets

          (queue depth/total drops/no-buffer drops/flowdrops) 0/75/0/75

          (pkts output/bytes output) 1224209/518750755

          bandwidth remaining 25% (1750 kbps)

          Fair-queue: per-flow queue limit 16

show int gi 0/1

GigabitEthernet0/1 is up, line protocol is up

  Hardware is MV96340 Ethernet, address is 000a.b86c.6829 (bia 000a.b86c.6829)

  Description: 10 MB Ethernet MPLS

  Internet address is X.X.X.X/30

  MTU 1600 bytes, BW 10000 Kbit/sec, DLY 100 usec,

     reliability 255/255, txload 93/255, rxload 88/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 100Mb/s, media type is T

  output flow-control is XON, input flow-control is XON

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 00:00:00, output 00:00:00, output hang never

  Last clearing of "show interface" counters 01:56:48

  Input queue: 1/75/0/0 (size/max/drops/flushes); Total output drops: 75

  Queueing strategy: Class-based queueing

  Output queue: 0/1000/0 (size/max total/drops)

  30 second input rate 3451000 bits/sec, 395 packets/sec

  30 second output rate 3656000 bits/sec, 434 packets/sec

     1312327 packets input, 756090532 bytes, 0 no buffer

     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 0 multicast, 0 pause input

     0 input packets with dribble condition detected

     1546347 packets output, 581824391 bytes, 0 underruns

     0 output errors, 0 collisions, 0 interface resets

     0 unknown protocol drops

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier, 0 pause output

     0 output buffer failures, 0 output buffers swapped out

~~~
Rate helpful posts
Blog - http://tripplehelix.net

~~~ Rate helpful posts Blog - http://tripplehelix.net
New Member

Re: QoS Shaping / Policy Map

Hi Friend,

I doubt if pinging from the router with a high payload will be able to generate the amount of load you intend to. I would suggest use a tool such as Iperf to generate the load. You could even try transferring some large data between two systems at the branch and headqaurters end. This will help you put actual load and test the BW on the link

HTH

Regards

Umesh Shetty

Re: QoS Shaping / Policy Map

I agree with Umesh. You're going to need something more than an extended ping. Are you using a timeout of 0 when you're doing it? Either way, what does the normal utilization of the link look like? You said that you can barely get it above 3Mb, and if you're truly hitting class default, you've guaranteed 1750 to this class. You could be butting up against other classes that are already taking the bandwidth.

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
New Member

Re: QoS Shaping / Policy Map

That's the thing normally the link is pretty empty. I managed doing a delay of 0 getting the link up to 4.2mbps, I do have some minor traffic 150kbps in other queues but it seems like this is caping out around 4.2mbps. I am getting a machine put on the LAN to do an iperf with since I think you might be right the rotuer just can't generate enough traffic.

~~~
Rate helpful posts
Blog - http://tripplehelix.net

~~~ Rate helpful posts Blog - http://tripplehelix.net
1045
Views
0
Helpful
10
Replies
CreatePlease to create content