Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

QoS traffic shaping question

I have a 150MB internet pipe coming into a 3750 switch..from that 3750 switch i have 15 ports (they are L3 routed ports) connecting to customers. What i want is to guarentee each customer 10MB of internet at all times, but if there is more available (another customer is only using 2 of their 10MB) allow the customer who needs more then 10MB to burst...

Any ideas what the best way is to do this? any examples would be greatly appreciated

8 REPLIES
New Member

Re: QoS traffic shaping question

Something similar to this should work as a basic way to get your desired results. All of the layer 3 interfaces this was applied to would get a minimum of 10 meg and can use more if available.

ip access-list All_Traffic

permit ip any any

class-map match Output_Traffic

match access-group name All_Traffic

!

!

policy-map Bandwidth_Control

class Output_Traffic

bandwidth 10000000

!

interface GigabitEthernet0/*

ip address x.x.x.x x.x.x.x

service-policy output Bandwidth_Control

Re: QoS traffic shaping question

Hi Shaun

u could use a similar config as per previous reply. but avoid using ACL, use class default instead, so same as ip any any but less CPU. also, shape instead of using BW statement.

In order to get some kind of sharing between your ports, you need to have them grouped.

the bandwidth statement would allow one class under same policy map to use left overs from another class but not when you have a policy applied to more than one interface.

You coud try to shape to peak instead of average and police inbound on your 150Mb. so your customers can peak but not all of them at same time.

If you shape at peak and use a PIR equal to CIR you can in effect double the rate..so 20MB.

HTH

Sam

New Member

Re: QoS traffic shaping question

Sam,

Do you have an example you could submit? Whatever works best...i just need to guarentee 10MB at ALL times to all sites. If one site isnt using the full 10, then another site can use that bw...

TIA

Re: QoS traffic shaping question

Shaun

below you have option to shape to average or peak. parameters to tweak are Bc/Be and CIR and PIR as previos;y stated (these are ATM and Frame relay terms).

as I said before, I do not know of any ways to get the desired result, ie sharing of overall 150Mb if one customer is under utilising his link.

Policy-map INTERNET

Class class-default

Shape average 10000000 1250000 ( BC=1250000 or a Tc =125ms)

!

Interface Gigabit 0/2

Service-policy output INTERNET

Or

Policy-map INTERNET

Class class-default

Shape peak 10000000 125000000 1250000 ( BC=BE=1250000 or a Tc =125ms)

!

Interface Gigabit 0/2

Service-policy output INTERNET

New Member

Re: QoS traffic shaping question

Using the shaping will do just that. It will shape the traffic even though additional bandwidth is available. I think he wanted to be able to use the bandwidth if needed, thats why I suggested the bandwidth statment, which woul garanteee the bandwidth during times of saturation.

Re: QoS traffic shaping question

I know :-)

BW statement wil guarantee BW, but in this case where each interface has its own service policy you will not be able to make use of unused BW from other customers.

so you shape, or use BW wont solve teh issue. what I suggested it to shape to peak and this shoudl double up the offered rate.

New Member

Re: QoS traffic shaping question

well neither of those work for me..im using a Cisco 3750 switch which doesnt support the bandwidth or shape statements...so i had to use a policier...unless you guys know of something else?

Re: QoS traffic shaping question

if u can add another L3 box to your set up you can have a design that would meet your requirement.

[INTERNET]---RTR---3750---[CUSTOMERS]

On RTR you set up access vlan 100 facing internet. and 10 subinterfaces in Q-in-Q set up , so outer VLAN 100 and inner VLANs from 10, 15,20 etc...with dot1q primary and secondary vlan.

on your 3750, facing RTR, you set up VLAN stack or Q-in-Q as well.

at this stage you wil have 10 Vlans for custmers, all running within a same outer VLAN 100.L3 termination is done at RTR level and your 3750 ports towards customers are switchports, acces VLAN's if u want.

this gives you the ability to group the traffic and control it at RTR level. you then make a policy map using BW statement fot the whole phusical interface connected to your 3750...this way BW will be shared.

your subintefaces terminated on 3750 needs to have service policies with BW statement. in this case you may to try to shape at 150Mb on the physical interface.

NB: an RTR that supports Q-in-Q termination is not cheap, and testing of this setup is required.

few hints on config

RTR

interface GigabitEthernet0/1.1200013

encapsulation dot1Q 100 second-dot1q 15

3750

interface GigabitEthernet0/10

switchport access vlan 100

switchport mode dot1q-tunnel

HTH and sorry for the long reply.

Sam

306
Views
0
Helpful
8
Replies
CreatePlease to create content