Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

QOS traffic shaping

I am looking for some sort of validation or probably better recommendation for a traffic shaping design that we plan on implementing (service policy outbound) at the hub with dual Cisco7206 routers, each with 150M circuit facing to MPLS service provider.  The servers are mostly located at the hub and the traffic pattern is basically hub and spoke that talk to around 200 remote sites with various circuit speed from T1 to 20M.

The objective is for the hub not to send traffic to a site at a higher bandwidth that the site can handle.   I have defined that in the class-map and ACL for two sites but there will be more. My concern is for the remaining sites that are not explicitly defined.. they shouldn’t be shaped and should be able to use all available bandwidth of 150M.   In the sample configuration below, I used shape peak percent 100 statement for all remaining site but need more validation.

Thanks in Advance!

----------------------------------------

ip access-list extended ACL-Site1

permit ip any 165.179.171.0 0.0.0.127

permit ip any 10.146.1.0 0.0.0.255

!

ip access-list extended ACL-Site2

permit ip any 10.80.192.0 0.0.1.255

permit ip any 10.80.195.0 0.0.0.255

!

ip access-list extended ACL-Any

permit ip any any

!

class-map match-any Site1

match access-group name ACL-Site1

class-map match-all Site2

match access-group name ACL-Site2

class-map match-all Remaining_Sites

match access-group name ACL-Any

!

class-map match-any Class-EF

match ip dscp ef

class-map match-any Class-AF41

match ip dscp af41

class-map match-any Class-AF31

match ip dscp af31

class-map match-any Class-AF21

match ip dscp af21

class-map match-any Class-AF11

match ip dscp af11

class-map match-any Class-BE

match ip dscp default

!

policy-map vz-etm-Sub-Policy

class Class-EF

   priority percent 10

class Class-AF41

   bandwidth remaining percent 25

class Class-AF31

   bandwidth remaining percent 40

class Class-AF21

   bandwidth remaining percent 20

class Class-AF11

   bandwidth remaining percent 10

class Class-BE

   bandwidth remaining percent 4

!

policy-map vz-etm

class Site1

   shape average 6000000

   service-policy vz-etm-Sub-Policy

class Site2

   shape average 2000000

   service-policy vz-etm-Sub-Policy

class Remaining_Sites

shape peak percent 100

   service-policy vz-etm-Sub-Policy

!

policy-map shape

class class-default

   shape average 141176000 564704 33664

service-policy vz-etm

!

interface GigabitEthernet0/1.871

bandwidth 150000

service-policy output shape

Everyone's tags (4)
446
Views
0
Helpful
0
Replies
CreatePlease to create content