Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

QOS

IOS Version 12.2(12a)

I need to implement QOS to Prioritize VOIP traffic.

Router has 2 interfaces

FastE 1

FastE 2

I have set up my Class map and policy map

I have tried to change class-default to fair-queue but nothing changes, it does not show in my config or when I do a show int.

Any sugestions on how to make this qos solution better?

Here is my config -

class-map match-any VOIP

match ip rtp 16384 16383

match access-group 100

match ip precedence 5

match ip dscp ef

!

!

policy-map qos-policy

class VOIP

set ip precedence 5

class class-default

!

!

!

!

interface FastEthernet0

description WAN

full-duplex

!

interface FastEthernet1

description LAN

full-duplex

service-policy input qos-policy

!

access-list 100 permit udp any any eq 5060

access-list 100 permit udp any any eq 5061

Thanks,

13 REPLIES
New Member

Re: QOS

You can also use NBAR to prioritize traffic based on protocol instead of using access-list if your router is capable of handling it.

You marked packets as "ip precedence 5 and ef"...which means the same thing, just different field in the packet that's being marked. Use EF as the standard.

class-map match-any VOIP

match ip dscp ef

match ip rtp 16384 16383

match ip access-group 100

class-map match-any VOIP-Signaling

match ip dscp cs3

policy-map qos-policy

class VOIP

priority percent (of your bandwidth that you would like to designate for VOIP)

class VOIP-Signaling

bandwidth percent 5 (default as recommended by Cisco)

class class-default

bandwidth percent (of your bandwidth that you would like to designate for class-default)

random-detect dscp-based

By default, cisco wont' allow you to use more than 75% of BW, so you can use this command to override it (max-reserved bandwith 100) if you want, then apply the policy-map "service-policy output qos-policy" to your interface.

HTH,

hieu

Pls rate post if helpful.

New Member

Re: QOS

When I am setting a percentage of bandwidth, what is that a percentage of? The 100mbs ethernet connection?

The WAN uplink goes into a wireless connection that is slower then 100mbs.

Thanks,

Re: QOS

Friend,

It is better to apply QoS as an Output policy since it will prioritize the traffic on the slower interface.

Service-policy output

HTH, rate if it does

Narayan

New Member

Re: QOS

In your case, that's the 100MBits ethernet connection of your FE1.

Gold

Re: QOS

When you have a situation as you describe it really doesn't matter what you configure. QoS setting have little impact until you have caused a queue on the interface. Since you have a bottleneck past your router you will have problems long before your ethernet port becomes conjested.

You will need to cause a artifcial queue on your ethernet port to prevent the traffic from being send into your wan network too quickly.

Something like

policy shape

Class class-default

shape average 100000

service-policy QoS-policy

This cause it to first shape all traffic to a desired rate and then apply the service policy to that traffic after it is limited

New Member

Re: QOS

Good to know, thanks Tim.

hieu

New Member

Re: QOS

I may be completely wrong but i was under the impression that regaurdless of the utilization, prioritized packets still get transmitted first?

When you say

shape average 100000

do I adjust this value to the bottleneck rate?

Thanks,

Gold

Re: QOS

In a way yes it does transmit them first but first implies there is more than one packet then you have a queue and QoS is in effect.

If a packet arives and the interface is idle it will be tranmitted immediately. If a voice packet now comes in it will not stop tranmiting the first packet and send the voice packet. On fast interfaces like this it makes no difference it is pretty mush fifo unless you get a burst of traffic.

Yes 100000 is just a random sample I used.

New Member

Re: QOS

Ok, just so I understand correctly-

So if the link utilization is at 50% for a sustained period, QOS will still transmit priortized packets first before packets classified as class-default?

Thanks,

New Member

Re: QOS

Also, when I create:

policy shape

Class class-default

shape average 100000

service-policy QoS-policy

I would then apply on my interface

( service-policy output shape ) ?

Both of my ethernet ports have a bottleneck on each side, what interface should I apply this policy to and what direction?

Thanks again,

New Member

Re: QOS

hi,

i would also mark packets in the default-class with 1 or 2 or 3.

so it would not possible that a ip device (pc or whatever) sends pakets with ip prec=5 and goes into the voice queue

New Member

Re: QOS

My new configuration -

(classification is done at the endpoints)

class-map match-any voip-signal

match ip dscp cs3

match ip dscp af31

class-map match-any voip-media

match ip dscp ef

!

!

policy-map qos-policy

class voip-media

bandwidth percent 75

class voip-signal

bandwidth percent 5

class class-default

fair-queue

policy-map shape-wan

class class-default

shape average 48800000

service-policy qos-policy

!

!

!

!

!

interface FastEthernet0

description WAN

bandwidth 48800

full-duplex

service-policy output shape-wan

!

interface FastEthernet1

description LAN

bandwidth 33000

There is a wireless link on both sides (lan) and (wan), should I be applying the policy to both interfaces?

I would want the default class marked with dscp 0 (best effort) I thought this was the default behavior?

Thanks,

New Member

Re: QOS

Dan,

It's not neccessary that you've to apply the same policy to both FE0 and FE1. Just the FE0(WAN) will do, but also config it the same at the other end of the WAN link and monitor its performance from both ends.

Class class-default is already set at dscp 0 as the default setting.

hieu

227
Views
4
Helpful
13
Replies