Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Question about BGP routing

Hello, I have a question about BGP/OSPF routing. Please see the scenario

example Router A                                                

GI1/1 10.10.2.1/30 -----EBGP link to router B

Router BGP 500

neighbor 10.10.2.2 remote-as 600

example Router B

GI1/1 10.10.2.2/30 -----EBGP link

VLAN 5 192.168.1.6/30

loop0 192.168.1.2

GI1/2 switchport access VLAN 5

Router BGP 600

neighbor 10.10.2.1 remote-as 500 ------  EBGP link to router A

neighbor 192.168.1.1 remote-as 600 ------- IBGP link to router C

!

Router OSPF 600

passive-interface default

no passive-interface vlan 5

network 192.168.1.2 0.0.0.0 area 0
network 192.168.1.6 0.0.0.0 area 0

Assuming Router B has an IBGP connection to Router C.

example Router C

VLAN 5 192.168.1.5/30

loop0 192.168.1.1

GI1/2 switchport access VLAN 5

Router BGP 600

neighbor 192.168.1.2 remote-as 600 ------ IBGP link to router B

!

Router OSPF 600

passive-interface default

no passive-interface vlan 5

network 192.168.1.1 0.0.0.0 area 0
network 192.168.1.5 0.0.0.0 area 0

network 192.168.1.9 0.0.0.0 area 0

when I do a show ip route 192.168.1.9 form router A, I get the below output.

sh ip ro 192.168.1.9

Routing entry for 192.168.1.8/30
  Known via "bgp 500", distance 20, metric 0
  Tag 600, type external
  Last update from 10.10.2.2 7w0d ago
  Routing Descriptor Blocks:
  * 10.10.2.2, from 10.10.2.2, 7w0d ago
      Route metric is 0, traffic share count is 1
      AS Hops 1
      Route tag 600

My question is how is it that I have a route entry in Router A known via BGP when BGP is not advertising any networks on any of the routers and OSPF is not being redistributed into BGP?

Note - There is a route-map on Router A that basically says Router A can only advertise the default-route out to router B. Please let me know if anything needs to be clarified. Thanks,

2 REPLIES
VIP Super Bronze

Re: Question about BGP routing

Hi,

Based on the configs you posted, I see a couple of issues with your design.

1-Network 10.10.2.0 is not being advertised to OSPF on router-B, so if you try to ping 10.10.2.1 or 2 from router-C it will not work.

2-You have configured the IBGP connectivity between Router-B and Router-C with physical IP addressess. although it works, it is not a common practice.

for IBGP you should use the loopback interfaces to peer.

3-Do you have end-to-end IP connectivity in this network?

HTH

Reza

Hall of Fame Super Silver

Re: Question about BGP routing

Hello,

>> My question is how is it that I have a route entry in Router A known via BGP when BGP is not advertising any networks on any of the routers and OSPF is not being redistributed into BGP?

please post

sh ip bgp 192.168.1.8 taken on RB, the node that has an eBGP session with Ra

Hope to help

Giuseppe

215
Views
0
Helpful
2
Replies
CreatePlease to create content