Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

question about the design

Hi,

I will setup one data center in China. Enclosed the design.

There are two routers with three interfaces. FE0/0 is for Provider and both routers (FE0) are running HSRP. Provider IP is 172.16.128.4. All inbound traffic will go to 172.16.128.3. If Router A is down, Router B can take care the inbound traffic.

!R1

interface FastEthernet0/0

ip address 172.16.128.1 255.255.255.248

standby 1 ip 172.16.128.3

standby 1 priority 110

standby 1 preempt

!

ip route 0.0.0.0 0.0.0.0 172.16.128.4

!R2

interface FastEthernet0/0

ip address 172.16.128.2 255.255.255.248

standby 1 ip 172.16.128.3

standby 1 preempt

!

ip route 0.0.0.0 0.0.0.0 172.16.128.4

For the internal traffic, I assign two interfaces FE1 and FE2. both of them are running HSRP. They are connect to different ethernet switch. The LAN is connected to two ethernet switches. If one ethernet switch goes down, another ethernet switch can be function properly to handle the LAN traffic. the default gateway of PC points to 192.168.128.10

! R1

interface FastEthernet0/1

ip address 192.168.128.1 255.255.255.0

standby 1 ip 192.168.128.10

standby 1 priority 110

standby 1 preempt

standby 1 track FE0

!R2

interface FastEthernet0/1

ip address 192.16.128.2 255.255.255.0

standby 1 ip 192.168.128.10

standby 1 preempt

standby 1 track FE0

! R1

interface FastEthernet0/2

ip address 192.168.128.3 255.255.255.0

standby 1 ip 192.168.128.10

standby 1 priority 110

standby 1 preempt

standby 1 track FE0

!R2

interface FastEthernet0/2

ip address 192.16.128.4 255.255.255.0

standby 1 ip 192.168.128.10

standby 1 preempt

standby 1 track FE0

I would like to achieve below:

1. For internal, two ethernet switches are installed to avoid the single point of failure. if one is down, other will be function.

2. if there are two LAN cards in servers, one etherenet switch goes down, the traffic can go second LAN card. there is no down time

3. if Router A goes down, all traffic will go router B. there is no down time for internal

4. for the external, if the router A goes down, the in/out traffic will not be affected

5. for the external, if the ethernet switch is down, all traffic cannot go outside. (any idea to solve the single point of failure ?)

How do I re-design the network to meet above requirement?

rgds

4 REPLIES
New Member

Re: question about the design

Hi,

Your design is perfectly right. Because you have single ISP connection, you need not to place one more switch. Think about your wan connection, if that fails.

regards

skrao

New Member

Re: question about the design

Hi,

any idea regarding WAN connection?

how to put two interfaces in the same segment for internal LAN?

rgds

Bronze

Re: question about the design

Hi

Is your internal network a flat network??,ie no vlan etc.

As per the configuration and diagram u gave ,all internal devices cannot have default gateway as 192.168.128.10,because in routers the interface ip fa0/1 and fa0/2 are in different subnets(192.168.128.X and 192.16.128.X ) and u are giving same ip as virtual ip(192.168.128.10) on both interfaces.Since ur switch is a layer 2 switch ,i dont think this would work..

Divide the internal network into two networks,ie two vlan with subnets 192.168.128.0/24(say vlan 10) and 192.16.128.0/24(say vlan 20).Then put the virtual ip in fa0/1 as 192.168.128.10(default gateway for vlan 10) and in fa0/2 as 192.16.128.10(default gateway for vlan 20) on routers 1 hsrp configuration and appropriatly in router 2..

arun

New Member

Re: question about the design

Hi Arun,

yes, tyo error, the ip address is

!R2

interface FastEthernet0/1

ip address 192.168.128.2 255.255.255.0

standby 1 ip 192.168.128.10

!

R2

interface FastEthernet0/2

ip address 192.168.128.4 255.255.255.0

standby 1 ip 192.168.128.10

standby 1 preempt

standby 1 track FE0

I know that it does not work. How to config it to meet the requirement? pls advise

rdgs

244
Views
0
Helpful
4
Replies