Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Question on BGP routing

   Hi,

I have configured 5 routers with BGP as in the image for testing purpose.

Untitled.jpg    

I have assign loopback addresses on each router and each router get all route informations as intended. But when I try to ping from router E to router A it is not success. But when I try sh ip bgp on E it shows Router A's networks can reach trough router C. Router C can ping to loopback of router A. Router A , C, E in different ASs. No ACLs configured due to testings. How can I troubleshoot this?

thank you

Chamara

Thank you for helping on this. Here I listed all the information you need.

thank you again

kind regards

Chamara

A - AS1 , B,C in AS2 , D in AS3, E in AS4

Router A

interface Serial0/0/0

ip address 10.1.1.1 255.255.255.252

!

interface Serial0/0/1

ip address 10.1.2.1 255.255.255.252

!

router bgp 1

bgp log-neighbor-changes

no synchronization

neighbor 10.1.1.2 remote-as 2

neighbor 10.1.2.2 remote-as 2

network 1.1.1.0 mask 255.255.255.0

----

Router#sh ip bgp

BGP table version is 21, local router ID is 1.1.1.1

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

              r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path

*> 1.1.1.0/24        0.0.0.0                  0     0 32768 i

*> 2.2.2.0/24        10.1.1.2                 0     0     0 2 i

*> 3.3.3.0/24        10.1.2.2                 0     0     0 2 i

*  4.4.4.0/24        10.1.2.2                 0     0     0 3 4 2 i

*>                   10.1.1.2                 0     0     0 3 2 i

*> 5.5.5.0/24        10.1.2.2                 0     0     0 4 2 i

*                    10.1.1.2                 0     0     0 4 3 2 i

------------------------

Router B

interface Serial0/0/0

ip address 10.1.1.2 255.255.255.252

clock rate 64000

!

interface Serial0/0/1

ip address 10.1.3.2 255.255.255.252

!

router bgp 2

bgp log-neighbor-changes

no synchronization

neighbor 10.1.3.1 remote-as 3

neighbor 10.1.1.1 remote-as 1

network 2.2.2.0 mask 255.255.255.0

---------------------------------------

Router#sh ip bgp

BGP table version is 11, local router ID is 2.2.2.2

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

              r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path

*> 1.1.1.0/24        10.1.1.1                 0     0     0 1 i

*> 2.2.2.0/24        0.0.0.0                  0     0 32768 i

*> 4.4.4.0/24        10.1.3.1                 0     0     0 3 i

*> 5.5.5.0/24        10.1.3.1                 0     0     0 4 3 i

---------------------------------------

Router C

interface Serial0/0/0

ip address 10.1.2.2 255.255.255.252

clock rate 64000

!

interface Serial0/0/1

ip address 10.1.5.2 255.255.255.252

!

router bgp 2

bgp log-neighbor-changes

no synchronization

neighbor 10.1.2.1 remote-as 1

neighbor 10.1.5.1 remote-as 4

network 3.3.3.0 mask 255.255.255.0

-----------------------

Router#sh ip bgp

BGP table version is 9, local router ID is 3.3.3.3

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

              r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path

*> 1.1.1.0/24        10.1.2.1                 0     0     0 1 i

*> 3.3.3.0/24        0.0.0.0                  0     0 32768 i

*> 4.4.4.0/24        10.1.5.1                 0     0     0 3 4 i

*> 5.5.5.0/24        10.1.5.1                 0     0     0 4 i

Router#ping 1.1.1.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 2/4/5 ms

Router#sh ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

       * - candidate default, U - per-user static route, o - ODR

       P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/24 is subnetted, 1 subnets

B       1.1.1.0 [20/0] via 10.1.2.1, 07:40:50

     3.0.0.0/24 is subnetted, 1 subnets

C       3.3.3.0 is directly connected, Loopback1

     4.0.0.0/24 is subnetted, 1 subnets

B       4.4.4.0 [20/0] via 10.1.5.1, 07:40:50

     5.0.0.0/24 is subnetted, 1 subnets

B       5.5.5.0 [20/0] via 10.1.5.1, 07:40:50

     10.0.0.0/30 is subnetted, 2 subnets

C       10.1.2.0 is directly connected, Serial0/0/0

C       10.1.5.0 is directly connected, Serial0/0/1

-------------------------

Router D

interface Serial0/0/0

ip address 10.1.3.1 255.255.255.252

clock rate 64000

!

interface Serial0/0/1

ip address 10.1.4.2 255.255.255.252

!

!

router bgp 3

bgp log-neighbor-changes

no synchronization

neighbor 10.1.4.1 remote-as 4

neighbor 10.1.3.2 remote-as 2

network 4.4.4.0 mask 255.255.255.0

!

----------------------------------------

Router#sh ip bgp

BGP table version is 16, local router ID is 4.4.4.4

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

              r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path

*  1.1.1.0/24        10.1.4.1                 0     0     0 1 2 4 i

*>                   10.1.3.2                 0     0     0 1 2 i

*> 2.2.2.0/24        10.1.3.2                 0     0     0 2 i

*> 3.3.3.0/24        10.1.4.1                 0     0     0 2 4 i

*> 4.4.4.0/24        0.0.0.0                  0     0 32768 i

*> 5.5.5.0/24        10.1.4.1                 0     0     0 4 i

-----------------------------------------

Router E

interface Serial0/0/0

ip address 10.1.5.1 255.255.255.252

clock rate 64000

!

interface Serial0/0/1

ip address 10.1.4.1 255.255.255.252

clock rate 64000

!

!

router bgp 4

bgp log-neighbor-changes

no synchronization

neighbor 10.1.4.2 remote-as 3

neighbor 10.1.5.2 remote-as 2

network 5.5.5.0 mask 255.255.255.0

------------------------------------------------------

Router# sh ip bgp

BGP table version is 15, local router ID is 5.5.5.5

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

              r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path

*> 1.1.1.0/24        10.1.5.2                 0     0     0 1 2 i

*                    10.1.4.2                 0     0     0 1 2 3 i

*> 2.2.2.0/24        10.1.4.2                 0     0     0 2 3 i

*> 3.3.3.0/24        10.1.5.2                 0     0     0 2 i

*> 4.4.4.0/24        10.1.4.2                 0     0     0 3 i

*> 5.5.5.0/24        0.0.0.0                  0     0 32768 i

Router#ping 1.1.1.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

Router#traceroute 1.1.1.1

Type escape sequence to abort.

Tracing the route to 1.1.1.1

  1   10.1.5.2        4 msec    1 msec    3 msec   

  2   *     *     *    

  3   *     *     *    

  4   *     *     *    

  5   *     *     *    

  6   *     *     *    

Router#sh ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

       * - candidate default, U - per-user static route, o - ODR

       P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/24 is subnetted, 1 subnets

B       1.1.1.0 [20/0] via 10.1.5.2, 07:42:36

     2.0.0.0/24 is subnetted, 1 subnets

B       2.2.2.0 [20/0] via 10.1.4.2, 07:42:36

     3.0.0.0/24 is subnetted, 1 subnets

B       3.3.3.0 [20/0] via 10.1.5.2, 07:42:36

     4.0.0.0/24 is subnetted, 1 subnets

B       4.4.4.0 [20/0] via 10.1.4.2, 07:42:36

     5.0.0.0/24 is subnetted, 1 subnets

C       5.5.5.0 is directly connected, Loopback1

     10.0.0.0/30 is subnetted, 2 subnets

C       10.1.4.0 is directly connected, Serial0/0/1

C       10.1.5.0 is directly connected, Serial0/0/0

------------------------------------------------------

Thank you for helping on this. Here I listed all the information you need.

thank you again

kind regards
Chamara


A - AS1 , B,C in AS2 , D in AS3, E in AS4

Router A
interface Serial0/0/0
ip address 10.1.1.1 255.255.255.252
!
interface Serial0/0/1
ip address 10.1.2.1 255.255.255.252

!
router bgp 1
bgp log-neighbor-changes
no synchronization
neighbor 10.1.1.2 remote-as 2
neighbor 10.1.2.2 remote-as 2
network 1.1.1.0 mask 255.255.255.0


----
Router#sh ip bgp
BGP table version is 21, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 1.1.1.0/24        0.0.0.0                  0     0 32768 i
*> 2.2.2.0/24        10.1.1.2                 0     0     0 2 i
*> 3.3.3.0/24        10.1.2.2                 0     0     0 2 i
*  4.4.4.0/24        10.1.2.2                 0     0     0 3 4 2 i
*>                   10.1.1.2                 0     0     0 3 2 i
*> 5.5.5.0/24        10.1.2.2                 0     0     0 4 2 i
*                    10.1.1.2                 0     0     0 4 3 2 i
------------------------

Router B

interface Serial0/0/0
ip address 10.1.1.2 255.255.255.252
clock rate 64000
!
interface Serial0/0/1
ip address 10.1.3.2 255.255.255.252

!
router bgp 2
bgp log-neighbor-changes
no synchronization
neighbor 10.1.3.1 remote-as 3
neighbor 10.1.1.1 remote-as 1
network 2.2.2.0 mask 255.255.255.0
---------------------------------------
Router#sh ip bgp
BGP table version is 11, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 1.1.1.0/24        10.1.1.1                 0     0     0 1 i
*> 2.2.2.0/24        0.0.0.0                  0     0 32768 i
*> 4.4.4.0/24        10.1.3.1                 0     0     0 3 i
*> 5.5.5.0/24        10.1.3.1                 0     0     0 4 3 i
---------------------------------------

Router C


interface Serial0/0/0
ip address 10.1.2.2 255.255.255.252
clock rate 64000
!
interface Serial0/0/1
ip address 10.1.5.2 255.255.255.252

!
router bgp 2
bgp log-neighbor-changes
no synchronization
neighbor 10.1.2.1 remote-as 1
neighbor 10.1.5.1 remote-as 4
network 3.3.3.0 mask 255.255.255.0

-----------------------
Router#sh ip bgp
BGP table version is 9, local router ID is 3.3.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 1.1.1.0/24        10.1.2.1                 0     0     0 1 i
*> 3.3.3.0/24        0.0.0.0                  0     0 32768 i
*> 4.4.4.0/24        10.1.5.1                 0     0     0 3 4 i
*> 5.5.5.0/24        10.1.5.1                 0     0     0 4 i

Router#ping 1.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/4/5 ms

Router#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/24 is subnetted, 1 subnets
B       1.1.1.0 [20/0] via 10.1.2.1, 07:40:50
     3.0.0.0/24 is subnetted, 1 subnets
C       3.3.3.0 is directly connected, Loopback1
     4.0.0.0/24 is subnetted, 1 subnets
B       4.4.4.0 [20/0] via 10.1.5.1, 07:40:50
     5.0.0.0/24 is subnetted, 1 subnets
B       5.5.5.0 [20/0] via 10.1.5.1, 07:40:50
     10.0.0.0/30 is subnetted, 2 subnets
C       10.1.2.0 is directly connected, Serial0/0/0
C       10.1.5.0 is directly connected, Serial0/0/1

-------------------------


Router D


interface Serial0/0/0
ip address 10.1.3.1 255.255.255.252
clock rate 64000
!
interface Serial0/0/1
ip address 10.1.4.2 255.255.255.252
!
!
router bgp 3
bgp log-neighbor-changes
no synchronization
neighbor 10.1.4.1 remote-as 4
neighbor 10.1.3.2 remote-as 2
network 4.4.4.0 mask 255.255.255.0
!

----------------------------------------

Router#sh ip bgp
BGP table version is 16, local router ID is 4.4.4.4
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*  1.1.1.0/24        10.1.4.1                 0     0     0 1 2 4 i
*>                   10.1.3.2                 0     0     0 1 2 i
*> 2.2.2.0/24        10.1.3.2                 0     0     0 2 i
*> 3.3.3.0/24        10.1.4.1                 0     0     0 2 4 i
*> 4.4.4.0/24        0.0.0.0                  0     0 32768 i
*> 5.5.5.0/24        10.1.4.1                 0     0     0 4 i

-----------------------------------------


Router E

interface Serial0/0/0
ip address 10.1.5.1 255.255.255.252
clock rate 64000
!
interface Serial0/0/1
ip address 10.1.4.1 255.255.255.252
clock rate 64000
!
!
router bgp 4
bgp log-neighbor-changes
no synchronization
neighbor 10.1.4.2 remote-as 3
neighbor 10.1.5.2 remote-as 2
network 5.5.5.0 mask 255.255.255.0


------------------------------------------------------

Router# sh ip bgp
BGP table version is 15, local router ID is 5.5.5.5
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 1.1.1.0/24        10.1.5.2                 0     0     0 1 2 i
*                    10.1.4.2                 0     0     0 1 2 3 i
*> 2.2.2.0/24        10.1.4.2                 0     0     0 2 3 i
*> 3.3.3.0/24        10.1.5.2                 0     0     0 2 i
*> 4.4.4.0/24        10.1.4.2                 0     0     0 3 i
*> 5.5.5.0/24        0.0.0.0                  0     0 32768 i


Router#ping 1.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

Router#traceroute 1.1.1.1
Type escape sequence to abort.
Tracing the route to 1.1.1.1

  1   10.1.5.2        4 msec    1 msec    3 msec   
  2   *     *     *    
  3   *     *     *    
  4   *     *     *    
  5   *     *     *    
  6   *     *     *  

Router#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/24 is subnetted, 1 subnets
B       1.1.1.0 [20/0] via 10.1.5.2, 07:42:36
     2.0.0.0/24 is subnetted, 1 subnets
B       2.2.2.0 [20/0] via 10.1.4.2, 07:42:36
     3.0.0.0/24 is subnetted, 1 subnets
B       3.3.3.0 [20/0] via 10.1.5.2, 07:42:36
     4.0.0.0/24 is subnetted, 1 subnets
B       4.4.4.0 [20/0] via 10.1.4.2, 07:42:36
     5.0.0.0/24 is subnetted, 1 subnets
C       5.5.5.0 is directly connected, Loopback1
     10.0.0.0/30 is subnetted, 2 subnets
C       10.1.4.0 is directly connected, Serial0/0/1
C       10.1.5.0 is directly connected, Serial0/0/0

------------------------------------------------------

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
Silver

Re: Question on BGP routing

Hi Chamara,

John is right.

you means Do I have to configure all connection IPs with network command?  if it is like that how can I configure this kind of scenario with ISPs?

Well you don't have to since you don't care about advertising the internal 10.X.X.X that are used only for neighbor definition and p2p connections with other routers, right?

The only reason that you think you have a problem is because your routers do not know about other than connected 10.X.X.X networks and that's why the ping/traceroute fails. If you would do it as John suggests, you will find no problems in the setup. If you intended the other routers to know about 10.X.X.X network as well then do so via static or dynamic routing but that is not necessary if you want just the loopbacks (and other networks specified in bgp through the network command as well) to communicate with each other.

Best regards,

Jan

7 REPLIES
Hall of Fame Super Blue

Re: Question on BGP routing

Chamara

           

It would help us if your post included -

1) a diagram showing which routers were in which AS together with IP addresses

2) the "sh ip bgp" and "sh ip route" for routers which you are having problems with

3) the BGP configurations of all routers. Note without knowing the IPs (see 1)) it can be hard to make sense of the configurations.

Jon

Community Member

Re: Question on BGP routing

Let assume. All are in same autonmous system..

Kindly share the BGP configuration in each router.

U able to see the Router A ip address and Router E. But u not able to reach the  Router A.

Check the  Router E have route to reach the Router A  by Sh Ip route command on Router A.

BGP can learn the routes through BGP. But it can reach Router A  through routing table only.

Configure static Route to overcome this issue or advertise the Loop back ip address under bgp through Network Command.

Question on BGP routing

You'll need to source your ping from your loopback interface. The bgp table doesn't have a route back to your 10.1.x.x address:

Router#ping 1.1.1.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

Ping from Router E like: ping 1.1.1.1 sour 5.5.5.5

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
Community Member

Question on BGP routing

I forgot to mention. All the loopback addreses are configured on each router and it has posted with network command under BGP.

thank you

Chamara

Community Member

Question on BGP routing

you means Do I have to configure all connection IPs with network command?  if it is like that how can I configure this kind of scenario with ISPs?

thank you for all helps

Chamara

Silver

Re: Question on BGP routing

Hi Chamara,

John is right.

you means Do I have to configure all connection IPs with network command?  if it is like that how can I configure this kind of scenario with ISPs?

Well you don't have to since you don't care about advertising the internal 10.X.X.X that are used only for neighbor definition and p2p connections with other routers, right?

The only reason that you think you have a problem is because your routers do not know about other than connected 10.X.X.X networks and that's why the ping/traceroute fails. If you would do it as John suggests, you will find no problems in the setup. If you intended the other routers to know about 10.X.X.X network as well then do so via static or dynamic routing but that is not necessary if you want just the loopbacks (and other networks specified in bgp through the network command as well) to communicate with each other.

Best regards,

Jan

Community Member

Re: Question on BGP routing

Hi Jan and john ,

both of you are correct since the Router A doesnt know where is Router E because as you said it doesnt have any way to know it.

On the packet tracer the "ping source " not working.

thank you for remembering me the root cause. 

further I have added connected Networks to BGP and advertised. But Ping takes very loang time than it should. but it works. What will be the issue?

thank you again for everybody.

Kind regards

Chamara

261
Views
5
Helpful
7
Replies
CreatePlease to create content