Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Quick 1841 routing question

Hey guys,

Hoping someone might be able to give me a quick response...

I have a Cisco 1841 partially setup, but I need some quick help regarding port forwarding.

I have a PC running IIS and a website on 10.10.10.2 using port 82.

The Cisco is 10.10.10.1 and the external address is 120.151.XXX.XXX.

I guess all I need to do is create a rule so that when someone tries to access the external IP on port 82 it gets redirected to the test website I have running..

So my question is, does anyone know to do this?

Cheers in advance

1 ACCEPTED SOLUTION

Accepted Solutions
Community Member

Re: Quick 1841 routing question

ah... if your outside interface is F0/1 then...

ip nat inside source static tcp 10.10.10.2 82 interface FastEthernet0/1 82

3 REPLIES
Community Member

Re: Quick 1841 routing question

I think you're looking for something like this:

ip nat inside source static tcp 10.10.10.2 82 interface FastEthernet0/0 82

Community Member

Re: Quick 1841 routing question

Probably should of included my current config, so here it is

version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname router
!
boot-start-marker
boot-end-marker
!
no logging buffered
enable secret 5 $1$36Nq$OXnnHoXFqH5JxfAItZN.K.
enable password xxxxxxx
!
no aaa new-model
ip cef
!
!
!
!
ip name-server 139.130.4.4
ip name-server 203.50.2.71
multilink bundle-name authenticated
!
!
archive
log config;
  hidekeys
!
!
!
policy-map shape-all
class class-default
  shape average 9300000
!
!
!
!
interface FastEthernet0/0
description $ETH-LAN$
ip address 10.10.10.1 255.255.255.0
ip nat inside
ip virtual-reassembly
speed auto
full-duplex
no mop enabled
!
interface FastEthernet0/1
description $ETH-LAN$
ip address 120.xxxx.xxx.10 255.255.255.252
ip nat outside
ip virtual-reassembly
speed auto
full-duplex
no mop enabled
service-policy output shape-all
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 120.xxx.xxx.9 permanent
ip route 10.1.1.0 255.255.255.0 FastEthernet0/1
ip route 120.xxx.xxx.8 255.255.255.252 FastEthernet0/0
!
!
ip http server
ip nat inside source list 2 interface FastEthernet0/1 overload
!
access-list 1 remark SDM_ACL Category=2
access-list 1 permit 10.10.10.0 0.0.0.255
access-list 2 remark SDM_ACL Category=2
access-list 2 permit 10.10.10.0 0.0.0.255
dialer-list 1 protocol ip permit
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
password xxxxxxx
login
!
scheduler allocate 20000 1000
end

Community Member

Re: Quick 1841 routing question

ah... if your outside interface is F0/1 then...

ip nat inside source static tcp 10.10.10.2 82 interface FastEthernet0/1 82

216
Views
0
Helpful
3
Replies
CreatePlease to create content