Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

R&S lab ospf nei challenges

Hi, All,

It is flappy and wierd. Anyone can shed some lights?

Thanks.

Senario:

r3 hub s0/0.235 mul use nei statement - r2, r5 spoke s0/0

Problem:

1. r2 and r5 or either r2 or r5 no route from other ospf areas.

2. using "ip os ne p-mp" or "ip os ne br" or "use all physical interfaces" is fine

Note:

// osp r5 no full route

1. change router id from 2.2.5.5 to 5.5.5.5 for all routers. cle ip os proce: not working

2. reboot r3/2/5 routers: not working (r3 sub-int multipoint not working; r3 physical int works)

3. change nei statment to ip os ne p-mp: it works.

4. change from ip os ne p-mp to ip os ne p-p: not working

5. cle ip os pro for r2/3/5: still not working

6. put it back: ip os ne p-mp: it is fine.

7. however, it is required to use nei statement.

21 REPLIES
Hall of Fame Super Silver

Re: R&S lab ospf nei challenges

Hello Dengming,

you should post the exact text of the scenario description to understand what are the requirements and the constraints.

About point-to-multipoint and neighbor command:

a Cisco proprietary version exists that is called point-to-multipoint non-broadcast.

That mode not using multicast hellos requires to use neighbor command

not receiving routes from other areas:

this should call for a totally stub area.

hub router should be ABR(0, totallystub_area)

Hope to help

Giuseppe

New Member

Re: R&S lab ospf nei challenges

thanks Giuseppe.

Senario:

1. r3 hub s0/0.235 mul - r2, r5 spoke s0/0 ospf area 0: requires to use nei statement on r3

2. R3 connects to multiple ospf areas.

Problem:

r2 and r5 or either r2 or r5 gets no routes from other ospf areas

Note:

I think this is standard ospf implementation with nei statement, but it turns out it is no easy job to get it work.

ip os ne p-p = always works

ip os ne p-mp = works fine

ip os ne br = works fine

nei = works fine for hub physical interface mode

nei = NOT working or not stable in hub sub-interface mode, that is, either both spoke routers or one of the spoke router gets no route from ospf other areas.

This is wierd.

New Member

Re: R&S lab ospf nei challenges

// no router with r3 using nei statement

r3#conf t

Enter configuration commands, one per line. End with CNTL/Z.

r3(config)#router os 1

r3(config-router)#nei 2.2.12.12

r3(config-router)#nei 2.2.12.13

r3(config-router)#end

Access-Server#2

[Resuming connection 2 to r2 ... ]

r2#sh ip rout

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

2.0.0.0/8 is variably subnetted, 3 subnets, 2 masks

C 2.2.2.2/32 is directly connected, Loopback0

C 2.2.12.0/24 is directly connected, Serial0/0

C 2.2.17.0/24 is directly connected, FastEthernet0/0

r2#

Access-Server#5

[Resuming connection 5 to R5 ... ]

*

r5#sh ip rout

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

2.0.0.0/8 is variably subnetted, 3 subnets, 2 masks

C 2.2.5.5/32 is directly connected, Loopback0

C 2.2.12.0/24 is directly connected, Serial0/0

C 2.2.17.0/24 is directly connected, FastEthernet0/1

150.2.0.0/24 is subnetted, 1 subnets

C 150.2.2.0 is directly connected, FastEthernet0/0

r5#

Access-Server#3

[Resuming connection 3 to R3 ... ]

New Member

Re: R&S lab ospf nei challenges

// changing to "ip os ne p-mp" routes show up from other ospf areas

r3#conf t

Enter configuration commands, one per line. End with CNTL/Z.

r3(config)#router os 1

r3(config-router)#no nei 2.2.12.13

r3(config-router)#no nei 2.2.12.13

*Jun 16 17:45:02.901: %OSPF-5-ADJCHG: Process 1, Nbr 0.0.0.0 on Serial0/0.235 fr

om ATTEMPT to DOWN, Neighbor Down: Neighbor deconfigured

r3(config-router)#no nei 2.2.12.12

r3(config-router)#

*Jun 16 17:45:05.513: %OSPF-5-ADJCHG: Process 1, Nbr 0.0.0.0 on Serial0/0.235 fr

om ATTEMPT to DOWN, Neighbor Down: Neighbor deconfigured

r3(config-router)#int s0/0.235

r3(config-subif)#ip os ne p

r3(config-subif)#ip os ne point-to-m

r3(config-subif)#

Access-Server#2

[Resuming connection 2 to r2 ... ]

r2#conf t

Enter configuration commands, one per line. End with CNTL/Z.

r2(config)#int s0/0

r2(config-if)#ip os ne po

r2(config-if)#ip os ne point-to-m

r2(config-if)#

Access-Server#5

[Resuming connection 5 to R5 ... ]

r5#conf t

Enter configuration commands, one per line. End with CNTL/Z.

r5(config)#int s0/0

r5(config-if)#ip os ne po

r5(config-if)#ip os ne point-to-m

r5(config-if)#

*Feb 4 03:29:09.656: %OSPF-5-ADJCHG: Process 1, Nbr 3.3.3.3 on Serial0/0 from L

OADING to FULL, Loading Done

r5(config-if)#end

r5#sh ip rout

*Feb 4 03:29:14.488: %SYS-5-CONFIG_I: Configured from console by console

r5#sh ip rout

Codes: C - connected, S - static, R - ....

2.0.0.0/8 is variably subnetted, 12 subnets, 3 masks

O 2.2.12.12/32 [110/128] via 2.2.12.11, 00:00:01, Serial0/0

O IA 2.2.6.6/32 [110/66] via 2.2.12.11, 00:00:01, Serial0/0

C 2.2.5.5/32 is directly connected, Loopback0

O IA 2.2.4.4/32 [110/129] via 2.2.12.11, 00:00:01, Serial0/0

O 2.2.3.3/32 [110/65] via 2.2.12.11, 00:00:01, Serial0/0

O 2.2.2.2/32 [110/129] via 2.2.12.11, 00:00:01, Serial0/0

O IA 2.2.1.1/32 [110/130] via 2.2.12.11, 00:00:01, Serial0/0

O 2.2.12.11/32 [110/64] via 2.2.12.11, 00:00:02, Serial0/0

O IA 2.2.8.0/21 [110/65] via 2.2.12.11, 00:00:02, Serial0/0

C 2.2.12.0/24 is directly connected, Serial0/0

O IA 2.2.16.0/24 [110/128] via 2.2.12.11, 00:00:02, Serial0/0

C 2.2.17.0/24 is directly connected, FastEthernet0/1

150.2.0.0/24 is subnetted, 1 subnets

C 150.2.2.0 is directly connected, FastEthernet0/0

r5#

Access-Server#2

[Resuming connection 2 to r2 ... ]

*Mar

r2(config-if)#end

r2#sh ip

*Mar 14 07:11:07.698: %SYS-5-CONFIG_I: Configured from console by console

r2#sh ip rout

Codes: C - connected, S - static, R - ....

2.0.0.0/8 is variably subnetted, 12 subnets, 3 masks

O IA 2.2.6.6/32 [110/66] via 2.2.12.11, 00:00:08, Serial0/0

O 2.2.5.5/32 [110/129] via 2.2.12.11, 00:00:08, Serial0/0

O IA 2.2.4.4/32 [110/129] via 2.2.12.11, 00:00:08, Serial0/0

O 2.2.3.3/32 [110/65] via 2.2.12.11, 00:00:08, Serial0/0

C 2.2.2.2/32 is directly connected, Loopback0

O IA 2.2.1.1/32 [110/130] via 2.2.12.11, 00:00:08, Serial0/0

O 2.2.12.13/32 [110/128] via 2.2.12.11, 00:00:08, Serial0/0

O 2.2.12.11/32 [110/64] via 2.2.12.11, 00:00:09, Serial0/0

O IA 2.2.8.0/21 [110/65] via 2.2.12.11, 00:00:09, Serial0/0

C 2.2.12.0/24 is directly connected, Serial0/0

O IA 2.2.16.0/24 [110/128] via 2.2.12.11, 00:00:09, Serial0/0

C 2.2.17.0/24 is directly connected, FastEthernet0/0

r2#

Hall of Fame Super Silver

Re: R&S lab ospf nei challenges

Hello Dengming,

this is a subtle issue:

when the IP OSPF network type is different on the two sides of a link even if the OSPF neighborship says it is up the other router cannot install in its routing tables the routes received by the other router even if actually received during the loading phase.

the OSPF network type must match.

you can compare the network type using

sh ip ospf interface type x/y

Hope to help

Giuseppe

Cisco Employee

Re: R&S lab ospf nei challenges

Additional to Giuseppe's comment on network type. They network type needs to be matched or compatible with each other, like

- point-to-point is compatible with point-to-multipoint, but you need to make sure the hello and dead intervals are match

- broadcast is compatible with non-broadcast, but you need to make sure the hello and dead intervals are match

HTH,

jerry

New Member

Re: R&S lab ospf nei challenges

Thanks Giuseppe and Jerry.

But how to make nei work, as nei is required and no way to bypass.

New Member

Re: R&S lab ospf nei challenges

// all Network Type NON_BROADCAST

r3(config-router)#nei 2.2.12.12

r3(config-router)#nei 2.2.12.13

r3(config-router)#end

r3#sh ip os int s0/0.235

Serial0/0.235 is up, line protocol is up

Internet Address 2.2.12.11/29, Area 0

Process ID 1, Router ID 3.3.3.3, Network Type NON_BROADCAST, Cost: 64

....

r2#sh ip os int s0/0

Serial0/0 is up, line protocol is up

Internet Address 2.2.12.12/24, Area 0

Process ID 1, Router ID 2.2.2.2, Network Type NON_BROADCAST, Cost: 64

Transmit Delay is 1 sec, State DROTHER, Priority 0

No designated router on this network

No backup designated router on this network

Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5

r5#sh ip os int s0/0

Serial0/0 is up, line protocol is up

Internet Address 2.2.12.13/24, Area 0

Process ID 1, Router ID 5.5.5.5, Network Type NON_BROADCAST, Cost: 64

Transmit Delay is 1 sec, State DROTHER, Priority 0

No designated router on this network

No backup designated router on this network

Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5

New Member

Re: R&S lab ospf nei challenges

r5#sh ip os nei

r5#

r2#sh ip os nei

r2#

r3#sh ip os nei

Neighbor ID Pri State Dead Time Address Interface

N/A 0 ATTEMPT/DROTHER - 2.2.12.12 Serial0/0.235

N/A 0 ATTEMPT/DROTHER - 2.2.12.13 Serial0/0.235

2.2.7.7 1 FULL/BDR 00:00:34 2.2.13.7 FastEthernet0/

0

2.2.9.9 1 FULL/DR 00:00:32 2.2.13.9 FastEthernet0/

0

6.6.6.6 1 2WAY/DROTHER 00:00:37 2.2.13.1 FastEthernet0/

0

2.2.8.8 1 FULL/BDR 00:00:31 2.2.10.8 FastEthernet0/

1

4.4.4.4 0 FULL/ - 00:00:31 2.2.16.4 Serial0/1

r3#

Cisco Employee

Re: R&S lab ospf nei challenges

Without seeing your configuration, I can't really tell what is wrong. However, I have tested the condition you've described, and I am able to get it to work, please see below:

! R3

interface Serial0/0

no ip address

encapsulation frame-relay

no frame-relay inverse-arp

!

interface Serial0/0.333 multipoint

ip address 152.1.123.3 255.255.255.0

frame-relay map ip 152.1.123.1 301

frame-relay map ip 152.1.123.2 302

!

router ospf 1

log-adjacency-changes

network 150.1.3.3 0.0.0.0 area 0

network 152.1.123.3 0.0.0.0 area 0

neighbor 152.1.123.1

neighbor 152.1.123.2

!

! R1

interface Serial0/0

ip address 152.1.123.1 255.255.255.0

encapsulation frame-relay

ip ospf priority 0

frame-relay map ip 152.1.123.3 103

frame-relay map ip 152.1.123.2 103 !<- next hop resolution for networks adv by R2

!

router ospf 1

log-adjacency-changes

network 150.1.1.1 0.0.0.0 area 0

network 152.1.123.1 0.0.0.0 area 0

!

! R2

interface Serial0/0

ip address 152.1.123.2 255.255.255.0

encapsulation frame-relay

ip ospf priority 0

frame-relay map ip 152.1.123.3 203

frame-relay map ip 152.1.123.1 203 !<- next hop resolution for networks adv by R1

no frame-relay inverse-arp

!

router ospf 1

log-adjacency-changes

network 150.1.2.2 0.0.0.0 area 0

network 152.1.123.2 0.0.0.0 area 0

!

Here is the show output

! R3

Rack1R3#sh frame map

Serial0/0.333 (up): ip 152.1.123.1 dlci 301(0x12D,0x48D0), static,

CISCO, status defined, active

Serial0/0.333 (up): ip 152.1.123.2 dlci 302(0x12E,0x48E0), static,

CISCO, status defined, active

Rack1R3#sh ip ospf nei

Neighbor ID Pri State Dead Time Address Interface

150.1.1.1 0 FULL/DROTHER 00:01:58 152.1.123.1 Serial0/0.333

150.1.2.2 0 FULL/DROTHER 00:01:34 152.1.123.2 Serial0/0.333

Rack1R3#sh ip ospf int s0/0.333

Serial0/0.333 is up, line protocol is up

Internet Address 152.1.123.3/24, Area 0

Process ID 1, Router ID 150.1.3.3, Network Type NON_BROADCAST, Cost: 64

Transmit Delay is 1 sec, State DR, Priority 1

Designated Router (ID) 150.1.3.3, Interface address 152.1.123.3

No backup designated router on this network

Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5

.....

Neighbor Count is 2, Adjacent neighbor count is 2

Adjacent with neighbor 150.1.1.1

Adjacent with neighbor 150.1.2.2

Suppress hello for 0 neighbor(s)

! R1

Rack1R1#sh frame map

Serial0/0 (up): ip 152.1.123.3 dlci 103(0x67,0x1870), static,

CISCO, status defined, active

Rack1R1#sh ip ospf nei

Neighbor ID Pri State Dead Time Address Interface

150.1.3.3 1 FULL/DR 00:01:32 152.1.123.3 Serial0/0

Rack1R1#sh ip ospf int s0/0

Serial0/0 is up, line protocol is up

Internet Address 152.1.123.1/24, Area 0

Process ID 1, Router ID 150.1.1.1, Network Type NON_BROADCAST, Cost: 64

Transmit Delay is 1 sec, State DROTHER, Priority 0

Designated Router (ID) 150.1.3.3, Interface address 152.1.123.3

No backup designated router on this network

Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5

! R2

Rack1R2#sh frame map

Serial0/0 (up): ip 152.1.123.3 dlci 203(0xCB,0x30B0), static,

CISCO, status defined, active

Rack1R2#sh ip ospf nei

Neighbor ID Pri State Dead Time Address Interface

150.1.3.3 1 FULL/DR 00:01:30 152.1.123.3 Serial0/0

Rack1R2#sh ip ospf int s0/0

Serial0/0 is up, line protocol is up

Internet Address 152.1.123.2/24, Area 0

Process ID 1, Router ID 150.1.2.2, Network Type NON_BROADCAST, Cost: 64

Transmit Delay is 1 sec, State DROTHER, Priority 0

Designated Router (ID) 150.1.3.3, Interface address 152.1.123.3

No backup designated router on this network

Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5

Regards,

jerry

New Member

Re: R&S lab ospf nei challenges

wow. thanks Jerry for your great effort to the help.

I do extra test again for another lab: the hub s0/0.134 mul to r3, r4 spoke s0/0 nei statement with same thing r3, or r4 no route from ospf other areas.

No worry. I will see if I will put together all the config files for your check later on.

Thanks again Jerry and All for the great help and have a wonderful day.

New Member

Re: R&S lab ospf nei challenges

It is lucky to get it working tonight.

Thanks Jerry. I am good. I will keep watch on this and will update this as needed.

R5#

interface Serial0/0

no ip address

encapsulation frame-relay

no frame-relay inverse-arp

frame-relay lmi-type cisco

!

interface Serial0/0.125 multipoint

ip address 2.2.125.5 255.255.255.0

ip ospf priority 255

snmp trap link-status

frame-relay map ip 2.2.125.1 501 broadcast

frame-relay map ip 2.2.125.2 502 broadcast

frame-relay map ip 2.2.125.5 501

!

router ospf 1

log-adjacency-changes

network 2.2.5.5 0.0.0.0 area 0

network 2.2.125.5 0.0.0.0 area 0

neighbor 2.2.125.1

neighbor 2.2.125.2

R1#

interface Serial0/0

ip address 2.2.125.1 255.255.255.0

encapsulation frame-relay

ip ospf priority 0

no dce-terminal-timing-enable

frame-relay map ip 2.2.125.1 105

frame-relay map ip 2.2.125.2 105 broadcast

frame-relay map ip 2.2.125.5 105 broadcast

no frame-relay inverse-arp

frame-relay lmi-type cisco

!

interface Serial0/1

ip address 2.2.13.1 255.255.255.0

encapsulation frame-relay

ip ospf network point-to-point

no dce-terminal-timing-enable

frame-relay map ip 2.2.13.1 113

frame-relay map ip 2.2.13.3 113 broadcast

no frame-relay inverse-arp

!

router ospf 1

log-adjacency-changes

network 2.2.1.1 0.0.0.0 area 0

network 2.2.13.1 0.0.0.0 area 13

network 2.2.125.1 0.0.0.0 area 0

R2#

interface Serial0/0

ip address 2.2.125.2 255.255.255.0

encapsulation frame-relay

ip ospf priority 0

frame-relay map ip 2.2.125.1 205 broadcast

frame-relay map ip 2.2.125.2 205

frame-relay map ip 2.2.125.5 205 broadcast

no frame-relay inverse-arp

frame-relay lmi-type cisco

!

router ospf 1

log-adjacency-changes

network 2.2.2.2 0.0.0.0 area 0

network 2.2.125.2 0.0.0.0 area 0

!

================

r5#sh ip os nei

Neighbor ID Pri State Dead Time Address Interface

2.2.1.1 0 FULL/DROTHER 00:01:57 2.2.125.1 Serial0/0.125

2.2.2.2 0 FULL/DROTHER 00:01:59 2.2.125.2 Serial0/0.125

r1#sh ip os nei

Neighbor ID Pri State Dead Time Address Interface

2.2.5.5 255 FULL/DR 00:01:55 2.2.125.5 Serial0/0

2.2.3.3 0 FULL/ - 00:00:30 2.2.13.3 Serial0/1

r2#sh ip os nei

Neighbor ID Pri State Dead Time Address Interface

2.2.5.5 255 FULL/DR 00:01:50 2.2.125.5 Serial0/0

New Member

Re: R&S lab ospf nei challenges

r2#sh ip rou

2.0.0.0/8 is variably subnetted, 11 subnets, 2 masks

O IA 2.2.7.7/32 [110/130] via 2.2.125.1, 00:00:24, Serial0/0

O 2.2.5.5/32 [110/65] via 2.2.125.5, 00:01:58, Serial0/0

O IA 2.2.3.3/32 [110/129] via 2.2.125.1, 00:00:34, Serial0/0

C 2.2.2.2/32 is directly connected, Loopback0

O 2.2.1.1/32 [110/65] via 2.2.125.1, 00:01:58, Serial0/0

O IA 2.2.12.0/24 [110/129] via 2.2.125.1, 00:00:19, Serial0/0

O IA 2.2.13.0/24 [110/128] via 2.2.125.1, 00:01:58, Serial0/0

r1#sh ip rout

2.0.0.0/8 is variably subnetted, 8 subnets, 2 masks

O 2.2.7.7/32 [110/66] via 2.2.13.3, 00:00:30, Serial0/1

O 2.2.5.5/32 [110/65] via 2.2.125.5, 00:01:41, Serial0/0

O 2.2.3.3/32 [110/65] via 2.2.13.3, 00:00:30, Serial0/1

O 2.2.2.2/32 [110/65] via 2.2.125.2, 00:01:41, Serial0/0

C 2.2.1.1/32 is directly connected, Loopback0

O 2.2.12.0/24 [110/65] via 2.2.13.3, 00:00:30, Serial0/1

r5#sh ip rout

2.0.0.0/8 is variably subnetted, 10 subnets, 2 masks

O IA 2.2.7.7/32 [110/130] via 2.2.125.1, 00:00:37, Serial0/0.125

C 2.2.5.5/32 is directly connected, Loopback0

O IA 2.2.3.3/32 [110/129] via 2.2.125.1, 00:00:47, Serial0/0.125

O 2.2.2.2/32 [110/65] via 2.2.125.2, 00:02:11, Serial0/0.125

O 2.2.1.1/32 [110/65] via 2.2.125.1, 00:02:11, Serial0/0.125

O IA 2.2.12.0/24 [110/129] via 2.2.125.1, 00:00:32, Serial0/0.125

O IA 2.2.13.0/24 [110/128] via 2.2.125.1, 00:02:11, Serial0/0.125

Cisco Employee

Re: R&S lab ospf nei challenges

Okay, thanks for letting me know.

Regards,

jerry

New Member

Re: R&S lab ospf nei challenges

Thanks Jerry. You are very helpful.

New Member

Re: R&S lab ospf nei challenges

Hi,Dear Dchen,

when you are doing lab with ospf over Fram Relay, it is very helpful for your troubleshooting ,if you can check the layer 2 configuration first before check ospf connection, use the following command, sh fram map, deb fram lmi,

Yang

New Member

Re: R&S lab ospf nei challenges

Hi Yang,

Correct. Will keep in mind.

FR is relatively easy in CCIE lab and it is my 2nd nature with no fail (excluding typo like wrong submask, ip address, or put it in wrong serial interface) at any time except nei statement not behaving stable as it should be in term of spoke router won't get routes from other ospf areas.

Not sure it is due to different of IOS version in the routers like 12.4 (x-xx)?

Thanks friend.

New Member

Re: R&S lab ospf nei challenges

glad to let you know: doing another lab, nei works fine with all routes from other ospf areas coming in to the hub and spoke routers.

thanks Giuseppe, Jerry, Yang for the great help.

========

R3#

interface Serial0/0

no ip address

encapsulation frame-relay

no frame-relay inverse-arp

frame-relay lmi-type cisco

!

interface Serial0/0.345 multipoint

ip address 2.2.11.3 255.255.255.0

ip ospf priority 255

snmp trap link-status

frame-relay map ip 2.2.11.3 304

frame-relay map ip 2.2.11.4 304 broadcast

frame-relay map ip 2.2.11.5 305 broadcast

!

router ospf 1

log-adjacency-changes

network 2.2.3.3 0.0.0.0 area 0

network 2.2.11.3 0.0.0.0 area 11

network 2.2.13.2 0.0.0.0 area 0

network 2.2.31.2 0.0.0.0 area 0

neighbor 2.2.11.4

neighbor 2.2.11.5

-----

R4#

interface Serial0/0

ip address 2.2.11.4 255.255.255.0

encapsulation frame-relay

ip ospf priority 0

frame-relay map ip 2.2.11.3 403 broadcast

frame-relay map ip 2.2.11.4 403

frame-relay map ip 2.2.11.5 403 broadcast

no frame-relay inverse-arp

frame-relay lmi-type cisco

!

router ospf 1

log-adjacency-changes

network 2.2.4.4 0.0.0.0 area 11

network 2.2.11.4 0.0.0.0 area 11

-----

R5#

interface Serial0/0

ip address 2.2.11.5 255.255.255.0

encapsulation frame-relay

ip ospf priority 0

frame-relay map ip 2.2.11.3 503 broadcast

frame-relay map ip 2.2.11.4 503 broadcast

frame-relay map ip 2.2.11.5 503

no frame-relay inverse-arp

frame-relay lmi-type cisco

!

router ospf 1

log-adjacency-changes

network 2.2.5.5 0.0.0.0 area 11

network 2.2.11.5 0.0.0.0 area 11

network 2.2.55.254 0.0.0.0 area 11

New Member

Re: R&S lab ospf nei challenges

r4#sh ip rout

2.0.0.0/8 is variably subnetted, 13 subnets, 2 masks

O IA 2.2.8.8/32 [110/66] via 2.2.11.3, 00:00:52, Serial0/0

O IA 2.2.7.7/32 [110/66] via 2.2.11.3, 00:00:52, Serial0/0

O 2.2.5.5/32 [110/65] via 2.2.11.5, 00:00:52, Serial0/0

O IA 2.2.3.3/32 [110/65] via 2.2.11.3, 00:00:52, Serial0/0

O IA 2.2.2.2/32 [110/67] via 2.2.11.3, 00:00:52, Serial0/0

O IA 2.2.12.0/24 [110/66] via 2.2.11.3, 00:00:53, Serial0/0

O IA 2.2.13.0/24 [110/65] via 2.2.11.3, 00:00:53, Serial0/0

O IA 2.2.21.0/24 [110/66] via 2.2.11.3, 00:00:53, Serial0/0

O IA 2.2.31.0/24 [110/65] via 2.2.11.3, 00:00:53, Serial0/0

O 2.2.55.0/24 [110/65] via 2.2.11.5, 00:00:53, Serial0/0

O IA 2.2.100.0/24 [110/66] via 2.2.11.3, 00:00:54, Serial0/0

r5#sh ip rout

2.0.0.0/8 is variably subnetted, 13 subnets, 2 masks

O IA 2.2.8.8/32 [110/66] via 2.2.11.3, 00:01:02, Serial0/0

O IA 2.2.7.7/32 [110/66] via 2.2.11.3, 00:01:02, Serial0/0

O 2.2.4.4/32 [110/65] via 2.2.11.4, 00:01:02, Serial0/0

O IA 2.2.3.3/32 [110/65] via 2.2.11.3, 00:01:02, Serial0/0

O IA 2.2.2.2/32 [110/67] via 2.2.11.3, 00:01:02, Serial0/0

O IA 2.2.12.0/24 [110/66] via 2.2.11.3, 00:01:03, Serial0/0

O IA 2.2.13.0/24 [110/65] via 2.2.11.3, 00:01:03, Serial0/0

O IA 2.2.21.0/24 [110/66] via 2.2.11.3, 00:01:03, Serial0/0

O IA 2.2.31.0/24 [110/65] via 2.2.11.3, 00:01:03, Serial0/0

O IA 2.2.100.0/24 [110/66] via 2.2.11.3, 00:01:03, Serial0/0

r3#sh ip rout

2.0.0.0/8 is variably subnetted, 13 subnets, 2 masks

O 2.2.8.8/32 [110/2] via 2.2.31.1, 00:02:45, FastEthernet0/1

O 2.2.7.7/32 [110/2] via 2.2.13.1, 00:02:45, FastEthernet0/0

O 2.2.5.5/32 [110/65] via 2.2.11.5, 00:01:14, Serial0/0.345

O 2.2.4.4/32 [110/65] via 2.2.11.4, 00:01:14, Serial0/0.345

O 2.2.2.2/32 [110/3] via 2.2.31.1, 00:02:45, FastEthernet0/1

[110/3] via 2.2.13.1, 00:02:45, FastEthernet0/0

O 2.2.12.0/24 [110/2] via 2.2.13.1, 00:02:46, FastEthernet0/0

O 2.2.21.0/24 [110/2] via 2.2.31.1, 00:02:46, FastEthernet0/1

O 2.2.55.0/24 [110/65] via 2.2.11.5, 00:01:16, Serial0/0.345

O 2.2.100.0/24 [110/2] via 2.2.31.1, 00:02:47, FastEthernet0/1

[110/2] via 2.2.13.1, 00:02:47, FastEthernet0/0

----

r3# sh ip os nei

Neighbor ID Pri State Dead Time Address Interface

2.2.8.8 1 FULL/BDR 00:00:36 2.2.31.1 FastEthernet0/

1

2.2.7.7 1 FULL/BDR 00:00:33 2.2.13.1 FastEthernet0/

0

2.2.4.4 0 FULL/DROTHER 00:01:35 2.2.11.4 Serial0/0.345

2.2.5.5 0 FULL/DROTHER 00:01:53 2.2.11.5 Serial0/0.345

r4#sh ip os nei

Neighbor ID Pri State Dead Time Address Interface

2.2.3.3 255 FULL/DR 00:01:40 2.2.11.3 Serial0/0

r5#sh ip os nei

Neighbor ID Pri State Dead Time Address Interface

2.2.3.3 255 FULL/DR 00:01:34 2.2.11.3 Serial0/0

Hall of Fame Super Silver

Re: R&S lab ospf nei challenges

Hello Dengming,

nice to know that this new lab is working well.

About the first one:

if you compare your sh ip ospf interface with those provided by Jerry you see:

in yours:

>>No designated router on this network

>>No backup designated router on this network

in Jerry's show ip ospf int a DR is seen is on the spoke and it is the hub router.

I cannot say what was the cause of the issue.

Jerry:

thanks for correction I had oversimplified the question of network type for sake of clarity and for lack of time.

Hope to help

Giuseppe

New Member

Re: R&S lab ospf nei challenges

Interesting.

1. nice to know that this new lab is working well. //thanks.

2. About the first one:

if you compare your sh ip ospf interface with those provided by Jerry you see:

in yours:

>>No designated router on this network

>>No backup designated router on this network

// Correct. The first one is not working properly.

3. in Jerry's show ip ospf int a DR is seen is on the spoke and it is the hub router.

I cannot say what was the cause of the issue.

// No worry. I think it might be the router itself is causing the problem, as each lab is using different router to be hub and spoke. BTW: for the problematic lab, I do it for 7 times, and everytime it is same problem leading me to think it is nei statement problem.

The hub-spoke connection is fine, but spoke routers won't get routes from other ospf areas resulting the whole lab unfunctional.

Now, pretty much knowing the problem and their temporary or permanent fix for the lab sake.

I think this is the purpose of CCIE lab test letting you to play around as much as possible for the technologies: when it is working and when it is not working as well as different ways to accomplish the same task.

4. thanks Giuseppe, Jerry, Yang for the great help.

Have a good night to All.

173
Views
40
Helpful
21
Replies
CreatePlease to create content