Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Rapid STP in the WAN?

My company has received a number of bids for a new WAN.

Info on the WAN

11 sites in a ring topology. Circumference of the ring is 200 miles.

Point to point Ethernet links between each site in the ring.

There will be "spurs" off of the ring in the future.

The bid that has been determined to be the "best" by management (i.e. cheapest) implements a Rapid Spanning Tree ring around the loop.

While a Layer 2 solution does allow for some flexibility...11 hops and 200 miles - this seems like a meltdown waiting to happen. Not to mention the spurs that will be added in the future, which could create a situation where traffic must span 13 switches from end to end, and the distance could be up to 230 miles.

Can RSTP be tuned to perform well in this environment? What kind of failover could be expected from such a design?

I admit my spanning tree knowledge is all LAN based, and in the LAN I have eliminiated STP as much as possible.

Feel free to mock and ridicule, my skin is thick.

4 REPLIES
Silver

Re: Rapid STP in the WAN?

STP is STP, and it does not matter if it's in LAN, MAN or WAN. Those are only terms categorizing technologies.

STP recommends maximum radius of 7.

RSTP over so many miles does not sound that great. The propagation delay start to be a big problem, since light will travel 230 miles in about 2ms, but end to end delay will be larger. I'd guess around 6-7 ms.

Systems without modified TCP will be able to transfer files with a speed of no more than 70-80Mbps or so (because of maximum window size)

Do you really need to span all VLANs throughout the ring? I think Routing protocol would do a better job.

Community Member

Re: Rapid STP in the WAN?

Thanks for the reply.

There is one VLAN that needs to be dropped at multiple sites (2 of the 11 sites to be exact, with 3 of the spurs to be added later needing this VLAN) but I was thinking this could be done with L2TPv3 or GRE tunnels over a routed core.

The RSTP solution is just one offered (basically a MetroE/QinQ solution)...The bid I am in favor of has VRF-Lite as the base technology. One of the major requirements is to keep 6 networks isolated from each other while sharing a common transport (which is DS3, and all vendors offered solutions which convert DS3 to Ethernet before touching any LAN equipment, so the 70-80mbps limit you mention is not a problem).

Silver

Re: Rapid STP in the WAN?

With todays L3 switching routing seems a preferable way, but since you need one VLAN to be spanned, it won't make a difference from STP perspective whether there is a tunnel or if it's a clear trunk. Tunnel will reduce the size of the MTU.

What about setting up transparent VLANs that would be used as point-to-point connections, providing Layer 3 connectivity? Then you can trunk only the needed VLAN and only to locations you need.

I'm hope you understand what I mean. Here is an example:

Location1 Setup:

interface Vlan501

description point-to-point

ip address x.x.x.1 255.255.255.252

interface GigabitEthernet1/0/24

description to-isp

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 501

switchport mode trunk

Location2 Setup:

interface Vlan501

description point-to-point

ip address x.x.x.2 255.255.255.252

interface Vlan502

description point-to-point

ip address x.x.x.5 255.255.255.252

interface GigabitEthernet1/0/24

description to-isp

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 501,502

switchport mode trunk

Location3 Setup:

interface Vlan101

description user-vlan

ip address x.x.x.2 255.255.255.0

standby 1 ip x.x.x.1

interface Vlan502

description point-to-point

ip address x.x.x.6 255.255.255.252

interface Vlan503

description point-to-point

ip address x.x.x.9 255.255.255.252

interface GigabitEthernet1/0/24

description to-isp

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 502,503,101

switchport mode trunk

Location4 Setup:

interface Vlan101

description user-vlan

ip address x.x.x.3 255.255.255.0

standby 1 ip x.x.x.1

interface Vlan503

description point-to-point

ip address x.x.x.10 255.255.255.252

interface Vlan504

description point-to-point

ip address x.x.x.13 255.255.255.252

interface GigabitEthernet1/0/24

description to-isp

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 503,504,101

switchport mode trunk

Location5 Setup:

interface Vlan504

description point-to-point

ip address x.x.x.14 255.255.255.252

interface Vlan505

description point-to-point

ip address x.x.x.17 255.255.255.252

interface GigabitEthernet1/0/24

description to-isp

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 504,505

switchport mode trunk

Ans so on, until you close the ring.

Then run EIGRP on the point to point links, or other L3 routing protocol. The idea is not to rely on L2 mechanisms for convergence, since in large scale environment routing protocols converge much better.

Community Member

Re: Rapid STP in the WAN?

That is pretty much what most of the other bids are proposing. You are preaching to the choir about L2 convergence vs. L3!

The difference is price. Lower end switches can be used with the RSTP solution (ME3400 vs. 3750E or 3560E for VRF/routing solution).

Thanks for the input.

163
Views
0
Helpful
4
Replies
CreatePlease to create content