Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

RE: Routing configuration on Cisco 887 router

My company has recently purchased a Cisco 887 router, there are 4 Fastethernet 10/100 ports, 1 ADSLPoPOTS port etc. We are planning to connect the 887 router to Cisco 827 modem via a FE WAN interface on router. The Cisco 827 modem already has the DSL cable plugged into the DSL service. My question is where is the FE WAN interface on router. There are 4 FE LAN ports ranging from 0 to 3. Would the ip address configuration for the FE WAN interface be the same as the FE LAN interface, if not, I need detailed config info. Is this a special port or can any one of the LAN ports be used? OR should I use the DSL port on the 887 router directly and plug it into the DSL service. If this is the case, what are the CLI configuration commands required to configure WAN ip address settings on ADSL port?

The router functions as a catalyst switch as well. I CANNOT simply configure ip address settings on FE LAN ports since I receive an error message staing that "IP address settings may not be configured on L2 link" Does this mean I have to configure the IP address for interface and link the inerfacte to VLAN.

This is how I would attempt to configure:

interface fa1

ip address 200.205.20.4 255.255.255.0

exit

interface fa1

shutdown

switchport mode access

switchport access vlan 2

no shutdown

exit

There is a default Vlan 1 of address 10.1.1... on router settings. How do I determine on which port this has been set?

An immediate response would be appreciated!

Thanks,

Regards,

Nira

4 REPLIES
New Member

Re: RE: WAN configuration on Cisco 887 router

Hi Nira,

You question would be better answered here:

https://supportforums.cisco.com/community/netpro/network-infrastructure

You are currently posting in the Small Business section and the device you are inquiring about is an Enterprise router.


Thanks!

Dave

David L. Barrett, Jr.
New Member

Re: RE: WAN configuration on Cisco 887 router

Nira,

While I'm not a Cisco Support person, I see a few points that may require additional information. Such as what IOS is the Cisco 887 running and does it have L2/L3 interface capabilities? On most high end, real Cisco Cat switches a L2 interface can be upgrade to a L3 Interface

Switch# Config t

Switch# Int Fa0/1

Switch(config-if)# No switchport

Switch(config-if)# ip adress 192.20.135.21 255.255.255.0

Switch(config-if)# no shut

and vice versus

Switch# Config t

Switch# Int Fa0/1

Switch(config-if)# shut

Switch(config-if)# switchport mode access

Switch(config-if)# no shut

Again, this is on the basis that your IOS have the capabilities of turning a L2 into a L3 and vice versus.

New Member

Re: RE: Routing configuration on Cisco 887 router

Hi,

I got this working by defining the settings in Vlan1:

interface Vlan1
ip address 200.205.20.4 255.255.255.0

exit

Thanks,

Chris

New Member

Re: RE: Routing configuration on Cisco 887 router

Excellent, I'm glad that worked for you. But in your config you also had Vlan 2 that needs to be connected with a different IP. How will you accomplish that without a trunk or sub-interfaces?

3699
Views
0
Helpful
4
Replies
CreatePlease login to create content