Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Really Need Help Here!! RIP V2 & DHCP Server

Hi,

I have a multilayer Cisco 3560 network. All sites are connected to each other using RIP V2.

1. We have remote sites connected by microwave links using Cisco 3560.

2. In the attached image "Site-1" should get an IP from the HeadOffice DHCP Server.

3. HEAD OFFICE switch is running the VTP Domain.

Question

1. I have rip version 2 running. How do I get "SITE-1" to get an IP Address from the DHCP Server running in Head Office.

Kindly give me your expert comments/suggestions in how do I go about achieving the above.

Regards

Sarfaraz

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Gold

Re: Really Need Help Here!! RIP V2 & DHCP Server

Sarfaraz

I am glad that you are now able to get IP addresses from the DHCP server at HQ. In terms of problems with connectivity outside, it would be helpful if you would post the output of show ip route from the site 1 switch and perhaps also post the output of show ip route from the HQ.

HTH

Rick

16 REPLIES

Re: Really Need Help Here!! RIP V2 & DHCP Server

Hi

U need to create a vlan in u r site-1 switch according to the vlan present in the HQ,ie i mean create a vlan with the same vlan-id as it is HQ.Then create a SVI in the site-1 switch according to the subnet information in u r HQ SVI i mean within the same subnet.Under the SVI define the ip address of the DHCP server using the ip helper-address command like bleow

int vlan (vlan id)

ip address (subnet mask)

ip helper-address (ip address of dhcp server)

Thanks

Mahmood

Community Member

Re: Really Need Help Here!! RIP V2 & DHCP Server

Dear Mahmood thanks for your reply. The network is running RIPV2. The Headoffice is running the following vlans & subnets:

* Headoffice

172.20.109.0/24 (vlan 109)

172.20.110.0/24 (vlan 110)-->DHCP Server

172.20.160.0/24 (Vlan 160)-->VOIP Server

All these routes are advertised using RIPV2 at HO L3 switch. If I do what you have asked me then RIP doesnt know where to send the traffic to since both the sites are advertising the same subnets.

Re: Really Need Help Here!! RIP V2 & DHCP Server

You need to configure the Helper address under the SVI as posted above.

The device would then act as a DHCP relay agent converting your DHCP broadcast into a unicast to the server. The server replies back to this unicast address which is then forwarded back to the client.

Whats the RTD between the HO and the site1 btw? The only issue i see is the DHCP timing out if the latence between the sites is higher

HTH

Narayan

Community Member

Re: Really Need Help Here!! RIP V2 & DHCP Server

hi, I have done that but still doesnt help. The latency is 1ms between both the sites. For your reference I am attaching the configuration file.

Community Member

Re: Really Need Help Here!! RIP V2 & DHCP Server

You need to include "ip dhcp-server " command in global configuration. The ip helper-address interface configuration command only tells the router/switch to forward certain broadcast traffic (including DHCP/BOOTP) to the specified address, but without the "ip dhcp-server" global config command the router/switch won't keep track of DHCP binding requests from clients.

HTH

Hall of Fame Super Gold

Re: Really Need Help Here!! RIP V2 & DHCP Server

Sarfaraz

I have looked at the files that you have posted and I have these comments about them:

- you were correct to question the advice to configure vlan109 with the 172.20.109.x address since that would duplicate the subnet on the HQ site. I am very puzzled about the config file you posted representing the site 1 config which has this:

nterface Vlan109

172.20.109.52

ip helper-address 172.20.109.1

it has the address but not the ip address part of the command. What is given is a syntax error. It looks like it would be part of the running config, but it can not be. Can you clarify this?

- I see this in the config

nterface FastEthernet0/1

no switchport

ip address 10.10.21.2 255.255.255.252

ip helper-address 172.20.109.1

You do not need the helper-address on a layer 3 port connecting to the adjacent device. It does not hurt anything here, but it does not do any good and I would suggest removing this line in the config.

- there seem to be 2 switch ports assigned to vlan 3 but no VLAN interface for VLAN 3. And most of the switch ports appear to be in the default VLAN of VLAN 1, but the interface VLAN 1 is shutdown. Can you clarify where the user ports are on this switch for which you would like to get DHCP addresses?

- I see that interface VLAN 1 uses a different address for the DHCP server

nterface Vlan1

ip address dhcp

ip helper-address 172.20.110.12

can you clarify whether the DHCP server is at 172.20.109.1 or is at 172.20.110.12? Or are there 2 DHCP servers?

- interface VLAN 1 is shutdown. If this is where the users ports are connected then they have no layer 3 connectivity.

What you need is to configure ip helper-address on the VLAN interface at site 1 where the user ports are connected (not on its upstream interface), it needs to point to the correct address of the DHCP server, and the DHCP server needs to have a correct configuration for the scope of the subnet at site 1.

HTH

Rick

Community Member

Re: Really Need Help Here!! RIP V2 & DHCP Server

Dear Rick, I had to manually edit the configuration after copying it from the switch. I have properly understood the way you have explained things, thanks for that. We couldnt try it yesterday we will be trying it today and if it works I will definitely get back to you.

Regards

Sarfaraz

Community Member

Re: Really Need Help Here!! RIP V2 & DHCP Server

Dear Rick,

Now I am facing another problem. I am able to get the IP address from the Head Office but I have no internet now. I can ping all the vlans at the HO. But when I am doing a traceroute from a PC to the internet it stops at the VLAN I have defined at Site-1.

int vlan 1

ip address 192.168.100.1 255.255.255.0

ip helper-address 172.20.110.12

router rip

version 2

network 10.0.0.0

network 192.168.100.0

Do I need to add a default route?

Regards

Sarfaraz

Re: Really Need Help Here!! RIP V2 & DHCP Server

Sarfaraz,

Redistribute the default route at the HO in the RIP configuration.

With this the device would send packets to the HO for internet.

Also you need to make sure the new subnet you created is Natted / allowed on the Firewall facing the internet

HTH

Narayan

Community Member

Re: Really Need Help Here!! RIP V2 & DHCP Server

Dear Narayan,

Where do I redistribute the default routes? On my L3 switch? or the Internet router? The command is "redistribute rip" right?

Regards

Sarfaraz

Re: Really Need Help Here!! RIP V2 & DHCP Server

On the HO router do you have a static default route to the DSL?

If yes then do the followinh

access-list 1 permit host 0.0.0.0

route-map internet permit 10

match ip address 1

router rip

version 2

reditribute static route-map internet

no auto-summary

You could do away with the route-map if you do not have other static routes and or want to distribute all of them

HTH

Narayan

Community Member

Re: Really Need Help Here!! RIP V2 & DHCP Server

Dear Narayan,

On the L3 Switch we have a default route pointed towards the DSL.

Re: Really Need Help Here!! RIP V2 & DHCP Server

Just redistribute this route in RIP process

and see whethere you are able to access internet

Narayan

Community Member

Re: Really Need Help Here!! RIP V2 & DHCP Server

So do I say at the HO "default-information originate"?

Re: Really Need Help Here!! RIP V2 & DHCP Server

Yes...

That would do

Narayan

Hall of Fame Super Gold

Re: Really Need Help Here!! RIP V2 & DHCP Server

Sarfaraz

I am glad that you are now able to get IP addresses from the DHCP server at HQ. In terms of problems with connectivity outside, it would be helpful if you would post the output of show ip route from the site 1 switch and perhaps also post the output of show ip route from the HQ.

HTH

Rick

659
Views
3
Helpful
16
Replies
CreatePlease to create content