Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Received non RFC-1577 compliant ARP packet

Anyone know what this means ?

Am trying to do rfc1483 bridging over AAL5/snap encapsulated PVC but keep getting encapsulation failed.

rfc1483 routing works but wanted to do IRB to accomondate a small subnet.

4 REPLIES
VIP Purple

Re: Received non RFC-1577 compliant ARP packet

Hello,

can you post the configuration of your router ?

Regards,

GP

Community Member

Re: Received non RFC-1577 compliant ARP packet

It´s an Cisco 837 running c837-k9o3y6-mz.123-11.T5

version 12.3

no service pad

!

no aaa new-model

ip subnet-zero

ip routing

!

!

!

bridge irb

!

!

interface Ethernet0

no ip address

no ip route-cache

bridge-group 1

hold-queue 100 out

!

interface ATM0

no ip address

no ip route-cache

no atm ilmi-keepalive

dsl operating-mode auto

dsl enable-training-log

dsl lom 10

!

interface ATM0.1 point-to-point

ip address x.x.X.250 255.255.255.248

no ip route-cache

bridge-group 1

pvc 8/64

protocol ip x.x.98.249

encapsulation aal5snap

!

!

interface FastEthernet1

no ip address

duplex auto

speed auto

!

interface FastEthernet2

no ip address

duplex auto

speed auto

!

interface FastEthernet3

no ip address

duplex auto

speed auto

!

interface FastEthernet4

no ip address

duplex auto

speed auto

!

ip classless

ip http server

no ip http secure-server

!

!

!

control-plane

!

bridge 1 protocol ieee

bridge 1 route ip

!

line con 0

line aux 0

line vty 0 4

!

end

Purple

Re: Received non RFC-1577 compliant ARP packet

Hi,

It seems as if there are two separate issues that you need to fix:

1. You are unable to ping 157.157.98.249 - it gives you an encap error

2. You are receiving RFC-1577 compliant ARP packets

For your first issue, it's interesting that the debug output shows that the router is trying to route it via BVI1, which does not exist in your config. Did you have a BVI1 interface configured previously ?

To understand why you are getting the second error, we really need to look at the router at the other end of the PVC since that is the one sending it. It would appear that that router is configured for Classical IP over ATM. Could you pls post a config of that router ?

Regards,

Paresh.

Community Member

Re: Received non RFC-1577 compliant ARP packet

The config was probably some intermetiate config since I was doing a lot of testing, but I did test this with the BvI interface configured.

I don´t have access to the remote end of the PVC as it connects to a SP, sorry.

But anyway we solved this by put another subnet on the pvc and route the previous one over that one so the job is done

But I´m still a little cureous why I was not able to bridge this instead of routing it?

For instance I tried to debug the arp reply according to the RFC1577 but the content didn´t make sense to me which is probably why the error occurs.

0001 ar$hrd 16 bits Hardware type

0800 ar$pro 16 bits Protocol type

06 ar$shtl 8 bits Type & length of source ATM number (q)

04 ar$sstl 8 bits Type & length of source ATM subaddress (r)

0002 ar$op 16 bits Operation code (request, reply, or NAK)

00 ar$spln 8 bits Length of source protocol address (s)

03 ar$thtl 8 bits Type & length of target ATM number (x)

FE ar$tstl 8 bits Type & length of target ATM subaddress (y)

CC ar$tpln 8 bits Length of target protocol address (z)

9C54 9D9D 62F9 ar$sha qoctets source ATM number

0013 1A41 ar$ssa roctets source ATM subaddress

ar$spa soctets source protocol address

37C9 9D ar$tha xoctets target ATM number

9D 62FA ar$tsa yoctets target ATM subaddress

My mac-address is 0013.1A41.37C9

224
Views
0
Helpful
4
Replies
CreatePlease to create content