Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Bronze

Redist Static Routes via EIGRP

Hi All,

I have a router that has a load of static routes. I want to redistribute these routes to another router running EIGRP on the same ethernet segment. I setup an access list etc permitting the routes and the associated route-map. I also know the commanto redist within EIGRP.

However, I only want to advertise / send these static routes, no other. Do I still need to apply the network command under the EIGRP process? Basically I don't want to advertise the network the interface is on, if that makes sense?

I might be overthinking this, but all I want to do is have EIGRP running on my router and only have it redistributes my static addresses.

1 ACCEPTED SOLUTION

Accepted Solutions

Redist Static Routes via EIGRP

You have to have a neighborship between the two routers which means that you'll be advertising that network. If your acl matches only the static routes that you want to advertise, appying that with a route map will keep from advertising anything further. You do not need to advertise the statics with the network command, but the network command obviously has to match on whatever interface the neighbor is on and should be receiving routes.

int fa0/0 <--- your neighbor will be off of this interface

ip address 192.168.15.1 255.255.255.0

ip route 192.168.1.0 255.255.255.0 192.168.15.10

access-list 1 permit 192.168.1.0 0.0.0.255

route-map Only192 permit

match ip address 1

router eigrp 100

no auto

network 192.168.15.1 0.0.0.0

redistribute static metric 1 1 1 1 1 route-map Only192

Am I understanding the question?

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
7 REPLIES

Redist Static Routes via EIGRP

You have to have a neighborship between the two routers which means that you'll be advertising that network. If your acl matches only the static routes that you want to advertise, appying that with a route map will keep from advertising anything further. You do not need to advertise the statics with the network command, but the network command obviously has to match on whatever interface the neighbor is on and should be receiving routes.

int fa0/0 <--- your neighbor will be off of this interface

ip address 192.168.15.1 255.255.255.0

ip route 192.168.1.0 255.255.255.0 192.168.15.10

access-list 1 permit 192.168.1.0 0.0.0.255

route-map Only192 permit

match ip address 1

router eigrp 100

no auto

network 192.168.15.1 0.0.0.0

redistribute static metric 1 1 1 1 1 route-map Only192

Am I understanding the question?

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
Bronze

Redist Static Routes via EIGRP

Hi John,

Thanks, yeah you understood what I was putting across. So in your example, the command

network 192.168.15.1 0.0.0.0

Will this advertise the network 192.168.15.0 /24 to my EIGRP neighbour? As this is what I don't want to happen. Or does that command just allow me to form the neighbour relationship?

Re: Redist Static Routes via EIGRP

Hmm...technically the two networks are connected, so your neighbor would see the same route as you as connected and nothing more. They have to be on the same subnet in order to form an adjacency. Then the neighbor will see the statics that you're advertising, but the next hop will show this router's interface.

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
Bronze

Re: Redist Static Routes via EIGRP

That makes complete sense....I wasover thinking it! Thanks very much John.

Re: Redist Static Routes via EIGRP

You're welcome!

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
Bronze

Re: Redist Static Routes via EIGRP

Hi John,

Just a quick one. If my router interface on that LAN segment is for example 172.25.10.10 255.255.252.0, should my network statement under EIGRP process just be the actual interface address and not the network address.

e.g

network 172.25.10.10 0.0.0.0

Also, if I have OSPF running on the same router, will the EIGRP have any affect on this or can they run side by side?

Cheers

Re: Redist Static Routes via EIGRP

I'd recommend only specifying the interface address alone like your example. You can run both protocols simultaneously and they won't have any impact UNLESS you are learning the same subnet from both protocols, in which case the eigrp route would be preferred.

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
180
Views
0
Helpful
7
Replies
CreatePlease login to create content