Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

redistribute eigrp via bgp

hi ! i wanna configure rtr1, rtr2, and rtr3 for eigrp. rtr3 needs to redistribute eigrp routes to rtr4 via bgp. thanks.

rtr1---rtr2---rtr3(as1)---rtr4(as2)

1 REPLY
Hall of Fame Super Bronze

Re: redistribute eigrp via bgp

It would help if you posted what you have so far, however - I'm posting a sample config from 4 routers. Hope this helps.

Router1

interface f0/0

ip address 192.168.1.1 255.255.255.0

interface s0/0

ip address 172.16.1.1 255.255.255.252

router eigrp 1

network 192.168.1.0

network 172.16.1.0

no auto-summary

Router2

interface f0/0

ip address 192.168.2.1 255.255.255.0

interface s0/0

ip address 172.16.1.2 255.255.255.252

interface s0/1

ip address 172.16.2.1 255.255.255.252

router eigrp 1

network 192.168.2.0

network 172.16.1.0

network 172.16.2.0

no auto-summary

Router3

interface f0/0

ip address 192.168.3.1 255.255.255.0

interface s0/0

ip address 172.16.2.2 255.255.255.252

interface s0/1

ip address 172.16.3.1 255.255.255.252

router eigrp 1

network 192.168.3.0

network 172.16.2.0

network 172.16.3.0

no auto-summary

router bgp 2

no synchronization

bgp log-neighbor-changes

redistribute eigrp 1

neighbor 172.16.3.2 remote-as 2

no auto-summary

Router4

interface f0/0

ip address 192.168.4.1 255.255.255.0

interface s0/0

ip address 172.16.3.2 255.255.255.252

router bgp 2

no synchronization

bgp log-neighbor-changes

redistribute connected

neighbor 172.16.3.1 remote-as 2

no auto-summary

111
Views
0
Helpful
1
Replies