Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Redistributing EIGRP into OSPF

I have created a lab on GSN3. I have three routers, R1 is a network in EIGRP, the R3 is an OSPF network and in bettewen I has R2 redistribution EIGRP into OSPF.

But in the routing table do not see the route redistribution. What occur?

Next show running the routers:

R1
interface FastEthernet0/0
ip address 192.168.0.1 255.255.255.0
duplex auto
speed auto
!
interface Serial1/0
ip address 192.168.10.1 255.255.255.252
serial restart-delay 0
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
router eigrp 1
network 192.168.0.0 0.0.0.3
network 192.168.10.0
no auto-summary

SH IP ROUTE
192.168.10.0/30 is subnetted, 1 subnets
C 192.168.10.0 is directly connected, Serial1/0
C 192.168.0.0/24 is directly connected, FastEthernet0/0

+++++++++++++++++++++++++++++
R2
interface Serial0/0
ip address 192.168.10.2 255.255.255.252
serial restart-delay 0
!
interface Serial0/1
ip address 172.16.10.2 255.255.255.252
serial restart-delay 0
!
interface Serial0/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial0/3
no ip address
shutdown
serial restart-delay 0
!
router eigrp 1
redistribute ospf 1
network 192.168.10.0 0.0.0.3
no auto-summary
!
router ospf 1
log-adjacency-changes
network 172.16.0.0 0.0.255.255 area 0

SH IP ROUTE
192.168.10.0/30 is subnetted, 1 subnets
C 192.168.10.0 is directly connected, Serial0/0
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.10.0/30 is directly connected, Serial0/1
O 172.16.0.0/24 [110/65] via 172.16.10.1, 00:06:01, Serial0/1
D 192.168.0.0/24 [90/2172416] via 192.168.10.1, 00:41:55, Serial0/0
[/color]

+++++++++++++++++++++++
R4
interface Serial0/0
ip address 172.16.10.1 255.255.255.252
serial restart-delay 0
!
interface Serial0/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial0/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial0/3
no ip address
shutdown
serial restart-delay 0
!
interface FastEthernet1/0
ip address 172.16.0.1 255.255.255.0
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 172.16.0.0 0.0.255.255 area 0

SH IP ROUTE
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.10.0/30 is directly connected, Serial0/0
C 172.16.0.0/24 is directly connected, FastEthernet1/0

1 REPLY
Cisco Employee

Re: Redistributing EIGRP into OSPF

Hello Lincoln,

The redistribution under Cisco devices is always configured in the destination routing protocol. In your case, the EIGRP is the source routing protocol that provides routes for redistribution, and the OSPF is the destination protocol that takes these routes and distributes them further.

So your router R2 shall be configured as follows:

router ospf 1

redistribute eigrp 1 subnets

The "redistribute ospf 1" in your EIGRP configuration is currently not necessary, unless you want to perform an inverse redistribution from OSPF into EIGRP. Moreover, when redistributing routes into distance vector protocols (RIP, IGRP, EIGRP), you must specify a starting metric, otherwise the routes will not be advertised. This is the reason why you don't see the OSPF routes being redistributed into EIGRP and visible as D EX routes on R1 (although you are now trying to solve a different issue).

Best regards,

Peter

237
Views
10
Helpful
1
Replies
CreatePlease to create content