Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Redistributing Of Routing Protocol

Hi Everyone

Can someone help to interprept the following

sh ip route 10.234.241.22

Routing entry for 10.234.241.16/28

Known via "connected", distance 0, metric 0 (connected, via interface)

Redistributing via eigrp 30, bgp 65037

Advertised by bgp 65037

Routing Descriptor Blocks:

* directly connected, via Vlan20

Route metric is 0, traffic share count is 1

May i know , wat does the Redistributing via eigrp 30, bgp 65037 mean ? Someone help to advice. THanks

Thanks

4 ACCEPTED SOLUTIONS

Accepted Solutions

Re: Redistributing Of Routing Protocol

HI, [Pls Rate if Helps]

The route 102.34.241.22 is Advertised to the network via parent "BGP 65037" Autonomous System.

This is redistributed into Eigrp 30 - Autonomous System.

Eg:

router bgp 65037

network 10.234.241.22

router eigrp 30

redistribute bgp

If you can post your configuration more we can still help more.

PLS Rate if Helps

Best Regards,

Guru Prasad R

Hall of Fame Super Silver

Re: Redistributing Of Routing Protocol

Alan

I agree that the output indicates that the subnet is advertised by BGP in AS 65037. I am not sure that it is redistributed into EIGRP and believe that there is a network statement for this network under EIGRP 30.

I agree that posting the config would allow us to to determine more exactly what it is. It would also be interesting and perhaps helpful if you post the output of show ip protocol.

HTH

Rick

Highlighted
Silver

Re: Redistributing Of Routing Protocol

Hi ,

*** Redistributing via eigrp 30, bgp 65037

10.234.241.16/28 is directly connected subent on the router and you are using eigrp and bgp on the router.

** Advertised by bgp 65037

subent 10.234.241.16/28 was advertised in BGP means it is redistibuted using "redisritbute connected" command under "router bgp 65037".

Thanks,

Satish

Hall of Fame Super Silver

Re: Redistributing Of Routing Protocol

Alan

Thanks for posting the output of show ip protocol. In this output there is clear evidence that this subnet (or its interface) is included in EIGRP 30. In particular notice these lines:

Routing for Networks:

10.0.0.0

so there is a network statement for 10.0.0.0 and 10.234.241.22 is covered by the network statement and it is not made passive (only VLAN 30 is passive). So the address on VLAN 20 is an active EIGRP interface and the subnet is advertised by EIGRP.

It is harder to tell from the output about BGP. Pretty clearly BGP is advertising the network, but it is still ambiguous whether there is a BGP network statement for it or if it is being redistributed. I am thinking that there is a network statement for it under router bgp since it appears that BGP is redistributing static and eigrp routes, but that subnet is a connected subnet and not static or eigrp.

If you would post the config (or at least the router bgp part of the config) then we could determine for sure.

HTH

Rick

6 REPLIES

Re: Redistributing Of Routing Protocol

HI, [Pls Rate if Helps]

The route 102.34.241.22 is Advertised to the network via parent "BGP 65037" Autonomous System.

This is redistributed into Eigrp 30 - Autonomous System.

Eg:

router bgp 65037

network 10.234.241.22

router eigrp 30

redistribute bgp

If you can post your configuration more we can still help more.

PLS Rate if Helps

Best Regards,

Guru Prasad R

Hall of Fame Super Silver

Re: Redistributing Of Routing Protocol

Alan

I agree that the output indicates that the subnet is advertised by BGP in AS 65037. I am not sure that it is redistributed into EIGRP and believe that there is a network statement for this network under EIGRP 30.

I agree that posting the config would allow us to to determine more exactly what it is. It would also be interesting and perhaps helpful if you post the output of show ip protocol.

HTH

Rick

New Member

Re: Redistributing Of Routing Protocol

The sh ip protocol config are as below, any can interprate. confusing on redistribution.

Routing Protocol is "eigrp 30"

Outgoing update filter list for all interfaces is not set

Incoming update filter list for all interfaces is not set

Default networks flagged in outgoing updates

Default networks accepted from incoming updates

EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0

EIGRP maximum hopcount 100

EIGRP maximum metric variance 1

Default redistribution metric is 100000 10 255 1 1500

Redistributing: eigrp 30, bgp 65037

EIGRP NSF-aware route hold timer is 240s

EIGRP NSF disabled

NSF signal timer is 20s

NSF converge timer is 120s

Automatic network summarization is not in effect

Maximum path: 4

Routing for Networks:

10.0.0.0

Passive Interface(s):

Vlan30

Routing Information Sources:

Gateway Distance Last Update

10.234.245.18 90 09:02:51

10.234.245.5 90 09:45:18

10.234.245.14 90 09:02:51

Distance: internal 90 external 170

Routing Protocol is "bgp 65037"

Outgoing update filter list for all interfaces is not set

Incoming update filter list for all interfaces is not set

IGP synchronization is disabled

Automatic route summarization is disabled

Redistributing: static, eigrp 30

Neighbor(s):

Address FiltIn FiltOut DistIn DistOut Weight RouteMap

10.234.241.23 from-evpn

10.234.254.51

10.234.254.52

10.240.1.1

10.240.1.2

10.240.1.14

Maximum path: 2

Routing Information Sources:

Gateway Distance Last Update

10.234.241.23 20 01:50:41

10.234.254.52 200 09:34:59

10.234.254.51 200 09:05:29

10.240.0.22 200 32w2d

10.240.0.21 200 42w1d

10.240.1.14 200 01:50:42

10.240.1.2 200 09:05:25

10.240.1.1 200 09:05:40

Distance: external 20 internal 200 local 200

Hall of Fame Super Silver

Re: Redistributing Of Routing Protocol

Alan

Thanks for posting the output of show ip protocol. In this output there is clear evidence that this subnet (or its interface) is included in EIGRP 30. In particular notice these lines:

Routing for Networks:

10.0.0.0

so there is a network statement for 10.0.0.0 and 10.234.241.22 is covered by the network statement and it is not made passive (only VLAN 30 is passive). So the address on VLAN 20 is an active EIGRP interface and the subnet is advertised by EIGRP.

It is harder to tell from the output about BGP. Pretty clearly BGP is advertising the network, but it is still ambiguous whether there is a BGP network statement for it or if it is being redistributed. I am thinking that there is a network statement for it under router bgp since it appears that BGP is redistributing static and eigrp routes, but that subnet is a connected subnet and not static or eigrp.

If you would post the config (or at least the router bgp part of the config) then we could determine for sure.

HTH

Rick

New Member

Re: Redistributing Of Routing Protocol

Hi Rick

Thanks for your share of explaination to the config. I get what your explaination is about. It would be diffcult to post the config as the config that i posted is only a small part of a whole enterprise network.

Thanks again for the sharing.

Thanks

Alan

Highlighted
Silver

Re: Redistributing Of Routing Protocol

Hi ,

*** Redistributing via eigrp 30, bgp 65037

10.234.241.16/28 is directly connected subent on the router and you are using eigrp and bgp on the router.

** Advertised by bgp 65037

subent 10.234.241.16/28 was advertised in BGP means it is redistibuted using "redisritbute connected" command under "router bgp 65037".

Thanks,

Satish

140
Views
4
Helpful
6
Replies
CreatePlease login to create content