Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Redistributing RIP & BGP but unable to get routes

Hi All,

Please help i have 9 routers in my project R1,R2,R3,R4,R5,R6,R7,R8,R9 WHERE R1,R7,R8,R9 are CE routers & rest are PE routers.

i want to redistribute RIP into BGP & below are config.of  CE(R1) & PE(R2) as i run show ip route in R1 then unable to find BGP routes please confirm What is issue in config

Now i have configured RIP in R1 & config are

interface Loopback0

ip address 203.1.0.1 255.255.255.255

!

interface Loopback1

ip address 203.1.1.1 255.255.255.0

!

interface FastEthernet0/0

no ip address

shutdown

duplex auto

speed auto

!

interface FastEthernet1/0

no ip address

shutdown

duplex auto

speed auto

!

interface FastEthernet2/0

ip address 150.1.0.0 255.255.255.254

duplex auto

speed auto

!

router rip

version 2

network 150.1.0.0

network 203.1.0.0

network 203.1.1.0

...............................................................

R2 config

interface Loopback0

ip address 192.168.1.1 255.255.255.255

!

interface Ethernet0/0

no ip address

shutdown

duplex auto

!

interface GigabitEthernet0/0

ip address 192.168.1.6 255.255.255.254

media-type gbic

speed 1000

duplex full

negotiation auto

!

interface FastEthernet1/0

vrf forwarding vpnb

ip address 150.1.0.3 255.255.255.254

duplex half

!

interface FastEthernet2/0

vrf forwarding vpna

ip address 150.1.0.1 255.255.255.254

duplex full

!

interface FastEthernet3/0

no ip address

shutdown

duplex half

!

router ospf 1

log-adjacency-changes

network 192.0.0.0 0.255.255.255 area 0

mpls ldp sync

mpls ldp autoconfig

!

router rip

version 2

!

address-family ipv4 vrf vpna

  redistribute bgp 1 metric transparent

  network 150.1.0.0

  no auto-summary

exit-address-family

!

router bgp 1

no bgp default ipv4-unicast

bgp log-neighbor-changes

neighbor 192.168.1.5 remote-as 1

neighbor 192.168.1.5 update-source Loopback0

!

address-family ipv4

  no synchronization

  neighbor 192.168.1.5 activate

  no auto-summary

exit-address-family

!

address-family vpnv4

  neighbor 192.168.1.5 activate

  neighbor 192.168.1.5 send-community extended

exit-address-family

!

address-family ipv4 vrf vpna

  no synchronization

  redistribute rip

exit-address-family

!

address-family ipv4 vrf vpnb

  no synchronization

  redistribute connected

  redistribute static

exit-address-family

!

no ip http server

no ip http secure-server

!

!

ip route vrf vpnb 203.1.0.2 255.255.255.255 150.1.0.2

ip route vrf vpnb 203.1.2.0 255.255.255.0 150.1.0.2

!

!

mpls ldp router-id Loopback0

--More--

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Redistributing RIP & BGP but unable to get routes

First do a no auto summary on your CE router in router rip

ip address 150.1.0.0 255.255.255.254, this mask /31 must be used with caution, it may cause problems, It's not recommended to use anything smaller than a /30

The PE config looks ok, but to see rip routes or bgp routes or other pe or ce routers you need to have them imported probably the vrf router-target export and import and the rd

you must import what others PE exports and export what the others import in order to exchange routes

kind regards

5 REPLIES
New Member

Redistributing RIP & BGP but unable to get routes

First do a no auto summary on your CE router in router rip

ip address 150.1.0.0 255.255.255.254, this mask /31 must be used with caution, it may cause problems, It's not recommended to use anything smaller than a /30

The PE config looks ok, but to see rip routes or bgp routes or other pe or ce routers you need to have them imported probably the vrf router-target export and import and the rd

you must import what others PE exports and export what the others import in order to exchange routes

kind regards

Redistributing RIP & BGP but unable to get routes

Are you really really really sure you need to redistribute RIP into BGP?  It'll add a much greater level of complexity into not only your configuration job, but also the operation of the devices and support of them going forward.

Having two separate protocols running on the router is OK, but specifically -not- redistributing will make your troubleshooting much easier.  I would only recommend you redistribute those two protocols into each  other if there was no other way (such as using static routes) to solve  the problem.

New Member

Redistributing RIP & BGP but unable to get routes

Probably he is just testing or doing a lab but there is nothing wrong configuring MP-BGP you will have direct communication between sites, hub and spoke is easyer (NHRP) but you will loose the direct end to end communication without going to the central site.

Redistributing RIP & BGP but unable to get routes

Hello,

Please post the VRF configuration to check the RD and RT (make sure the import and export match on both sides as properly).

On the BGP protocol do you see any routes being learned?

Rate all of the helpful posts!!!

Regards,

Jcarvaja

Follow me on http://laguiadelnetworking.com

Looking for some Networking Assistance? Contact me directly at jcarvaja@laguiadelnetworking.com I will fix your problem ASAP. Cheers, Julio Carvajal Segura http://laguiadelnetworking.com
New Member

Redistributing RIP & BGP but unable to get routes

Hi Imediavilla,

Thanks a lot now i am able to ping my loopback to loopback IPs which was initially not happen as i have configure no auto summary in RIP of my CE its working & on PE R2 im getting all BGP routes.

Aside All Thanks for your suggestions

Regards

Neeraj

658
Views
0
Helpful
5
Replies
CreatePlease login to create content