Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Redistributing Static Route in to BGP

Hi all,

I am having the following doubt in Redistributing static routes into BGP .

Consider eBGP between R2 and R3.

Configurations are :

R2 configs :

hostname R2

ip route 150.1.1.0/24 10.1.1.20

router bgp 100

redistribute static

neighbor 40.1.1.30 remote-as 200

R3 configs :

router bgp 200

neighbor 40.1.1.20 remote-as 100

When I do 'show ip bgp' in R3, it shows as below :

*> 150.1.1.0/24 40.1.1.20 100 100 ?

My doubt is why it is showing the route as incomplete (?), Won't it be 'e' because it got that route from ebgp neighbor R2. Correct me if I am wrong.

Thanks,

Vijaybabu

7 REPLIES

Re: Redistributing Static Route in to BGP

Hi,

the ? refers to the origin code, which can have 3 values:

i - IGP, i.e. a network statement under router bgp was configured

e - EGP, this is NOT eBGP, but a previous protocol (Exterior Gateway Protocol) not in use today

? - incomplete, i.e. it was included into the BGP table through redistribution

This means everything is fine and as it should be in your case.

Hope this helps! Please rate all posts.

regards, Martin

New Member

Re: Redistributing Static Route in to BGP

Hi Martin,

Thanks for explanation.

what will be the case if it's learned from eBGP ?

Thanks,

Vijaybabu

Re: Redistributing Static Route in to BGP

Hi,

the origin code is set by the router originally inserting the network into the BGP table. During this process you can modify the origin code with a route-map.

The origin code does not depend on the way it is learned (iBGP or eBGP). Routes that were sent at least once through an eBGP session can be seen from the fact, that the AS path is not empty. The complete "story" can be seen from "show ip bgp ". There you will get a statement which either tells you "internal" (learned through iBGP) or "external" (learned through eBGP).

Hope this helps! Please rate all posts.

Regards, Martin

New Member

Re: Redistributing Static Route in to BGP

Hi Martin,

I have one doubt, you said all redistributed routes will come as '?'. But when I redistributed 'connected' routes , it showing as below :

R2 config:

---------

router bgp 100

redistribute connected

neighbor 40.1.1.30 remote-as 200

R3 config:

------------

router bgp 200

neighbor 40.1.1.20 remote-as 100

Show ip bgp in R3

-----------------

Network Next Hop Metric LocPref

Path

*> 10.1.1.0/24 40.1.1.20 100 100 i

* 40.1.1.0/24 40.1.1.20 100 100 i

*> 101.101.101.20/32 40.1.1.20 100 100 i

As you said, it should come as '?'. Correct me if I am wrong .

Thanks,

Vijaybabu

Hall of Fame Super Bronze

Re: Redistributing Static Route in to BGP

As Martin stated, it should come as '?' when doing redistibuted connected under the BGP process, unless you have a route-map altering the origin.

Can we see a larger portion of the config ?

Here is mine:

Router 1:

router bgp 2

no synchronization

bgp log-neighbor-changes

redistribute connected

redistribute static

neighbor 172.25.1.1 remote-as 1

neighbor 172.25.1.1 ebgp-multihop 10

default-information originate

no auto-summary

#sh ip int brief

Interface IP-Address OK? Method Status Protocol

FastEthernet0/0 192.168.66.1 YES NVRAM up up

Serial0/0 172.25.1.2 YES NVRAM up up

Loopback0 10.40.1.1 YES NVRAM up up

Loopback1 10.45.1.1 YES NVRAM up up

Loopback2 10.50.1.1 YES NVRAM up up

Loopback3 10.55.1.1 YES NVRAM up up

Router 2:

#sh ip bgp

BGP table version is 63, local router ID is 199.21.21.1

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path

*> 0.0.0.0 172.25.1.2 0 0 2 ?

*> 10.40.0.0/16 172.25.1.2 0 0 2 ?

*> 10.45.0.0/16 172.25.1.2 0 0 2 ?

*> 10.50.0.0/16 172.25.1.2 0 0 2 ?

*> 10.55.0.0/16 172.25.1.2 0 0 2 ?

*> 10.150.1.0/24 172.25.1.2 0 0 2 ?

Please rate helpful posts.

Thanks

New Member

Re: Redistributing Static Route in to BGP

Hi Edison,

Thanks for your extensive help.

I have one more doubt, how learning routes from any IGP(though it happens only because of redistribution) show as 'i' ? it shud come as '?'. correct me if I am wrong.

Kindly, can you post me samples containing 'i' routes in 'show ip bgp ' output.

Thanks,

Vijaybabu

Hall of Fame Super Bronze

Re: Redistributing Static Route in to BGP

I believe you are confusing IGP with iBGP.

IGP = EIGRP, OSPF, RIP and the others.

iBGP = Internal BGP, BGP peers sharing the same AS.

Only with iBGP learned routes you will see the 'i'.

Please rate helpful posts.

Thanks

1058
Views
10
Helpful
7
Replies
CreatePlease login to create content