Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Redistributing statics into EIGRP for backup path

(see the attached network diagram)

Senario:

You're network is connected to a vendor's network. You have a primary and secondary link to the vendor network. The secondary link is connected to the vendor network through your secondary site. You are running EIGRP for your main network (primary and secondary locations). You would like to inject static routes to the networks you need to access in the vendor's network. You are thinking about also using a floating static on your primary and secondary routers connected to the vendor.

Any suggestions for the best approach?

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Blue

Re: Redistributing statics into EIGRP for backup path

Brandon

I think we still may be talking at cross purposes.

If you use floating statics on the secondary router the routes will NEVER be used unless the primary fails. An example -

Primary router

==============

ip route 160.20.40.0 255.255.255.0 10.99.0.68

Secondary router

================

ip route 160.20.40.0 255.255.255.0 10.99.0.68 250 <--- Notice the 250 here - this is the AD (Adminstrative Distance)

On both routers you add this under your eigrp config

router eigrp 1

redistribute static

So why don't you need metric's ?

The primary router redistributes the above static into EIGRP. When a route is redistributed into EIGRP it gets an AD of 170.

So the secondary router receives a route from the primary for 160.20.40.0/24 with an AD of 170. It also has a locally configured static route with an AD of 250. So it uses the route received from the primary router. It's own locally configured static is not used, not installed in the routing table and therefore never redistributed.

So the secondary router only has one route to 160.20.40.0/24 and that is via the primary router.

So this is why you don't need metrics because the only active route for 160.20.40.0/24 is via the primary router.

If the primary router fails then it stops advertising the 160.20.40.0/24 network. Because the secondary router no longer receives the route it now uses it's locally configured static to 160.20.40.0/24 which has an AD of 250. It's installs this in it's routing table and then redistributes it into EIGRP. So now all devices in your LAN see the path to that network via your secondary router.

If the primary router comes back up it's static route will be used again because it has a better AD.

Does this make sense ? Is this not what you tested in your lab ?

Jon

53 REPLIES
Hall of Fame Super Blue

Re: Redistributing statics into EIGRP for backup path

Brandon

There are a number of ways to do this. Just to clarify

1) You are looking to add static routes for vendor networks to primary router and secondary router ?

2) if 1) is correct are you then proposing to redistribute these statics into EIGRP ?

3) Where does the idea of using floating statics come in ? - is that for use on the secondary router.

4) Do you need all L3 devices within your network to see the primary router as the way to go to the vendor network ie. is it just the L3 switches or is the L3 switches and the backup router ?

Jon

Community Member

Re: Redistributing statics into EIGRP for backup path

Hi Jon,

Thanks for your reply.

1) I am looking at adding static routes on the primary and secondary router ( to redistribute into EIGRP with a route-map and tag) to access the networks in the vendor's network.

2) Yes proposing to redistribute into EIGRP.

3) Not really sure, I am up for suggestions on this, but yes initially for use on the secondary router.

4) I think I would like to use the primary router for the path first from both the L3 switches and the backup router, but I am also up for suggestions on this.

I have a home lab I can lab-up the senario this evening if you have some suggestions to try.

Thanks,

Brandon

Hall of Fame Super Blue

Re: Redistributing statics into EIGRP for backup path

Brandon

If you want to have all the devices use the primary router then i would suggest

1) Configure statics on primary router eg.

ip route 160.20.54.0 255.255.255.0 50.50.50.2

2) COnfigure statics on secondary router but use an AD of > 170 ie.

ip route 160.20.54.0 255.255.255.0 50.50.50.6 250

3) Then under each eigrp config on both primary and secondary routers

router eigrp

redistribute static

What should happen is that the primary router redistributes it's statics into EIGRP. The secondary router receives them and because the AD of external EIGRP routes is 170 this AD is less than 250 floating statics. So it uses the primary router routes.

If the primary router goes down then it will stop advertising the statics, the secondary router should then use it's floating statics and redistribute these into EIGRP.

Jon

Community Member

Re: Redistributing statics into EIGRP for backup path

Hi Jon,

I'll try this this evening. So no real need to use a route-map to inject (redistribute)the statics into EIGRP? I guess if I did use a route-map it would essentially be the same, but without the redistribute static under the EIGRP process, huh?

Thanks,

Brandon

Hall of Fame Super Blue

Re: Redistributing statics into EIGRP for backup path

Brandon

You may want to use a route-map if you are looking to tag routes or limit which statics you want redistributing.

Jon

Community Member

Re: Redistributing statics into EIGRP for backup path

Jon,

Attached is a config for the primary and secondary routers. Please feel free to shoot holes at it.;-)

Thanks,

Brandon

Hall of Fame Super Blue

Re: Redistributing statics into EIGRP for backup path

Brandon

I'm a bit confused. Could you explain what you are trying to as this is not what we werer talking about, which is fine, but i just need to understand how this will work.

Jon

Community Member

Re: Redistributing statics into EIGRP for backup path

disregard

Community Member

Re: Redistributing statics into EIGRP for backup path

Hi Jon,

You can see the configs that would be on the primary and seconday routers.

We are taking the following routes (to the vendor network) and re-distributing them into EIGRP. Is the config not accurate?

ip route 160.20.50.0 255.255.255.0 50.50.50.8

ip route 160.20.40.0 255.255.255.0 50.50.50.8

ip route 160.20.30.0 255.255.240.0 50.50.50.8

ip route 160.20.20.0 255.255.240.0 50.50.50.8

Thanks,

Brandon

Hall of Fame Super Blue

Re: Redistributing statics into EIGRP for backup path

Bradon

I can't see 50.50.50.8 on your jpg. The 2 routes to the vendor network on your jpg are

primary -> 50.50.50.2

secondary -> 50.50.50.6

what am i missing :-)

Jon

Community Member

Re: Redistributing statics into EIGRP for backup path

Oh, Let me see if I am leaving something out.

Thanks

Community Member

Re: Redistributing statics into EIGRP for backup path

Jon,

I left some stuff off. See if this diagram makes sense?

Thanks,

Brandon

Hall of Fame Super Blue

Re: Redistributing statics into EIGRP for backup path

Brandon

Can you have a quick read of the posts between myself and Richard. It's unclear how far EIGRP extends ie. is it running between your primary router and the vendor business router and likewise for the secondary router.

Also it looks like you are using a next hop that is not connected to either of your routers ie. 50.50.50.8 is not on either vendor/business router ? So how would your routers know how to get to that address ?

Sorry for all the questions but we need to understand fully before we can give you an answer.

Jon

Community Member

Re: Redistributing statics into EIGRP for backup path

Brandon,

If you are running EIGRP then why redistribute routes within EIGRP? Shouldn't the routes already redistribute automatically by DUAL? If I understand what you are wanting, you want your primary route outside your network for all users (at primary site and secondary site) to be through your primary router (10.10.10.1). You also want there to be a feasible successor to the outside through your secondary router (10.20.1.1). The advantage of this will allow no outage experienced by the user when the primary site goes down (EIGRP doesn't take the route in to active because there is a FS). Is that correct?

Richard

Hall of Fame Super Blue

Re: Redistributing statics into EIGRP for backup path

Richard

I think that EIGRP is not running between the Vendor and Brandon's network so the Vendor networks are not being advertised to the primary router and the secondary router.

If EIGRP is running between Brandon's network and the Vendor network then i agree with what you say.

Jon

Community Member

Re: Redistributing statics into EIGRP for backup path

Jon,

Understood. With that part of the config missing from the attachement (routing protocol for the 50.x.x.x net) I guess it is assumed to be constant and advertised. Having said that, since it is assumed that 2 routing processes are running on the 2 routers (10.10.x.x and 10.20.x.x), I would assume that they are redistributing between them. With the connections to the vendor sites (on both routers) being done on fastethernet I would also assume that DUAL would see the alternate path as a feasible successor without any manipulation. The problem, or manipulation needed, comes from forcing the secondary site users to use the route through the primary site instead of the directly attached vendor.

Am I tracking correctly or am I muddying the waters?

Richard

Hall of Fame Super Blue

Re: Redistributing statics into EIGRP for backup path

Richard

Must admit i'm a bit confused. I can't see 2 routing processes on the routers even though there is mention of it in the route-maps. On both routers there is only "router eigrp 1" so i'm unclear as to what it means in the route-map config -

route-map vendor permit 10

description ***Redistribute static into eigrp 20***

match tag 20

My understanding was that EIGRP ran between primary router -> L3 switch -> L3 switch -> secondary router but did not extend to the vendor/business partner routers.

"Am I tracking correctly or am I muddying the waters?"

Not sure, it may well be you are understanding this better than i am ! Guess we'll have to wait on Brandon :-)

Jon

Community Member

Re: Redistributing statics into EIGRP for backup path

Hi Jon,

I'll try to make things more clear. Sorry for muddying things.

EIGRP is running just like you said:

EIGRP is only running between primary router -> L3 switch -> L3 switch -> secondary router but did not extend to the vendor/business partner routers.

Jon,

What do you mean by:

"I can't see 2 routing processes on the routers even though there is mention of it in the route-maps."

Thanks,

Brandon

Hall of Fame Super Blue

Re: Redistributing statics into EIGRP for backup path

Brandon

You have these comments in your config -

primary router

==============

route-map vendor permit 10

description ***Redistribute static into eigrp 10***

match tag 10

but i can't see an EIGRP 10 process anywhere.

That aside try this config

primary router -

ip route 160.20.50.0 255.255.255.0 50.50.50.2

ip route 160.20.40.0 255.255.255.0 50.50.50.2

ip route 160.20.30.0 255.255.240.0 50.50.50.2

ip route 160.20.20.0 255.255.240.0 50.50.50.2

router eigrp 1

redistribute statics

secondary router

================

ip route 160.20.50.0 255.255.255.0 50.50.50.6 250

ip route 160.20.40.0 255.255.255.0 50.50.50.6 250

ip route 160.20.30.0 255.255.240.0 50.50.50.6 250

ip route 160.20.20.0 255.255.240.0 50.50.50.6 250

router eigrp 1

redistribute static

Jon

Community Member

Re: Redistributing statics into EIGRP for backup path

Oh,

description ***Redistribute static into eigrp 10***

The 10 is referencing the matched tag number.

Brandon

Community Member

Re: Redistributing statics into EIGRP for backup path

Brandon,

What protocol are you using to connect to the vendor sites on both sides of your network (primary and secondary)?

Richard

Community Member

Re: Redistributing statics into EIGRP for backup path

Hi Richard,

I am intending to use static routes on the primary and secondary routers that will be redistributed into EIGRP process 1. There is only one EIGRP process running on the primary and secondary ( and the L3 switches connecting the primary and secondary site)and only referencing the business network (10.0.0.0). Static routes to the vendor network will be redistributed into the EIGRP process 1.

Is this what you mean?

Thanks,

Brandon

Community Member

Re: Redistributing statics into EIGRP for backup path

Hi Jon,

I put together a more detailed diagram that may help.

Thanks,

Brandon

Hall of Fame Super Gold

Re: Redistributing statics into EIGRP for backup path

I am looking at the new diagram and there are several things that do not seem to make sense to me. The primary router is marked as 50.50.50.1/50.50.50.1HSRP and the secondary router is marked as 50.50.50.3/50.50.50.1HSRP. Are they both connected on a layer 2 VLAN running through the vendor network?

Also the VLAN at the primary site is marked as 10.10.0.0/24 but the interface on the primary router is 10.10.1.1 which is in a different subnet. Similarly at the secondary location the VLAN is marked as 10.20.0..0/24 while the router interface is 10.20.1.1 (again a different subnet).

What I am seeing so far it looks to me like the suggestion of a static route on the primary router and a floating static on the secondary router should work.

HTH

Rick

Community Member

Re: Redistributing statics into EIGRP for backup path

Rick,

Sorry,

that should listed as 10.10.1.0/24 for the vlan at then primary, and 10.20.1.0/24 at the secondary site. Yes there is a L2 vlan for the HSRP running through the vendor switch.

Thanks,

Brandon

Hall of Fame Super Gold

Re: Redistributing statics into EIGRP for backup path

Brandon

Thanks for the clarification. having taken a closer look at the config I have a couple of other comments.

The interface configuration of both routers shows the subnet/VLAN as a /29:

ip address 50.50.50.1 255.255.255.248

but if this is the case then 50.50.50.8 is the subnet address of the next subnet and not a host address. Therefore it is not an appropriate next hop in the static routes.

Also both routers have a floating default route with the next hop of 50.50.50.8 and the same administrative distance. I would have thought that the AD of the primary router would be better/lower than the AD of the secondary router.

Another thought is that if you made the static routes to the vendor on the secondary router to be floating static routes then it means that these routes get into the routing table only when the primary routes have failed. The way it is configured now the secondary router will have those static routes in its routing table and if any packet happened to come to it, the packet would be forwarded to the vendor by the secondary router rather than forwarding it to the primary - which is what I understand the desired behavior to be.

HTH

Rick

Community Member

Re: Redistributing statics into EIGRP for backup path

Rick,

Thanks for your reply. I'll post a new diagram soon with correct addressing. Initially when I posted I was thinking that maybe only posting part of the diagram and sanitizing the addressing would be enough. I was very wrong. What I'll do is post a new diagram soon that more reflects the addressing being used. I threw the previous diagram together and with the wrong subnetmask info.

Thanks,

Brandon

Community Member

Re: Redistributing statics into EIGRP for backup path

Rick & Jon,

I am posting here now a 4th network diagram. I really appreciated all the feedback and suggestions you have given.

We will call the business site your corporate network side. On your corporate network side you have many subnets under the major 10.0.0.0 network.

At the coporate primary site we will call 10.10.1.x/24 vlan 1, and at the corporate secondary site we will call 10.20.1.x/24 vlan 1. At both the primary and secondary corporate sites there are for example:

primary site:

vlan 2 - 10.10.2.x/24

vlan 3 - 10.10.3.x/24

vlan 4 - 10.10.4.x/24

etc... with many more vlans following this same scheme.

secondary site:

vlan 2 - 10.20.2.x/24

vlan 3 - 10.20.3.x/24

vlan 4 - 10.20.4.x/24

etc... with many more vlans following this same scheme.

You are running 1 EIGRP accross your corporate enterprise for the major network 10.0.0.0.

You are considering re-disrtibuting static routes to the vendor networks into your EIGRP process.

Vendor networks will be:

160.20.50.0/24

160.20.60.0/24

160.50.70.0/24

etc...

HTH & Thanks!

Brandon

Hall of Fame Super Blue

Re: Redistributing statics into EIGRP for backup path

Brandon

From the diagram i still think the best approach is floating statics unless Rick spots anything i am missing ?

So to update config -

primary router -

ip route 160.20.50.0 255.255.255.0

10.99.0.68

ip route 160.20.40.0 255.255.255.0 10.99.0.68

ip route 160.20.30.0 255.255.240.0 10.99.0.68

ip route 160.20.20.0 255.255.240.0 10.99.0.68

router eigrp 1

redistribute statics

secondary router

================

ip route 160.20.50.0 255.255.255.0 10.99.0.68 250

ip route 160.20.40.0 255.255.255.0 10.99.0.68 250

ip route 160.20.30.0 255.255.240.0 10.99.0.68 250

ip route 160.20.20.0 255.255.240.0 10.99.0.68 250

router eigrp 1

redistribute static

The secondary router statics will only be used if the primary router fails.

Jon

291
Views
4
Helpful
53
Replies
CreatePlease to create content