cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
735
Views
6
Helpful
8
Replies

Redistribution Issue between EIGRP & BGP protocols

mirzaakberali
Level 1
Level 1

Hello GS,

I am looking to configure Redistribution between EIGRP & BGP Protocol.

Current scenario:-

Core Switch: Only configured with EIGRP for ATM 2MB link.

WAN Router : Configured with EIGRP for ATM link and BGP for MPLS 10mb link .

Due to this All Traffic from my Core switch ( all sub nets) goes via ATM 2mb link instead of 10MB MPLS link.

I am looking forward to configure BGP on Coreswitch and perform Redistribution on WAN router for both EIGRP & BGP protocols.

Please suggest if the below commands are sufficient .

Configuration:-

Core switch:-

Router eigrp 1

passive-interface default

no passive-interface Vlan1

no passive-interface Vlan250

no passive-interface Vlan253

network 10.0.0.0

neighbor 10.8.254.16 Vlan1

distribute-list 1 in Vlan253

distribute-list 1 in

auto-summary

eigrp router-id 10.8.222.2

Router BGP 8

bgp log-neighbor-changes

neighbor 10.241.8.2 remote-as 6451X

neighbor 10.241.8.2 update-source GigabitEthernet0/3

!

address-family ipv4

neighbor 10.241.8.2 activate

no auto-summary

WAN Router :-

router eigrp 1

passive-interface default

no passive-interface GigabitEthernet0/1

no passive-interface GigabitEthernet0/2

no passive-interface GigabitEthernet0/3

no passive-interface ATM1/0

no passive-interface ATM1/0.1

no passive-interface ATM1/0.2

redistribute bgp 1 metric 10000 1 255 1 1500

network 10.8.99.1 0.0.0.0

network 10.241.0.0 0.0.255.255

network 10.0.0.0

no auto-summary

eigrp router-id 10.8.222.3

!

router bgp 8

bgp log-neighbor-changes

neighbor 10.241.8.2 remote-as 6451X

neighbor 10.241.8.2 update-source GigabitEthernet0/3

redistribute eigrp 1

!

address-family ipv4

neighbor 10.241.8.2 activate

no auto-summary

no synchronization

network 10.8.0.0 mask 255.255.255.0

Now by how can i configure Core switch so that Traffic should only take via BGP path as it is having higher bandwidth and also redundancy should work.

Thanks,

Mirza.

8 Replies 8

Giuseppe Larosa
Hall of Fame
Hall of Fame

Hello Mirza,

if I correctly understood your post you are trying to add an eBGP session on the core router.

two notes:

a) you may need to add ebgp-multihop if they (core and MPLS router ) are not directly connected.

neighbor 10.241.8.2 ebgp-multihop 2

b) a BGP session to be added needs configuration on both sides.

So if MPLS router is administered by SP you should ask them to add an eBGP session with the core switch.

Hope to help

Giuseppe

Hello Giuseppe,

Thanks for your post.

My BGP works perfectly fine from WAN Router which is a branch location and talk to our HQ BGP network.

Similarly WAN router at my branch location is running fine with EIGRP and talks to HQ WAN router.

But as of now Core switch is only running with EIGRP protocol and hence all the sub nets of core switch uses the EIGRP path.

Hence i want to configure BGP on my Core swich and configure Redistribution between EIGRP and BGP protocols vice versa on WAN router at branch office.

Also i want know how to perform a Auto failure between BGP and EIGRP protocols.

I want all the traffic should use BGP as it is having 10MB MPLS link.

Thanks,

Mirza.

Hello Mirza,

so if I understood your topology:

HQ

link1

HQ MPLS router --- MPLS 10 Mpbs --- BR WAN router

using BGP

link2

HQ WAN router --- ATM 2Mbps --- BR WAN router

the in HQ:

Core switch--- LAN ==== MPLS HQ, WAN HQ

and core switch with EIGRP only prefers WAN router because it sees internal EIGRP routes when compared to external EIGRP routes that are injected by MPLS HQ router as a result of redistributing BGP routers into EIGRP.

Possible solutions for this include:

a) using two EIGRP processes on HQ WAN router so that it sends out external EIGRP routes (with an higher seed metric so that routes via MPLS HQ router are preferred).

HQ WAN and BR WAN ca use EIGRP 12

router eigrp 12

network ...

no auto-summary

redistribute eigrp 1 route-map hqroutes

router eigrp 1

red eigrp 12 metric 10000 100000 255 1 1500

b)

HQ WAN router may use ip eigrp 1 summary-address to advertise a less specific route

int typex/y

desc lan interface to core

ip summary-address eigrp 1 10.10.0.0 255.255.0.0 180

in this way most specific external routes even if with a greater AD are used if present.

To be noted the two solutions can even be deployed together.

adding BGP to core would help only if you can deploy a real eBGP session, otherwise AD is 200 even higher then 170 (AD of D EX EIGRP external routes).

on the branch side it should prefer the eBGP MPLS link because the router is only one and eBGP AD is 20 < EIGRP AD (90 for internal, 170 for external routes as it happens with sol. a))

Hope to help

Giuseppe

Hello Giuseppe,

Thanks for your post again!

Let me further add about my current network and my requirement.

Head Quarter :-

Core switch : running with EIGRP & BGP Protocol.

WAN Router is running with EIGRP & BGP.

HQ subnet is 10.1.1.0

To prefer traffic on BGP path at HQ location we have configured more specific routes under BGP.

ex: router BGP 1

network 10.1.101.0 0.0.0.255

network 10.1.102.0 0.0.0.255

&

under EIGRP we configured as

router eigrp 1

network 10.1.0.0

no auto-summary

Both HQ & BR loc links are connected to ISP and they are not point-point.

BR location:

Currently Core switch is only configured with EIGRP & WAN router at BR loc is configured with EIGRP & BGP.

Since BGP is not known to Coreswitch , Subnets( L3 vlans) configured on this will not use BGP link which is having higher Bandwidth.

I just need the two things ..one traffic from Core switch at BR loc should use BGP path and second is auto failure should happen incase of MPLS link failure.

For which i have shared the configuration, please let me know what all i need to add up more.

Once again appreciate your support on this.

Thanks,

Mirza.

Hello GS,

Can any one please advise on my below Query.

Thanks,

Mirza.

Hello Mirza,

so branch site has both a core switch and a BGP router.

I guess the 2Mbps link is directly between HQ core switch to BR core switch.

HQ core switch should use ip summary-address eigrp 1 10.0.0.0 255.0.0.0 250

the command has to be applied in interface config mode and provides a 10/8 prefix with suppression of more specific routes out the interface where it is applied.

for example to send less specific routes to BR core switch.

doing this should be enough even without adding BGP to BR core switch it should use the more specific routes result of redistribution of BGP routes into EIGRP at BR MPLS/BGP router.

Even using two EIGRP processes at BR core switch wouldn't help as routes coming from 2Mbps link would be considered EIGRP routes in any case but it may be considered to make working routing at HQ to BR direction.

Hope to help

Giuseppe

Hello Giuseppe,

Looks like i could not able to convey my requirement and about my current network.

HQ Loc- All Links are terminated at WAN Router.

BR loc : both MPLS n ATM links are terminated on single WAN Router .

Bcoz of this traffic from BR Core switch is only use ATM ( eigrp) path as only EIGRP configured on the BR core switch & BR Core both eigrp & MPLS is configured.

All the L3 vlans created on the BR Core switch uses the EIGRP path.

As EIGRP is 2mb & MPLS is 10 MB i want to configure BR Core switch also BGP and

Redistribute on BR WAN router.

So that all traffic at BR Core switch should use the MPLS path instead of ATM path.

I am really sorry for not explaining

properly in my above posts.

AT HQ both EIGRP and MPLS is configured on WAN router and Core switch.

Thanks,

Mirza.

Hello Mirza,

I wish I would have asked you a network diagram.

First of all, unless you have an iBGP connection over the MPLS link you should already use it.

Whatever choice the BR core switch does it has no direct links to HQ so it has to send traffic to BR WAN router.

Let me read again your config template.

Edit:

please post a network diagram

and configuration of branch WAN router and core switch.

It looks like you have one or two eBGP sessions on the HQ side and they should be preferred over EIGRP also on the branch side specially if only BR WAN router terminates both MPLS link and ATM link.

also may you specify if this is a L3 MPLS VPN service or a L2 MPLS VPN service like EoMPLS.

all this to minimize the number of iterations.

Hope to help

Giuseppe

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Innovations in Cisco Full Stack Observability - A new webinar from Cisco