Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Reduce the size of the routing table

Hello,

I have hub router with various spokes on serial links to other networks in the same AS number, but off this hub router I have a fa link to a RIP to network.  The RIP network has a large routing table but all route back to this hub, can I advertise a default route or do something elase to keep it dynamic?

Hub

interface FastEthernet0/0

ip address 15.1.1.1 255.255.255.252

duplex auto

speed auto

!

interface Serial0/0

ip address 172.12.123.1 255.255.255.0

encapsulation frame-relay

no ip split-horizon eigrp 100

no ip split-horizon eigrp 40

clock rate 2000000

frame-relay map ip 172.12.123.2 122 broadcast

frame-relay map ip 172.12.123.3 123 broadcast

no frame-relay inverse-arp

router eigrp 100

variance 2

redistribute connected

redistribute rip metric 100 100 255 1 1500

network 1.1.1.1 0.0.0.0

network 10.10.10.0 0.0.0.255

network 172.12.123.0 0.0.0.255

no auto-summary

!

router rip

version 2

redistribute connected metric 1

redistribute eigrp 100 metric 2

network 15.0.0.0

no auto-summary

!

Rip Spoke network

interface FastEthernet0/0

ip address 15.1.1.2 255.255.255.252

duplex auto

speed auto

!

router rip

version 2

network 5.0.0.0

network 15.0.0.0

no auto-summary

I guess I could just add a default route on the RIP router and remote the RIP router config.

Thanks

4 REPLIES
Hall of Fame Super Silver

Re: Reduce the size of the routing table

There are several things in this config that puzzle me. And I can not be sure how they might relate to the question that you are asking about reducing the size of the routing table.

- the split horizon configurations mention both eigrp 40 and 100. But the config has only 100. What is eigrp 40? What does it do? How does it relate to this network?

- router eigrp configuration has network statements for networks 1.1.1.1 and for 10.10.10.0 but no interfaces with these addresses. So what are these addresses and how do they relate to this network?

Given what you have described I believe that you do not need to redistribute eigrp into rip. There is no need to advertise the eigrp learned routes out to the RIP spoke. You just need to be sure that the RIP spoke has a default route pointing back to the hub. It is more difficult to determine what needs to be done on the hub router in terms of the RIP networks. One alternative could be to continue to run RIP on the hub router so that it dynamically learns the routes from the spoke, and perhaps redistributes them into eigrp so that the other spokes learn the networks from the RIP side. Or perhaps you could configure a static route that summarizes the RIP routes and just redistribute that into eigrp so that the eigrp spokes are aware of that network.

HTH

Rick

New Member

Reduce the size of the routing table

Sorry to confuse you, it was my fault as the 1.1.1.1 is just a loopback I'm advertising to other networks and the eigrp 40 is an old network I was testing with that hung off another eigrp spoke.

Just another question, on another network a site is OSPF and has a spoke that is connected to area 0 via a virtual link, I want to make it a totally stub area to reduce the routing table, but I can't if it is a virtual link, so what options do I have?

Hall of Fame Super Silver

Reduce the size of the routing table

The option that comes to mind would be to configure a GRE tunnel from the spoke to a router that does have an area 0 connection. You could then configure the spoke as being in its own totally stub area. From a technical perspective I know that this would work. Whether it would achieve what you really want, and how it would change traffic flows is something that you will need to evaluate as you decide whether this is a good option for you.

HTH

Rick

Hall of Fame Super Gold

Re: Reduce the size of the routing table

Large how much? Even some hundreds is not really a "large" number.

Or remove RIP, and configure a static route.

522
Views
0
Helpful
4
Replies
CreatePlease login to create content