Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Redundant fiber connection

Is is possible to setup two incoming fiber links from a 6509 to a 3750. The goal is to setup a redundant fiber link should 1 gbic go bad (example). Is what I am describing GB ether channeling? Seems like this would create a spanning tree loop and yet it seems this should be possible. Any thoughts appreciated!

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Redundant fiber connection

6 REPLIES
Hall of Fame Super Silver

Re: Redundant fiber connection

Hello Daniel,

if you don't configure them on both ends to be part of an etherchannel STP will block one link.

STP is able to deal with link redundancy and technically it is better to speak of bridging loops because STP has been thouoght to avoid them.

if both are fiber links you can bundle them you will get redundancy and more bandwidth.

Hope to help

Giuseppe

New Member

Re: Redundant fiber connection

Thanks for the quick response!

For clarification: Are you saying I should only set the ether-channel up on one end for each fiber? Does it matter which end (3750 or 6509)that I set it up on?

Re: Redundant fiber connection

Re: Redundant fiber connection

You could create an etherchannel which "bonds" them together creating a 2 gig channel. If a link fails, the channel stays up because it still has one good link left. From a spanning tree perspective, it's a single link. You can also run to separate fiber cables and have spanning tree block one of them, preventing a loop. If the active one fails, the other will become active and forward traffic. In the second scenario there could be a small outage as STP converges.

Hope that helps.

Re: Redundant fiber connection

////////6509////////

interface GigabitEthernet10/10

no ip address

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

spanning-tree portfast disable

channel-group 25 mode on

interface GigabitEthernet11/10

no ip address

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

spanning-tree portfast disable

channel-group 25 mode on

interface Port-channel25

no ip address

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

//////ON 3750////////

interface Port-channel1

switchport trunk encapsulation dot1q

switchport mode trunk

interface GigabitEthernet1/0/49

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode on

spanning-tree portfast disable

interface GigabitEthernet1/0/50

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode on

spanning-tree portfast disable

New Member

Re: Redundant fiber connection

Thanks to all who responded. Applied this weekend and it's working out very well. Appreciate the help!

224
Views
8
Helpful
6
Replies
CreatePlease to create content