Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Redundant Internet connections on 1812 router

I am trying to set up a 1812 router with 2 internet connections. One is a cable connection with DHCP and the other is DSL with static IP addresses. Neither ISP supports BGP for me.

I have looked at this link (http://www.cisco.com/en/US/tech/tk648/tk361/technologies_configuration_example09186a00808d2b72.shtml) but I'm still having some trouble figuring out what to do with the set up in my situation.

Any help on this would be appreciated.

5 REPLIES
Hall of Fame Super Gold

Re: Redundant Internet connections on 1812 router

Hi, you can start with a simpler configuration:

http://www.cisco.com/en/US/tech/tk648/tk361/technologies_configuration_example09186a0080950834.shtml

Then when is working you add OER, firewall, etc, as needed.

New Member

Re: Redundant Internet connections on 1812 router

Thanks. That link makes a little more sense. The dialer interface has me a little off, but hopefully I can do something with that.

Hall of Fame Super Gold

Re: Redundant Internet connections on 1812 router

If you don't have PPP, don't configure dialer. You might have to configure a BVI instead.

New Member

Re: Redundant Internet connections on 1812 router

This is what I have. Am I following this correctly?

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname 1812Router

!

boot-start-marker

boot-end-marker

!

logging buffered 51200 warnings

!

no aaa new-model

!

resource policy

!

!

!

ip cef

!

!

!

!

interface FastEthernet0

ip address 1.2.3.4 255.255.255.248

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

!

interface FastEthernet1

ip address dhcp

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

!

interface BRI0

no ip address

encapsulation hdlc

shutdown

!

interface FastEthernet2

!

interface FastEthernet3

!

interface FastEthernet4

!

interface FastEthernet5

!

interface FastEthernet6

!

interface FastEthernet7

!

interface FastEthernet8

!

interface FastEthernet9

!

interface Vlan1

description LAN Interface

ip address 192.168.3.254 255.255.255.0

ip nat inside

ip virtual-reassembly

ip tcp adjust-mss 1452

!

!

!

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

ip nat inside source route-map dhcp-nat interface FastEthernet1 overload

ip nat inside source route-map fixed-nat interface FastEthernet0 overload

ip nat inside source static tcp 192.168.3.175 80 1.2.3.4 80 route-map fixed-nat extendable

ip nat inside source static tcp 192.168.3.175 443 1.2.3.4 443 route-map fixed-nat extendable

ip nat inside source static tcp 192.168.3.203 80 1.2.3.5 80 route-map fixed-nat extendable

ip nat inside source static tcp 192.168.3.203 443 1.2.3.5 443 route-map fixed-nat extendable

ip nat inside source static tcp 192.168.3.1 25 1.2.3.6 25 route-map fixed-nat extendable

ip nat inside source static tcp 192.168.3.1 80 1.2.3.6 80 route-map fixed-nat extendable

ip nat inside source static tcp 192.168.3.1 443 1.2.3.6 443 route-map fixed-nat extendable

ip nat inside source static tcp 192.168.3.205 20 1.2.3.7 20 route-map fixed-nat extendable

ip nat inside source static tcp 192.168.3.205 21 1.2.3.7 21 route-map fixed-nat extendable

ip nat inside source static tcp 192.168.3.202 80 1.2.3.7 80 route-map fixed-nat extendable

ip nat inside source static tcp 192.168.3.202 443 1.2.3.7 443 route-map fixed-nat extendable

ip nat inside source static tcp 192.168.3.201 80 1.2.3.8 80 route-map fixed-nat extendable

ip nat inside source static tcp 192.168.3.201 443 1.2.3.8 443 route-map fixed-nat extendable

!

access-list 110 permit ip 192.168.3.0 0.0.0.255 any

no cdp run

!

!

!

route-map fixed-nat permit 10

match ip address 110

match interface FastEthernet0

!

route-map dhcp-nat permit 10

match ip address 110

match interface FastEthernet1

!

!

!

Hall of Fame Super Gold

Re: Redundant Internet connections on 1812 router

Just add:

ip route 0.0.0.0 0.0.0.0

and the static NAT should not need to reference route-map. Actually not even the dynamic nat do, but cisco says otherwise in their examples.

143
Views
0
Helpful
5
Replies
CreatePlease to create content