Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Reestablishing the vpn tunnel when the External IP change

hello all,

I have an issue regarding a setup of a VPN connection betwen tow sites

one site is having a statis IP

the other site is using a 3G modem with a dynamic public IP

i hve attached a brief layout of the setup for more clarification.

i used a GRE tunnel betwen the tow sites and the VPN is working fine.

the only issue i have is that in case the 3G modem public IP change due to a restart or any other reson ,

the VPN is not reestablishing because the ip of the router (10.10.1.2)  is not changing when the public ip of the 3G modem is changing ,

and thus the router keep thinking that the tunnel is up ,

the only solution is manualy having to clear the tunnel  then the new tunnel will establish.

is there any workout to solve this issue

Thank you for the great support

Everyone's tags (1)
3 REPLIES

Reestablishing the vpn tunnel when the External IP change

Hi

from router on 3G side tunnel sousce musst be interface Cellular

interface Tunnel14

ip address 10.x

...

tunnel source Cellular0

tunnel destination 192.168.102.1

tunnel protection ipsec profile vpnprof

on central router

interface Tunnel14

ip address 10.1.x

...

tunnel source 192.168.102.1

tunnel mode gre multipoint

tunnel protection ipsec profile vpnprof

New Member

Reestablishing the vpn tunnel when the External IP change

Thanks for the reply  ttemirgaliyev

i think i made the layout clear that the 3G modem is a seperate device (not a 3G Card)

Thanks again

New Member

Re: Reestablishing the vpn tunnel when the External IP change

after second check on the setup ,

the tunnel is actully re-establishing but the eigrp process is taking too much time ( around 6 minutes ) to form the neighbors relationship and add the networks to the routing table.

*Jun  6 20:16:02.039: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 50: Neighbor 172.16.16.2 (Tunnel0) is down: holding time expired

*Jun  6 20:16:16.119: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 50: Neighbor 172.16.16.2 (Tunnel0) is up: new adjacency

*Jun  6 20:16:16.131: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 50: Neighbor 172.16.16.2 (Tunnel0) is down: Interface Goodbye received

*Jun  6 20:16:16.167: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 50: Neighbor 172.16.16.2 (Tunnel0) is up: new adjacency

*Jun  6 20:16:16.323: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 50: Neighbor 172.16.16.2 (Tunnel0) is down: peer restarted

*Jun  6 20:16:20.963: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 50: Neighbor 172.16.16.2 (Tunnel0) is up: new adjacency

*Jun  6 20:17:07.943: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 50: Neighbor 172.16.16.2 (Tunnel0) is down: holding time expired

any suggestions

472
Views
0
Helpful
3
Replies