Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Regarding EIGRP routing

Hi all,

I have a routing question with regards to EIGRP. Our hd office is connecting to br office via EIGRP. one of my office network is 18.25.0.0/18. My br office network is 18.26.6.0/24. We recently installed a secondary link, I wanted to route the subnet 18.25.5.0/24 from hd office via the secondary link for destination 18.26.6.0/24. So as in Br office the route from 18.26.6.0/24 for 18.25.5.0/24 should be routed via secondary link. I have not enabled any routing on secondary link, and thinking of EIGRP for routing. How to achieve this.

on our wan router in hd office

router eigrp 1

redistribute static

ip route 18.25.0.0 255.255.124.0 172.16.10.13

On our Wan router in br office

router eigrp 1

redistribute static

ip route 18.26.6.0 255.255.255.0 10.152.48.1

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Regarding EIGRP routing

It would be better to use PBR than EIGRP for acheiving this

With EIGRP all traffic to 18.26.6.0 or 18.26.5.0 will use the secondary link if configured but if you need a specific source destination conversation to flow through a particualr link, PBR would be the choice

at HD

access-list 100 permit ip 18.25.5.0 0.0.0.255 18.26.6.0 0.0.0.255

route-map test permit 10

match ip address 100

set ip next-hop

interface

ip policy route-map test

At Branch

access-list 100 permit ip 18.26.6.0 0.0.0.255 18.25.5.0 0.0.0.255

route-map test permit 10

match ip address 100

set ip next-hop

interface

ip policy route-map test

HTH

Narayan

3 REPLIES

Re: Regarding EIGRP routing

It would be better to use PBR than EIGRP for acheiving this

With EIGRP all traffic to 18.26.6.0 or 18.26.5.0 will use the secondary link if configured but if you need a specific source destination conversation to flow through a particualr link, PBR would be the choice

at HD

access-list 100 permit ip 18.25.5.0 0.0.0.255 18.26.6.0 0.0.0.255

route-map test permit 10

match ip address 100

set ip next-hop

interface

ip policy route-map test

At Branch

access-list 100 permit ip 18.26.6.0 0.0.0.255 18.25.5.0 0.0.0.255

route-map test permit 10

match ip address 100

set ip next-hop

interface

ip policy route-map test

HTH

Narayan

Community Member

Re: Regarding EIGRP routing

Hi Narayan,

Thanks for your quick response. This should definetely work.

Taj

Community Member

Re: Regarding EIGRP routing

If you actually want to loadshare the traffic, you can actually use Variance to do unequal cost load balancing.

Incase you have a specific requirement for routing these specific subnets, you can do so by static routing (with floating routes for redundancy).

104
Views
0
Helpful
3
Replies
CreatePlease to create content