Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Resilient Link Configuration

We have 2 site which are currently connected using a layer 2 LES circuit with bandwidth a 1000Mbps.  We trunk specific VLans accross this link for management and resources.  At each end we have Cisco 6509 switches/routers.  We have installed a second gigabit link to use as a backup should there be any issues with the primary circuit. 

The primary link is configured -

interface GigabitEthernet3/6

description *** Primary ****

no ip address

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 303,501,602,1001

switchport mode trunk

spanning-tree vlan 303 cost 10

spanning-tree vlan 501 cost 10

spanning-tree vlan 602 cost 10

spanning-tree vlan 1001 cost 10

The backup link is configured -

interface GigabitEthernet2/1

description *** Secondary ***

no ip address

shutdown

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 303,501,602,1001

switchport mode trunk

spanning-tree vlan 303 cost 20

spanning-tree vlan 501 cost 20

spanning-tree vlan 602 cost 20

spanning-tree vlan 1001 cost 20

There are 2 questions -

1.  Is this the best way to configure the link and use spanning treee to apply the appropriate metric/cost to the link?

2.  If this is the right way to configure the link then why when I enable the link do I get a duplicate IP address message in the log?  It is as though it is seeing the remote site accross both links.

Any help you can provide is appreciated.

ACT

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Re: Resilient Link Configuration

Hello Alex,

the command is effective on non root bridge devices incoming direction from the root bridge sorry if I haven't been clear.

In simple words you need to configure the spanning-tree cost commands on the interfaces of the two C6509 on the remote office and they are not effective on the local node if it is the root bridge.

Moving the second link to another device also in HQ may be a good idea for redundancy  purposes as the interconnections become fault tolerant also at node level not only at link level.

Hope to help

Giuseppe

4 REPLIES
Hall of Fame Super Silver

Resilient Link Configuration

Hello Actkillerby,

if you have applied this configuration templates on interfaces of both C6509 you are fine.

To be noted STP cost to root bridge is calculated in the incoming direction on the root port, so changing the STP port cost per port or per vlan on the port is effective on the device that is not the root bridge and allows to influence its choice of the root port.

So I would check who is the root bridge using

show spanning-tree vlan Y

You could use the port based version of the command

spanning-tree cost XX

that applies to all Vlans permitted on the L2 trunk if your objective is to use one link as primary and one as secondary.

Other options are possible: after having tested the new link you could also think of using an LACP bundle in order to use both links at the same time. This is possible if both links are terminated in the same two C6509 devices. (only two devices involved)

For LACP bundling the two interfaces need to have identical confiiguration including STP commands and then you configure channel-group X mode active where X is the first available group number (unused) as shown in the output of show spanning-tree summary.

To test the new link, the easier way to do it is to make it a routed port (L3 interface)  and to use extensive ping tests. In this way you can qualify the new link.

Hope to help

Giuseppe

New Member

Resilient Link Configuration

Hi Giuseppe

Thank you for the response.  It makes more sense now.

We have 2 x 6509s at the remote location and each of these will have one of the WAN connections terminating in one of the interfaces.  Currently they both connect back to a single 6509 at the local site.  However the local 6509 is the root bridge for all of these vlans and this may be the cause of the issue I am experiencing.  If the STP is calculated on the incoming direction to the root bridge and both WAN links terminate on the same 6509 would this mean that effectivley there is no spanning tree cost on the interfaces?

I can move the secondary to another 6509 on the local site it just means a slight bit more work but is not impossible.  It was always our intention to split the WAN links across 2 x 6509s at both the remote and local sites.

Regards

Alex

Hall of Fame Super Silver

Re: Resilient Link Configuration

Hello Alex,

the command is effective on non root bridge devices incoming direction from the root bridge sorry if I haven't been clear.

In simple words you need to configure the spanning-tree cost commands on the interfaces of the two C6509 on the remote office and they are not effective on the local node if it is the root bridge.

Moving the second link to another device also in HQ may be a good idea for redundancy  purposes as the interconnections become fault tolerant also at node level not only at link level.

Hope to help

Giuseppe

New Member

Resilient Link Configuration

Thanks for your help Giuseppe, that confirms my thinking.

Your help is appreciated.

Alex

735
Views
0
Helpful
4
Replies